はじめに

APC PowerChute Business Edition をインストールして使用する前に、この文書の各項目を必ずお読み下さい。この文書には、主に製品のインストールに関しての情報が記載されており、その他に、運用に関しての情報や、アプリケーションのデータ収集機能、サーバノード数の制限、さらにサードパーティのソフトウェア情報に関しても記載されております。

Copyright © 2002
by American Power Conversion Corp.
www.apc.co.jp
All rights reserved
事前の許可無く本書の一部または全部を複製することを禁じます。
Last updated: September 27, 2002.


インストールの概要

インストール時には、次の作業を行います。

注意：

PowerChute Business Editionをインストールする前に、PowerChute plus、PowerChute Personal Edition、PowerChute Network Shutdownなどの他のPowerChute製品をアンインストールして下さい。

  • PowerChute Business Editionで管理するUPS保護された各コンピュータ上にPowerChute Business Editionエージェントをインストールします。 これらのシステムは、次の各セクションで説明している条件を満たしている必要があります。

    • APCハードウェア要件

    • UPS通信ケーブルの要件

    • PowerChute Business Editionエージェントの要件

      注意:サポートしていないUPSにコンピュータを接続している場合、または間違ったUPS通信ケーブルを使用している場合は、UPSと通信できないためPowerChute Business Editionエージェントを正常にインストールすることはできません。

  • PowerChute Business Editionサーバを、PowerChute Business Editionサーバの要件のOS、プロセッサ、およびメモリ要件を満たすコンピュータ上にインストールします。
  • UPSで保護するシステムを監視するコンピュータにPowerChute Business Editionコンソールをインストールします。 インストールするコンピュータは、「PowerChute Business Editionコンソールの要件」の条件を満たしていなければなりません。
Copyright © 2002


システム要件

PowerChute Business Editionコンポーネントは、以下のOSのコンピュータにインストールすることができます。

  • Windows NT® 4.0 Workstation、Server 4.0 (Service Pack 6a適用済）
  • Windows® 2000 Professional (Service Pack 2適用済)
  • Windows® 2000 Server (Service Pack 2適用済)
  • Windows® 2000 Advanced Server (Service Pack 2適用済)
  • Windows® 2000 Datacenter Server (Service Pack 2適用済)
  • Windows® XP Professional

上記の他に、PowerChute Business Editionエージェントは、Red HatTM Linux® 7.3、Turbolinux® 7 Workstation、 Turbolinux® 7 ServerまたはNetWare® 6.0（Service Pack 1適用済）のコンピュータにインストールすることもできます。最新のサポートOSの情報については、APC Japanホームページ (http://www.apc.co.jp)をご参照下さい。

また、このコンピュータは、TCP/IPネットワークに接続されており、次の各セクションで説明している条件も満たしていなければなりません。

  • PowerChute Business Editionエージェントの要件
  • PowerChute Business Editionサーバの要件
  • PowerChute Business Editionエージェントの要件


PowerChute Business Editionエージェントの要件

PowerChute Business Editionエージェントを使用するには、次のプロセッサおよびメモリ要件を満たしていなければなりません。

注意:
インストールマニュアルおよびリリースノートに記載しているように、PowerChute Business Editionエージェントを、Red Hat Linux 7.3、Turbolinux 7 Workstation、 Turbolinux 7 ServerまたはNetWare 6.0 (Service Pack 1適用済）が動作するコンピュータにインストールすることもできます。

要件 | 最低 | 推奨
プロセッサ | Pentium II 233MHz | Pentium II 333MHz
RAM | 64 MB | 128 MB


PowerChute Business Editionサーバの要件

PowerChute Business Editionサーバを使用するには、次のプロセッサおよびメモリ要件を満たしていなければなりません。

要件 | 最低 | 推奨
プロセッサ | Pentium II 300MHz | Pentium II 400MHz
RAM | 96 MB | 128 MB


PowerChute Business Editionコンソールの要件

PowerChute Business Editionコンソールを使用するには、次の表示要件を満たしていなければなりません。

要件 | 最低 | 推奨
解像度 | 800 x 600 | 1024 x 768 (以上)
表示色数 | 16ビットカラー | 24ビットカラー


APCハードウェア要件

PowerChute Business Editionで使用できるUPSモデルおよびEnvironmental Monitoringデバイスについては、次の各項目を参照して下さい。

  • サポートするUPSモデル
  • UPS通信ケーブルの要件
  • サポートするEnvironmental Monitoringデバイス


サポートするUPSモデル

PowerChute Business Editionエージェントは、シリアル接続の以下のUPSモデルを管理することができます。

  • モデル番号にAPではなくSUが使われているSmart-UPSおよびSmart-UPS XL。

    注意:
    モデル番号はSmart-UPSのバックパネルのバーコードステッカーにあります。 たとえばSU700は、サポートされているSmart-UPS 700を表しています。AP900など、モデル名がAPから始まるものはサポートされていません。

    USB対応Smart-UPSのUSB通信は、Windows 2000、Windows XP上でのみサポートされます。

  • 1996年8月以降製造で、ファームウェアレビジョンが「z」以降のMatrix-UPS。

    注意:
    PowerChute Business Edition AgentのセットアッププログラムがMatrix-UPSを検出した場合、そのUPSはサポートされています。 詳細については、「    Matrix-UPSを認識できない場合」を参照して下さい。

  • Back-UPS。

PowerChute Business Editionエージェントは、Share-UPS 8-Port Interface Expanderや2-Port Interface Expander Cardを介してシリアル接続されているUPSでも、サポートしているモデルならば通信することができます。


UPS通信ケーブルの要件

PowerChute Business Editionエージェントは、通信ケーブルを介してUPSとの通信を行います。通信ケーブルはUPSとPowerChute Business Editionエージェントコンピュータの通信ポート間に接続されます。

UPSモデル | 通信ケーブル
Back-UPS | 940-0020B (シンプルシグナリング)
Matrix-UPS Smart-UPS | 940-0024C (スマートシグナリング)
USB Smart-UPS | 940-0117A
Share-UPS 8-Port Interface Expander | 940-0020B (ベーシックポート接続) 940-0024C (アドバンストポート接続)
2-Port Interface Expander Card | 940-0020B (シンプルシグナリング)


サポートするEnvironmental Monitoringデバイス

PowerChute Business Editionエージェントは、Environmental Monitoring Card (AP9612TH)の管理とステータス レポートを行うことができます。サポートするMonitoringデバイスのファームウェアレビジョンは「P」以降となります。（2000年8月以降製造）


インストール上の問題

PowerChute Business Editionのインストール時に発生する可能性がある問題については、次の各セクションを参照して下さい。

  • PowerChute plusがすでにインストールされている場合
  • インストール時のエラーメッセージ
  • セットアッププログラムがUPSを自動検出できない
  • Matrix-UPSを認識できない場合
  • シリアルポートの設定
  • UPS通信リンク


PowerChute plusがすでにインストールされている場合

PowerChute Business EditionとPowerChute plusを同一コンピュータ上で使用することはできません。 PowerChute Business Editionコンポーネントのインストール時に、そのコンピュータ上にPowerChute plusがインストールされていることが検出された場合、インストールされているPowerChute plusのバージョンに応じて次のいずれかのメッセージが表示されます。

メッセージ | 説明
セットアッププログラムは、PowerChute plusを検出しました。このソフトウェアは、PowerChute Business Editionのセットアッププログラムを実行する前に削除しておく必要があります。 PowerChute plusを削除しますか？ (［いいえ］を選択すると、セットアッププログラムが終了します。) | ［はい］を選択すると、既存のPowerChute plus 5.xがアンインストールされます。［いいえ］を選択した場合は、インストールが中止されます。
セットアッププログラムは、PowerChute plusを検出しました。 この製品をアンインストールしてからもう一度セットアッププログラムを実行して下さい。 | セットアッププログラムは、既存の PowerChute plus 4.xをアンインストールすることはできません。 PowerChute Business Editionコンポーネントをインストールする前に、PowerChute plusをアンインストールする必要があります。


インストール時のエラーメッセージ

PowerChute Business Editionのインストール時に表示される可能性があるメッセージを次に示します。

注意:
この表に記載されている情報を参考にしても問題を解決できない場合は、APCカスタマサポート (http://www.apc.co.jp/sands/)にお問い合わせ下さい。

メッセージ | 説明
UPSサービスを停止できません。 再起動してからもう一度セットアップし直して下さい。 | セットアッププログラムはWindows 2000/ Windows XP 標準UPSサービスを停止できませんでした。 コンピュータを再起動してから、PowerChute Business Editionエージェントを再インストールして下さい。
<エージェント／サーバ>サービスのインストール時にエラーが発生しました。 再起動してからもう一度セットアップし直して下さい。 | PowerChute Business Editionサービスのインストールに失敗しました。 まだPowerChute Business Editionのファイルがインストールされていないこと、およびコンピュータのOSが適切なものかどうかを確認した後(システム要件を参照)、もう一度インストール作業を行って下さい。
次のdllのロード時にエラー<ID>が発生しました:<dllのID> | セットアッププログラムがDLLファイルのロードに失敗しました。 コンピュータのOSが適切なものかどうかを確認し(システム要件を参照)、PowerChute Business Editionエージェントの要件で説明している条件を満たしていることを確認の上、もう一度インストール作業を行って下さい。
必要なリソースのロードに失敗しました。 | PowerChute Business Editionコンポーネントのインストールに必要なリソース(DLLリソース、InstallShieldリソースなど)をロードできませんでした。 コンピュータに十分なメモリがあることを確認してから(システム要件を参照)、もう一度インストール作業を行って下さい。
パスワードが3～16文字でありません。 | 3～16文字のパスワードを使用して下さい。
PowerChute Business Editionをインストール、実行するには管理者権限が必要です。 いったんログオフしてから、管理者権限を持つアカウントを使ってセットアッププログラムを再実行して下さい。 | PowerChute Business Editionコンポーネントをインストールするには、コンピュータに対する管理者権限が必要です。
選択されたパスが有効かどうか判断できません。 ローカルハードドライブ上のディレクトリを選択して下さい。 | PowerChute Business Editionをネットワークドライブ、フロッピーディスクドライブ、zipドライブなどの、ローカルハードディスク以外のドライブにインストールすることはできません。
標準UPSサービスの再起動に失敗しました。電源保護を有効にするには、手動でサービスを再開するか、システムを再起動する必要があります。 | PowerChute Business Editionエージェントをインストールするために停止させたOS標準のUPSサービスを再開することができません。 コンピュータを再起動するか、または手作業でサービスを再開して下さい。
両方のパスワードが一致していなければなりません。 | ［バスワード］と［確認］に入力した内容が一致しないとPowerChute Business Editionコンポーネントをインストールすることはできません。
ユーザ名が3～16文字ではありません。 | 3～16文字のユーザ名を使用して下さい。


セットアッププログラムがUPSを自動検出できない

ここでは、インストールプログラムがシステムUPSの検出に失敗する場合の対処方法について説明していきます。 最新の情報については、APCのWebサイトを確認して下さい。

Windows 2000/Windows XPのシリアル通信に関するヘルプ | http://www.apc.co.jp/direct/pbehelp/commhelp/win2000.html
Windows 2000/ Windows XPのUSB通信に関するヘルプ | http://www.apc.co.jp/direct/pbehelp/commhelp/usb.html
Windows NTのシリアル通信に関するヘルプ | http://www.apc.co.jp/direct/pbehelp/commhelp/winnt.html
Linuxの通信に関するヘルプ | http://www.apc.co.jp/direct/pbehelp/commhelp/linux.html

次のような場合、インストール中に［UPSタイプと通信ポート］画面が表示されます。

  • すべての通信ポートからUPSを検索するかどうかの問い合わせに対して［いいえ］を選択した。 この場合、ドロップダウンリストから［UPSタイプ］と［通信ポート］を選択することができます。システムがスマートシグナリングUPSを使用している場合は、［自動検出の実行］を選択してUPSを自動検出させることもできます。

    注意:
    Back-UPS、2-Port Interface Expander Card、またはベーシックポートを使ってシステムに接続するShare-UPS 8-Port Interface Expanderを自動検出することはできません。

  • ［はい］を選択して、通信ポートからUPSの自動検出を試みたが、UPSを検出できなかった。

    • シンプルシグナリングUPS(Back-UPS)、2-Port Interface Expander Card、またはベーシックポートを使ってシステムに接続するShare-UPS 8-Port Interface Expanderをシステムで使用している場合は、［UPSタイプ］および［通信ポート ］に適切なUPSタイプと通信ポートを指定してから、［次へ>］をクリックして下さい。

    • システムがスマートシグナリングUPSを使用している場合は、［自動検出の実行］をクリックしてUPSを再検出して下さい。

システムがスマートシグナリングUPSを使用しているのに、［UPSタイプおよび通信ポート］画面から［自動検出の実行］を選択しても、UPSデバイスが検出されない場合は、次の原因が考えられます。

  • ターミナルエミュレータなどの他のサービスが、UPSが接続されている通信ポートを使用している。 該当する通信ポートを使用しているサービスを終了するか、またはUPSを他の通信ポートに接続し直してから、もう一度［自動検出の実行］をクリックしてUPSの自動検出を行って下さい。
  • サポートしていないMatrix-UPSを使用している。 Matrix-UPSを認識できない場合を参照して下さい。
  • UPSが990-0024スマートシグナリングシリアルケーブルまたは標準USBケーブルを使って接続されていない。 UPS通信ケーブルの要件を参照して下さい。
  • UPSがコンピュータのBIOSによって有効にされていないUSBポートに接続されている。
  • UPSが接続している通信ポートの通信設定が誤っている。 USBではなくシリアルポートを使用している場合は、シリアルポートの設定を参照して下さい。
  • UPSとコンピュータ間の接続に問題がある。 UPS通信リンクを参照して下さい。
  • UPSと一緒にAP9606 Web/SNMP Management Cardを使用している場合に、そのデバイスが適切に設定されていないか、SNMPエージェントが動作していない。

    注意:
    それでも問題が発生する場合は、APCカスタマサポート (    http://www.apc.co.jp/sands/)にお問い合わせ下さい。


Matrix-UPSを認識できない場合

Matrix-UPSに接続しているシステム上にPowerChute Business Edition エージェントをインストールする際に自動検出に失敗する場合、サポートしていないバージョンのUPSモデルを使用している可能性があります。 1996年8月以前に製造された、ファームウェアレビジョンが「z」より前のMatrix-UPSは、PowerChute Business Editionがサポートしている通信手法と異なる手法を使用しています。

詳細については、APCカスタマサポート (http://www.apc.co.jp/sands/)にお問い合わせ下さい。


シリアルポートの設定

ここでは、USBポートではなくシリアルポートにUPS通信ケーブルを接続する場合について説明していきます。 UPSを接続しているシリアルポートの設定を表示するには、次の作業を行って下さい。

  • Windows NTの場合、コントロールパネルから次の各項目を順番に開いて下さい。

    • ［シリアルポート］アイコン

    • ［設定...］ボタン

  • Windows 2000/ XPの場合、コントロールパネルから次の各項目を順番に開いて下さい。

    • ［システム］アイコン

    • ［ハードウェア］タブ

    • ［デバイスマネージャ］ボタン

    • ［ポート］アイコン

ポートは、次のように設定しなければなりません。

パラメータ | 設定
ボーレート(ビット／秒) | 2400
データビット | 8
パリティ | なし
ストップビット | 1
フロー制御 | XON/XOFF

また、［詳細...］ボタンをクリックして、［FIFOを有効にする］(Windows NTの場合)または［FIFOバッファを使用する］(Windows 2000/ XPの場合)が無効になっていることを確認して下さい。


UPS通信リンク

ここの説明では、スマートシグナリングUPSとコンピュータOS間の接続を確認するためにハイパーターミナルを使用していますが、任意ののターミナルエミュレータを使用することができます。

  1. COMポートを他のサービスが使用していないことを確認します。

  2. 次の手順に従ってハイパーターミナルを起動します。

    • Windows NTの場合、［ハイパーターミナル］フォルダに移動して(［スタート］>［プログラム］> ［アクセサリ］> ［通信］> ［ハイパーターミナル］)、［ハイパーターミナル］アイコンをクリックして下さい。

    • Windows 2000/ XPの場合、［通信］フォルダに移動して(［スタート］>[プログラム]　（Windows XPの場合は[すべてのプログラム]）> ［アクセサリ］> ［通信］)、［ハイパーターミナル］アイコンをクリックして下さい。

  3. ［接続の設定］ダイアログに、ハイパーターミナル接続を識別する名前を入力して［OK］をクリックします。

    注意:
    「...モデルをインストールして下さい」のようなメッセージが表示された場合は、それを無視して下さい。

  4. ［接続の設定］ダイアログの［接続方法］に、UPSが使用するシリアルポートを指定して、［OK］をクリックします。

  5. ［ポートの設定］ダイアログの各項目に、次の値を設定します。

    • ボーレート2400ビット／秒

    • 8データビット

    • パリティなし

    • 1ストップビット

    • フロー制御Xon/Xoff

  6. 空の画面が表示されたら、大文字のYを入力します。 画面にSM（Smart Mode）の文字が表示された場合、シリアル通信リンクに問題はありません。SMと表示されない場合は、手順7に進んで下さい。

  7. 大文字のAを入力します。 画面にOKと表示され、UPSのブザーが鳴りフロントパネルのLEDが点滅した場合(UPSにアラームやフロントパネルのLEDがない場合を除く)、UPSは正常に信号を受信しています。ただし、次のような理由により信号を送信できない可能性があります。

    • UPSからコンピュータへ信号を送信するための機能が壊れている。 インターフェイスケーブル障害が発生している。

    • コンピュータのシリアルポートが信号を受信できない。 割り込みの衝突やシリアルポートの誤動作などの原因が考えられます。

Step 6で画面にSMと表示されない場合は、シリアルケーブルを交換して下さい。 それでも問題が解決しない場合は、上記の手順を参考に、同じUPSと他のコンピュータのシリアル接続を確認したり、同じコンピュータと他のUPSのシリアル接続を確認して、UPSとコンピュータのどちらに原因があるのかを切り分けて下さい。

注意:
問題が解決しない場合は、APCカスタマサポート (http://www.apc.co.jp/sands/)へお問い合わせ下さい。


運用上の問題点

PowerChute Business Edition使用時に発生する可能性がある問題については、次の各項目を参照して下さい。

  • DNSサーバが見つからない場合のネットワーク通信上の問題
  • Windows XPの制限付きユーザ
  • PowerChute Business Editionのアンインストール
  • SNMP サービス
  • Windows NTを使用したIPアドレスへのブロードキャストメッセージ
  • ユーザ名に使用する文字について


DNSサーバが見つからない場合のネットワーク通信上の問題

次のような場合、PowerChute Business Editionのエージェント、サーバ、およびコンソールに関するネットワーク通信に問題が発生する可能性があります。

  • DNSサーバがない、または見つからない場合
  • 最近ローカルシステムがネットワークから切断された場合
  • ローカルシステムとDNSサーバ間にネットワーク上の問題が発生した場合

またこの問題は、ピアツーピアネットワークを利用している場合や、スタンドアロンシステムを利用している場合にも発生する可能性があります。

このようなネットワーク通信に関する問題が発生した場合は、PowerChute Business EditionがDNSサーバを使ってホスト名を解決する代わりにIPアドレスを使用します。次の作業を行って下さい。

  1. PowerChute Business Editionコンソールを起動します。

  2. ［表示］メニューから［設定］を選択します。

  3. ［ネットワーク］タブを選択します。

  4. ［ホスト名を解決する］オプションの選択を解除します。

  5. ［適用］をクリックします。


Windows XPの制限付きユーザ

PowerChute Business Editionコンソールは、Windows XPの制限付きユーザモードで使用するように設計されていません。制限付きユーザはconsole.exeプログラムを実行することができません。


PowerChute Business Editionのアンインストール

PowerChute Business Editionをアンインストールした際、OS標準UPSサービスは有効化されますが、サービスがOS起動時に起動するようにするためには、サービスのスタートアップの種類を[自動]に選択する必要があります。

[サービス] ダイアログボックスで、Uninterruptible Power Supplyサービスをダブルクリックし、[スタートアップの種類]から[自動]を選択して下さい。サービスをすぐに開始する場合、[開始]ボタンをクリックして下さい。

PowerChute Business Editionを削除後、フォルダやファイルがインストールディレクトリに残る可能性があります。\program files\APC\PowerChute Business Editionのディレクトリを確認し、フォルダの中身とともに削除して下さい。

PowerChute Business Editionがシステムにインストールされている唯一のAPC製品である場合は、APCフォルダも削除して下さい。

PowerChute Business Editionエージェントのアンインストール時に、次のようなメッセージが表示されることがあります。

メッセージ | 説明
エージェントサービスの削除時にエラーが発生しました。 セットアップ終了後に再起動して下さい。 | PowerChute Business Editionエージェントサービスの削除に失敗しました。 サービスがハングアップしているか、インストールされていません。


SNMP サービス

PowerChuteは、システムのSNMPサービスを利用してSNMPトラップを送信します。PowerChuteコンソールには、ご使用のシステムにSNMPサービスがインストールされていない場合もSNMPオプションが表示されます。

注意:
Linux上ではPowerChuteのSNMPオプションはサポートされません。


Windows NTを使用したIPアドレスへのブロードキャストメッセージ

PowerChute Business Editionのブロードキャストメッセージ送信機能は、Windows NT環境でお使いの場合、以下の制限があります。

  • PowerChute Business Editionは、Windows NTマシンへIPアドレスを指定してのブロードキャストメッセージ送信は出来ません。
  • PowerChute Business EditionサーバがWindows NTマシンにインストールされている場合、IPアドレスを指定してのブロードキャストメッセージ送信は出来ません。

Windows NTマシンを使用し、ブロードキャストメッセージを送受信する際は、ホスト名を指定して下さい。


UPSセルフテスト結果及び日時が更新されない

PowerChute Business Editionエージェントをインストール後、一回目に行ったセルフテストの結果は、不明と表示されることがあります。2回目以降のUPSセルフテスト実施時は、正しい結果が表示されます。

また、UPS本体から行われたセルフテストについては、[前回のセルフテスト]の日時が更新されません。アクセサリからUPSセルフテストを行った場合は、セルフテスト結果及び日時が更新されません。


コンソール上でイベントがクリアされない

シンプルシグナリング接続の際、バッテリ状態時間しきい値超過イベントが発生すると、その後このイベントの状態から復帰しても、コンソール上からこのイベントがクリアされません。最新のイベントについては、イベントログを参照して下さい。


ユーザ名に使用する文字について

PowerChute Business Editionのユーザ名には、マルチバイト文字を使用することも可能ですが、インターフェースにより、ログインに問題が生じる場合がございますので、シングルバイト文字を使用して下さい。


アプリケーションのデータ収集機能

PowerChute Business Editionコンソールを初めて使用する際に、プログラムのアプリケーションデータ収集機能を有効にするかどうかを問い合わせるメッセージが表示されます。 ［設定］ダイアログの［データ収集］タブから、この機能を有効または無効にすることができます。

この機能を有効にした場合、PowerChute Business Editionはプログラム機能(ダイアログボックス、アイコンなど)の利用情報を収集し、この情報を定期的にAPCに送信します。 この情報は、弊社がPowerChute Business Editionや他のAPC製品の機能や操作性を向上するために使用させていただきます。

この機能を有効にしても、お客様の個人情報や、コンピュータ機器、ネットワーク、および他のアプリケーションに関する情報が送信されることはありません。

注意:
インターネット通信の仕組み上の理由により、APCが受け取る情報の中にはお客様のIPアドレスも含まれています。 ただし、APCはこの情報を保持することはありません。


サーバノード数の制限

ご利用のPowerChute Business Editionが5ノード版でも25ノード版でも、ネットワーク上にインストールできるPowerChute Business Editionエージェント、PowerChute Business Editionサーバ、およびPowerChute Business Editionコンソールの数に制限はありません。 このノード数の制限は、単に1台のPowerChute Business Editionサーバで管理できるPowerChute Business Editionエージェントの最大数を表しています。

PowerChute Business Editionサーバのノード制限を確認するには、PowerChute Business Editionコンソールの［バージョン情報］を参照して下さい（［ヘルプ］メニューの［バージョン情報］）。


サードパーティのソフトウェア

Portions of this software are Copyright (c) 1993 - 2001, Chad Z. Hower (Kudzu) and the Indy Pit Crew - http://www.nevrona.com/Indy/

Portions of this software are Copyright (c) 1997, 1998 by Francois PIETTE - http://users.swing.be/francois.piette

Portions of this software are Copyright 1989, 1991, 1992 by Carnegie Mellon University
Derivative Work - 1996, 1998-2000 Copyright 1996, 1998-2000 The Regents of the University of California.
All Rights Reserved

Portions of this software are Copyright (c) 2001, NAI Labs. All rights reserved.

Copyright (c) 1998-2001 The OpenSSL Project. All rights reserved.


Copyright (c) 1998-2001 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

    "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

  4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

  5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.

  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License -----------------------

/ Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com). The implementation was written so as to conform with Netscape's SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used.

This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    "This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)"

    The word ﾕcryptographicﾕ can be left out if the routines from the library being used are not cryptographic related:-).

  4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

    "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publicly available version or derivative of this code cannot be changed, i.e., this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.