入门教程

本《入门教程帮助》作为PowerChute Business Edition单节点代理免费版的引言部分，内容涵盖产品及安装程序说明。

请注意：
本“帮助”有时会使用“PowerChute ”字样代表“PowerChute Business Edition”。

PowerChute Business Edition 单节点代理
本代理可提供UPS状态监控，并在外部电力异常时，关闭受UPS保护的计算机系统。

计算机必须直接 可支持的UPS型号中相关的UPS系统连接才能安装本软件。

也可参见访问PowerChute Business Edition代理用户界面。

© 2008
by American Power Conversion Corp.
美国电力转换公司 http://www.apc.com
All rights reserved. 版权所有
最后更新时间: 2008/11


安装步骤

遵循以下步骤执行安装。

  • 安装PowerChute Business Edition 代理

您可能发现本节对您有帮助：

  • Windows代理静默安装

请注意：
在安装PowerChute Business Edition代理前应卸载掉其他APC PowerChute应用软件，包括有：PowerChute plus；PowerChute Personal Edition；PowerChute Network Shutdown。

© 2008
by American Power Conversion Corp.


安装PowerChute Business Edition 代理

应在每台受UPS保护的计算机上安装PowerChute 代理。

本代理可以安装在多个不同的操作系统上。如果您准备在Windows下安装从APC网站上下载的本代理，请下载setup可执行文件，并双击启用安装程序。相关Linux、X86及Solaris操作系统信息，请参见SolarisReadMe.txt、Solaris_x86ReadMe.txt及Linuxreadme.txt文件。

遵循以下步骤。

  1. 点击“安装” 按钮进行标准安装，或者，若您要更新PowerChute Business Edition，请点击“更新”按钮安装现有程序的更新版。

  2. 同意接收许可协议。

  3. 为 PowerChute 代理文件选择安装目录。

    若为更新类安装，无需选择安装目录。缺省使用以前所用的目录。

  4. 允许安装程序自动检测所连接的UPS。

    若为更新类安装，无需选择UPS。缺省选择以前所用的UPS。

    注：
    当询问时选择“否”，则会跳出“您想要在所有端口自动搜索APC UPS”对话框时，您可选择 PowerChute代理主机所使用的UPS 类型和通信端口。

    若您的UPS连接简单信号，则您必须手工检测UPS。若您正使用连接简单信号端口的UPS，并带有Interface Expander或Share-UPS等配件，那么就请选择配件基本端口。这能使您同时支持“定时器模式”和“确认模式”。

  5. 输入用户名和密码，无需与任何计算机、管理员或域帐户匹配。

    若为更新类安装，无需询问用户名和密码。缺省使用以前的用户名和密码。

© 2008


Windows代理静默安装

采用标准非静默安装，在安装过程中通常需要响应提示。静默安装不会提示输入，因为程序已有应答。

步骤1：创建“静默系统应答文件”

  1. 从您的计算机中卸载所有PowerChute 组件。

  2. 把 PowerChute CD中的bin\agent文件夹复制到本地文件夹，比如C:\agent中。

  3. 通过选择Windows“开始”按钮，然后点击“运行”并在框内键入“command”指令启用命令符提示。点击“确定”。

  4. 确保UPS已与计算机连接。

  5. 在命令符提示中，键入
    <agent path>setup.exe -r
    比如 C:\agent\setup.exe -r
    -r 记录安装过程中您所提供的应答。

    在安装过程中，选择让PowerChute 自动检测ups。然后在静默安装中，即使处于不同端口，也会检测到该ups。

  6. 安装程序会（在\Windows文件夹中）创建名为 setup.iss 文件。必要时需搜索查找该文件。把它复制到您在步骤2中创建的代理文件夹中。

步骤2：执行“静默安装”

静默安装使用您在上节中所创建的应答文件。

  1. 把整个代理文件夹（包含setup.iss文件）复制到要执行静默安装的计算机上。

    您也可把该文件夹复制到网络驱动器上，可从各台安装计算机上映射到该驱动器上。查看以下步骤3有关映射驱动器W:示例。

  2. 通过选择Windows“开始”按钮，然后点击“运行”并在框内键入“command ”指令启用命令符提示。点击“确定”。

  3. 在命令符提示中，键入
    <agent path>setup.exe -s
    比如 C:\agent\setup.exe -s
    或 W:\agent\setup.exe -s
    其中，w为映射网络驱动器

    您也可使用-m参数，把结果日志记录在 status.mif的SMS 文件中。
    比如 C:\agent\setup.exe -s -m

    若要确定是否已完成静默安装，请保留命令符提示窗口打开，直至再次显示提示（比如 C:\agent>）。安装过程可能需要数分钟。

  4. 关闭命令指示窗。

© 2008


访问PowerChute Business Edition代理用户界面

要访问PowerChute用户界面，请完成以下操作：

  • 请安装32位(x86)的 Java Runtime Environment (JRE), 1.4.2 或以上版本。（不支持 Windows x64平台版本）。

  • 添加127.0.0.1 为“受信任的站点”，操作步骤如下：

    1. 打开“ Internet Explore”浏览器。

    2. 选择“工具”菜单中的“Internet选项”。

    3. 选择“安全”选项卡。

    4. 选择“受信任的站点”图标，然后点击“站点”按钮。

    5. 在“将该网站添加到区域中”字段内键入 127.0.0.1。

    6. 选择“添加”按钮，然后点两次“确定(OK)”退出。

您有两种方式访问PowerChute Business Edition代理用户界面，分别是本地访问和远程访问。

若要访问本地机器上的PowerChute Business Edition代理，请选择Windows“开始”按钮，然后选择 PowerChute Business Edition, 和 代理 Web 界面。

若要远程访问PowerChute代理，在Web浏览器中键入以下一种URLs，代替原有servername和serverIPaddress值。

http://servername:3052:
http://COMP
http://serverIPaddress:3052

例如，若您的服务器名为COMP1，IP地址为117.14.53.59，那么您应键入如下：
http://COMP1:3052
http://117.14.53.59:3052
© 2008


可支持的UPS型号

版本注记在线帮助文件 Relnotes_ch.chm一般位于 C:\Program Files\APC\PowerChute Business Edition下，包含本程序最低软硬件配置信息。

© 2008