Introduction

Before you install and use APC® PowerChute® Business Edition Single Node Agent, read these release notes, which provide information about installing the product, everyday operation, server nodes, and third-party software.

Please see the Linuxreadme.txt, Solaris_x86ReadMe.txt, and SolarisReadMe.txt files also for information relevant to those operating systems.

Note:
This help sometimes uses PowerChute to represent PowerChute Business Edition.
Copyright © 2008
American Power Conversion Corp.
http://www.apc.com
All rights reserved.
Last updated: November 20, 2008.


Installation Overview

Uninstall other APC PowerChute applications before you try to install PowerChute Business Edition Single Node Agent. These applications include PowerChute plus, PowerChute Personal Edition, and PowerChute Network Shutdown.

During the installation, you will do the following:

  • Install PowerChute Business Edition Agent at each UPS-protected computer. These computers must meet the requirements listed in the following sections:
    • APC Hardware Requirements for Installation
    • UPS Communications Cable Requirements
    • PowerChute Business Edition Agent Requirements
      • Note:
      If the computer uses an unsupported UPS or an incorrect UPS communications cable, you might not be able to complete the PowerChute Single Node Agent Setup because the PowerChute Agent will not be able to communicate properly with the UPS.


System Requirements for Installation

For up-to-date information on the operating systems, service packs, and processors with which PowerChute Business Edition is compatible, see the latest revision of PowerChute Business Edition Operating System and Processor Compatibility Chart (APC Part Number 990-3058A), and the Compatible Hardware entry on the APC Web site at http://www.apc.com.

The computer must be connected to a TCP/IP network and meet the requirements listed in the following section.

PowerChute Business Edition Agent Requirements

The PowerChute Agent has the following processor and memory requirements:

Requirement
Minimum
Processor
Pentium® 4 1.3 GHz
RAM
256 MB


APC Hardware Requirements for Installation

For information about the UPSs, interface expanders, cables, and environmental monitors that can be used with PowerChute Business Edition Agent, see the following sections:

  • Supported UPS Models and Accessories
  • UPS Communications Cable Requirements
  • Supported Environmental Monitors


Supported UPS Models and Accessories

PowerChute Business Edition Agent can manage any UPS that is shipped with the software, including most Smart-UPS® models (3kva and below) that use advanced signaling with a serial port.

Basic signaling is also supported through an APC 8-Port UPS Interface Expander or APC Interface Expander Card, both of which use a serial cable to connect with the host computer.

USB communication with USB-capable Smart-UPS models is possible on Microsoft® Windows® operating system.

See the Compatible Hardware entry under the PowerChute Business Edition section on the APC Web site at http://www.apc.com.


UPS Communications Cable Requirements

The PowerChute Agent communicates with the UPS through a communications cable that connects to the UPS and to a communications port at the PowerChute Agent’s computer.

UPS Model
APC Part Number of Communications Cable
Smart-UPS
940-0024 (advanced signaling)
Any USB-compatible Smart-UPS
Any standard USB cable.
8-Port UPS Interface Expander
940-0020 (basic port connection)
940-0024 (advanced port connection)
Interface Expander Card
940-0020 (basic signaling)


Supported Environmental Monitors

The PowerChute Agent can manage and report the status of the Environmental Monitoring Card (AP9612TH) with firmware revision S or later.


Before you Install PowerChute Business Edition

Before you perform the installation, note the following information about the installation process.

  • Installation Backs Up the default.cmd or default.sh file
  • Upgrading PowerChute Business Edition
  • Characters Not Allowed in User Names and Passwords
  • Shutting Down During a Power Outage


Installation Backs Up the default.cmd or default.sh file

When you install a PowerChute upgrade, any default.cmd file (Windows) or default.sh file (Linux and Solaris) is backed up as _default_backup.bak in the cmdfiles directory.


Upgrading PowerChute Business Edition

Upgrading here means that you don’t uninstall PowerChute, you just install a newer version over the older (retaining your configuration settings).

You can upgrade from a PowerChute Single Node Agent to a 5-Node Deluxe version.

If you are unsure whether you can upgrade or not, please contact APC Worldwide Customer Support (http://www.apc.com/support/).


Characters Not Allowed in User Names and Passwords

In user names and passwords, you cannot use a colon (:), a quotation mark (“), a question mark (?), an asterisk (*), an ampersand (&), a space ( ), or double- and single-byte Japanese or Chinese characters. You can use a single quote or apostrophe (’).


Shutting Down During a Power Outage

The installation configures a PowerChute shutdown based on the strategy of keeping your computer running as long as possible when power fails. In practice, this means that it shuts down when the UPS has 5 remaining minutes of runtime.

(The events that can trigger a shutdown when power fails are Low Battery, Internal UPS Temperature Exceeded, and UPS Communication Lost While On Battery).


Installation Issues

This section discusses the issues and problems that can occur while installing PowerChute Business Edition.

Please see the Linuxreadme.txt, Solaris_x86ReadMe.txt, and SolarisReadMe.txt files also for information relevant to those operating systems.

  • Messages when PowerChute plus is Installed
  • Installation Messages that can occur as you install PowerChute Business Edition Agent
  • Incompatibility Message with Windows Server 2003 x64 Editions
  • Messaging Fails on Windows Vista or Windows 2008
  • Setup Might Not Automatically Detect the System’s UPS
  • Checking UPS Communications on Windows
  • Installing Older Versions


Messages when PowerChute plus is Installed

You cannot use PowerChute Business Edition Single Node and PowerChute plus on the same computer. When you attempt to install any PowerChute Business Edition Agent and Setup detects that PowerChute plus is installed:

  • For a 5.x version of PowerChute plus, you are prompted to uninstall PowerChute plus automatically. Click Yes to uninstall it.
  • For a 4.x version of PowerChute plus, a message informs you that Setup cannot uninstall PowerChute plus. You must uninstall PowerChute plus by using your operating system’s procedure for uninstalling programs.


Installation Messages that can occur as you install PowerChute Business Edition Agent

The following messages (listed alphabetically) may occur while you are installing a PowerChute Business Edition Agent.

Note:
If the problem persists, contact APC Worldwide Customer Support
(http://www.apc.com/support/).
Message
Description
An unidentified program wants access to your computer.
This message is a security feature of Windows Vista and occurs if User Account Control (UAC) is enabled. Click Allow to continue the installation.
Could not stop the UPS service. Please reboot and retry setup.
Setup failed to stop the native UPS service on Windows. Reboot the computer before you attempt to install the PowerChute Agent again.
Error encountered while installing the <Agent> service. Please reboot and retry setup.
Setup failed to install the PowerChute service. Ensure that no PowerChute files are already installed and that the computer uses a supported operating system. See the latest revision of PowerChute Business Edition Operating System and Processor Compatibility Chart (APC Part Number 990-3058A) on the APC Web site at http://www.apc.com before you retry the installation.
Error <identification> on attempt to load dll: <dll identification>.
Setup failed to load the identified DLL file. Before you attempt the installation again:
  • Ensure that the computer uses a supported operating system. See the latest revision of PowerChute Business Edition Operating System and Processor Compatibility Chart (APC Part Number 990-3058A) on the APC Web site at http://www.apc.com.
  • Ensure that the computer complies with the requirements listed in PowerChute Business Edition Agent Requirements.
Failed to load necessary resource.
Setup cannot load the DLL files, native InstallShield resources, and other resources needed to install the PowerChute component. Make sure that the computer has sufficient memory available before you retry the installation. See System Requirements for Installation.
Password is not 3-16 characters long.
Use a password that has at least three but no more than sixteen characters.
User name is not 3-16 characters long.
The user name must have at least three but no more than sixteen characters.
PowerChute Business Edition requires administrator privileges to install and run. Please log off and rerun Setup using an administrator-privileged account.
You must have administrative access to the computer before you can install any PowerChute component.
Setup could not determine if the selected path is valid. Please select a directory on the local hard drive.
You cannot install PowerChute on a network drive or on any other drive except the local hard-disk drive.
Setup failed to restart the native UPS service. You must manually restart the service or reboot to enable power protection.
The Windows UPS service did not restart. The service is stopped when you uninstall an older version of PowerChute Business Edition, for example, in order to install a newer version of the PowerChute Agent. Restart this service manually or by rebooting the computer.
The two passwords must match to proceed.
The passwords you entered in the Password and Confirm fields must match.
Windows needs your permission to continue
This message is a security feature of Windows Vista. Click Continue.


Incompatibility Message with Windows Server 2003 x64 Editions

When installing the PowerChute Agent on Windows Server 2003 x64 Editions in USB mode, ignore the warning “The software you are installing has not passed Windows Logo testing to verify its compatibility with this version of Windows.”


Messaging Fails on Windows Vista or Windows 2008

Windows Vista and Windows 2008 do not have the messenger service that other versions of Windows have. The lack of this service disables the method PowerChute Business Edition has used to send messages to the local server and remote servers. If you have an alternative messaging system on your computers that can be called from a command file or batch file, you may be able to use that messaging system as a solution.


Setup Might Not Automatically Detect the System’s UPS

Use the following troubleshooting checklists if PowerChute Business Edition Agent does not detect the UPS automatically

Note:
Setup cannot detect a device connected by a basic-signaling cable. Therefore, during setup, specify the port and UPS type of a UPS connected through the basic port of an Interface Expander Card or 8-port Interface Expander. If auto-detection fails with an advanced-signaling or USB cable, use the troubleshooting methods in this section.

On Windows, use the following checklist:.

  • If another service, such as a terminal emulator, is using the COM port to which the UPS is connected, stop that service or connect the UPS to another COM port, and use Run Detect to have the setup program search again for the UPS.
  • Ensure that the service APC PBE Agent is running.
  • Ensure that you are using the correct cable and that it is securely connected. See UPS Communications Cable Requirements. After any changes, stop and restart the service APC PBE Agent.
  • If you are using a USB cable,:
    • Ensure that the Communications Port is set to USB. (To change from a serial to a USB connection, you must re-install the PowerChute Business Edition Agent.)
    • Check your USB device through the Windows Control Panel, by selecting Administrative Tools, then Computer Management, then HID. if either HID, or (under HID) the driver American Power Conversion USB UPS is not displayed, ensure that the USB port is enabled at your computer. If you are using a USB hub instead (not recommended), ensure that the hub is receiving power, check the hub’s documentation to determine if an adapter is needed, ensure that the USB cable to the UPS is the last cable in the chain, and ensure that all USB devices upstream from the UPS have are communicating.
  • If either of the following is installed or connected, check its configuration:
    • A Network Management Card must be fully configured and operational.
    • If you are using PowerChute Business Edition Agent to monitor an Interface Expander Card or the basic port of an 8-port Interface Expander, ensure that you are using the correct cable (as listed in UPS Communications Cable Requirements), and that “Simple Signaling Accessory” was specified when the card or device was installed. If you are unsure what type of accessory was specified, reinstall the card or device with the correct settings.
  • To check for USB connection defects, use another USB port and USB cable, or use a terminal emulator to check the connection. See Checking UPS Communications on Windows.
Note:
If the troubleshooting methods in this section do not solve the problem, contact APC Worldwide Customer Support (http://www.apc.com/support/).


Checking UPS Communications on Windows

To check the connection between an advanced-signaling UPS and the computer’s supported Windows operating system, use any terminal-emulation program. The following procedure describes how to use HyperTerminal.

  1. Make sure that no other service is using the communications port.
  2. Open HyperTerminal at Start>Programs (or All Programs)>Accessories> Communications).
  3. In the “Connection Description” dialog box, type a name to identify the HyperTerminal connection, and click OK.
    4. Note:
    If the message “...must install a modem” is displayed, disregard it.
  4. In the Connect Using field of the “Connect To” dialog box, select the serial port that the UPS uses, and click OK.
  5. In the “Port Settings” dialog box, ensure that the port settings are those listed for Windows in Setup Might Not Automatically Detect the System’s UPS
  6. When a blank screen is displayed, type an uppercase Y.
    • If the screen displays the letters, SM (Smart Mode), there is no problem with the serial communications link.
    • If SM is not displayed, type an uppercase A. If the screen displays OK, the UPS can receive signals, but it cannot send them.
      • The serial cable may be faulty. Replace the serial cable.
      • The computer’s serial port may be unable to receive signals because of an interrupt conflict or a malfunctioning in the port. Try using a different computer.
      • The UPS may be faulty. Try using a different APC UPS.
Note:
If the problem persists, contact APC Worldwide Support (http://www.apc.com/support/ ).


Installing Older Versions

Do not install an older version of PowerChute Business Edition Agent without first uninstalling the current version. If you do not uninstall the current version first, the installation can corrupt the version you are installing and leave unused, undeleted files.


Starting the PowerChute Business Edition Agent

Please see the Linuxreadme.txt, Solaris_x86ReadMe.txt, and SolarisReadMe.txt files for information relevant to those operating systems.

On Windows, after the installation process is completed, the PowerChute Business Edition Agent begins running automatically. The Agent runs automatically each time the operating system is started. To start the PowerChute Business Edition Agent manually after it has been deliberately stopped, enter the following command at the shell prompt from anywhere in the file system:

<pcbe_agent_directory>/bin/startup start


Stopping the PowerChute Business Edition Agent

Please see the Linuxreadme.txt, Solaris_x86ReadMe.txt, and SolarisReadMe.txt files for information relevant to those operating systems.

On Windows, to stop the PowerChute Business Edition Agent when it is running, enter the following command from anywhere in the file system:

<pcbe_agent_directory>/bin/startup stop


Uninstalling PowerChute Business Edition

  • Issues on Windows:


Issues on Windows:

The following issues can occur when you are uninstalling PowerChute Business Edition on Windows:

  • The native UPS service might fail to restart. See the description of the error message Setup failed to restart the native UPS service. You must manually restart the service or reboot to enable power protection.
  • If you uninstall PowerChute from a Windows operating system, the native Windows UPS Service is restored, but you must configure it to start automatically.
  • After you uninstall PowerChute Business Edition, you might need to remove some files and folders manually. Delete the installation folder, including its contents, if it still exists.(the default folder \program files\APC\PowerChute Business Edition or the non-default folder you specified during the installation). If PowerChute Business Edition is the only APC product installed, also delete the APC folder.
  • If the following message occurs when you attempt to uninstall the PowerChute Business Edition Agent, the Agent is either not installed or is not responding:
    Error encountered while removing the Agent service. Please reboot after setup exits.
  • On Windows 2003 Web Edition only, some files are not deleted when you uninstall PowerChute Business Edition. These remaining files will not affect the operation of your computer system.
  • If a PowerChute Business Edition event is open in the Windows Event Viewer while you uninstall the PowerChute Business Edition Agent, you might receive the following misleading error message:
    InstallShield Wizard installed PowerChute Business Edition properly.
    The word “installed” should be “uninstalled.”


Operational Issues

This section describes issues that affect the use of PowerChute Business Edition.

  • Known Issues on All Operating Systems
  • Known Issues on Windows
  • Known Issues When You Use Microsoft Internet Explorer


Known Issues on All Operating Systems

  • UPS Self-Tests Not Always Logged
  • Out-of-Band Management Access Causes Comm Lost Event
  • Daylight Savings and Scheduled Shutdowns


UPS Self-Tests Not Always Logged

UPS Self-Test events are not always logged in the PowerChute event log.

Self-tests initiated from the front panel of the UPS are never logged. Sometimes, self-tests initiated by PowerChute or by APC accessories are not logged.


Out-of-Band Management Access Causes Comm Lost Event

When an APC Out-of-Band Management Card tries to obtain information from a UPS, it can cause the PowerChute Agent to log a UPS Communication Lost event and subsequently a UPS Communication Established event.


Daylight Savings and Scheduled Shutdowns

Don’t schedule a shutdown to start or finish during a daylight savings "transition hour". (The transition hour means the additional hour or the skipped hour when daylight savings commences or finishes).

If you originally used an older version of PowerChute to create a shutdown schedule with a start or finish time during a daylight savings "transition hour", you should edit it and resave.

Your PowerChute Agents and Console should be set at the same time zone for consistent results in shutdown scheduling. In addition, ensure that your system and JRE times are correct.


Known Issues on Windows

  • Standby Mode Disables the Agent Temporarily
  • iKernel.exe Application Error
  • Standby Can Postpone a Scheduled Shutdown


Standby Mode Disables the Agent Temporarily

The PowerChute Agent Windows service does not work while the computer is in Standby mode.


iKernel.exe Application Error

After uninstalling either the PowerChute Agent on Windows XP, a dialog box iKernel.exe - Application Error might display this error:

The instruction at “0x771c741a” referenced memory at “0x00163b60”. The memory could not be “read”. Click on OK to terminate the program.

To correct this problem, download and install a patch from the Microsoft Web page http://www.microsoft.com/downloads/details.aspx?FamilyID=9cf87cda-c7f3-41a2-8ea3-cc4f03ff0e31&DisplayLang=en. Although the article on the Web page is “Issue with DirectX May Cause DVD Players To Not Work,” the patch is relevant to this problem.


Standby Can Postpone a Scheduled Shutdown

If your Windows computer is on standby at the time for which a shutdown is scheduled (through the Shutdown Schedule command), the shutdown starts after standby mode ends, even if the time scheduled for the shutdown has already passed.

For example, if a shutdown is scheduled for 7 p.m. to 7 a.m., and your computer is on standby at 7 p.m., it will not shut down at that time. But if the computer resumes normal operation at 9 p.m., the shutdown begins when standby ends. Notification indicates that an administrative shutdown began at 7 p.m., and a minute later the computer shuts down. The computer turns on again twelve hours later.


Known Issues When You Use Microsoft Internet Explorer

  • Disabling Active Scripting Causes Problems with PowerChute Log-on
  • Security Alert when “Launching programs and files in an IFRAME” is disabled.
  • Distorted User Interface in PowerChute Business Edition Agent
  • “Every visit to this page” Option for Checking Web Pages Is Not Supported


Disabling Active Scripting Causes Problems with PowerChute Log-on

If you disable active scripting in Internet Explorer:

  • you cannot log on to PowerChute Business Edition Agent.
  • An ActiveX control in the log-on screen of PowerChute Business Edition Agent is marked as unsafe

If active scripting is disabled, enable it. For Internet Explorer 6.0, you enable active scripting as follows:

  1. Select Internet Options on the Tools menu in Internet Explorer.
  2. On the Security tab, open the list of custom level settings.
  3. Under Scripting, near the end of the list, enable “Active scripting.”


Security Alert when “Launching programs and files in an IFRAME” is disabled.

If “Launching programs and files in an IFRAME” is disabled in Internet Explorer, a Security Alert is displayed when you try to log on to PowerChute Business Edition Agent.

If “Launching programs and files in an IFRAME” is disabled, enable it. For Internet Explorer 6.0, you enable it as follows:

  1. (Select Internet Options on the Tools menu in Internet Explorer.
  2. On the Security tab, open the list of custom level settings.
  3. Under Miscellaneous, enable “launching programs and files in an IFRAME.”


Distorted User Interface in PowerChute Business Edition Agent

The User Interface of the PowerChute Business Edition Agent becomes distorted when you enable “Ignore colors specified on Web Pages” in Internet Explorer.

If “Ignore colors specified on Web pages” is enabled, disable it. For Internet Explorer 6.0, you disable it as follows:

  1. Select Internet Options on the Tools menu in Internet Explorer.
  2. On the General tab, click Accessibility...
  3. Unmark the check-box for “Ignore colors specified on Web pages.”


“Every visit to this page” Option for Checking Web Pages Is Not Supported

As the method by which Internet Explorer Web browser checks for newer versions of stored pages, the PowerChute Business Edition Agent does not support “Every visit to the page”.

To correct the problem. configure “Automatically” as the method for Internet Explorer to check for newer versions of stored pages. For Internet Explorer 6.0, you configure it as follows:

  1. Select Internet Options on the Tools menu in Internet Explorer.
  2. On the General tab, under Temporary Internet files, click Settings...
  3. Select “Automatically.”


Third-Party Software

Portions of this software are copyrighted as follows:

  • Copyright (c) 1996 Jef Poskanzer
  • Copyright (c) 2000 The Apache Software Foundation
  • Copyright (c) 2000-2002 Brett McLaughlin & Jason Hunter
  • Copyright (c) 1993-2003 Chad Z. Hower (Kudzu) and the Indy Pit Crew
  • Copyright (c) 1998-2004 The OpenSSL Project
  • Copyright (c) 1995-1998 Eric Young

This product includes software developed by ACME Labs (http://www.acme.com)

Copyright (C) 1996 by Jef Poskanzer <jef@acme.com>. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Visit the ACME Labs Java page for up-to-date versions of this and other fine Java utilities: http://www.acme.com/java/

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

The Apache Software License, Version 1.1

Copyright (c) 2000 The Apache Software Foundation. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)."

Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear.

  1. The names "Apache" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org.
  2. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Portions of this software are based upon public domain software originally written at the National Center for Supercomputing Applications, University of Illinois, Urbana-Champaign.

This product includes software developed by the JDOM Project
(http://www.jdom.org/).

Copyright (C) 2000-2002 Brett McLaughlin & Jason Hunter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the disclaimer that follows these conditions in the documentation and/or other materials provided with the distribution.
  3. The name "JDOM" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact license@jdom.org.
  4. Products derived from this software may not be called "JDOM", nor may "JDOM" appear in their name, without prior written permission from the JDOM Project Management (pm@jdom.org).

In addition, we request (but do not require) that you include in the end-user documentation provided with the redistribution and/or in the software itself an acknowledgement equivalent to the following:

"This product includes software developed by the
JDOM Project (http://www.jdom.org/)."

Alternatively, the acknowledgment may be graphical using the logos available at http://www.jdom.org/images/logos.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE JDOM AUTHORS OR THE PROJECT CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the JDOM Project and was originally created by Brett McLaughlin <brett@jdom.org> and Jason Hunter <jhunter@jdom.org>. For more information on the JDOM Project, please see <http://www.jdom.org/>.

Portions of this software are Copyright (c) 1993 - 2003, Chad Z. Hower (Kudzu) and the Indy Pit Crew - http://www.IndyProject.org/

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation, about box and/or other materials provided with the distribution.
  • No personal names or organizations names associated with the Indy project may be used to endorse or promote products derived from this software without specific prior written permission of the specific individual or organization.

THIS SOFTWARE IS PROVIDED BY Chad Z. Hower (Kudzu) and the Indy Pit Crew "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)

Copyright (c) 1998-2004 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)"

  1. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.
  2. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.
  3. Redistributions of any form whatsoever must retain the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used.

This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

"This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)"

The word 'cryptographic' can be left out if the rouines from the library being used are not cryptographic related :-).

  1. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

"This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.]