引言

在您安装使用 APC® PowerChute® Business Edition单节点代理免费版前，请阅读以下版本注记，获取产品安装、日常操作、服务器节点、第三方软件等方面的相关信息。

请参见Linuxreadme.txt、Solaris_x86ReadMe.txt和SolarisReadMe.txt这三个文件，获取相关操作系统信息。

请注意：
本“帮助”有时会使用“PowerChute”字样代表“PowerChute Business Edition”。

© 2008
by American Power Conversion Corp.
美国电力转换公司 http://www.apc.com
All rights reserved. 版权所有
最后更新时间: 2008/11


安装概览

在安装PowerChute Business Edition单节点代理免费版前，请先卸载其它APC PowerChute应用程序，包括有：PowerChute plus、PowerChute Personal Edition、PowerChute Network Shutdown。

安装时应遵循如下操作：

  • PowerChute Business Edition代理应安装在各台受UPS保护的计算机上。这些计算机必须符合下述章节所列要求：

    • APC硬件安装要求

    • UPS通信电缆要求

    • PowerChute Business Edition代理要求

      请注意：
      如果计算机使用了不支持的UPS或不正确的 UPS通信电缆，那么您可能无法完成PowerChute单节点代理安装，因为PowerChute代理无法与 UPS建立正常通信。


系统安装要求

有关PowerChute Business Edition兼容的操作系统、 补丁包、处理器方面的最新信息详情，请参阅最新版PowerChute Business Edition操作系统与处理器兼容表（获取途径：APC网站www.apc.com，APC产品号990-3058A）。

计算机必须连接TCP/IP网络，并符合下列章节中所述要求。

PowerChute Business Edition代理要求

配置要求 | 最低配置
处理器 | Pentium® 4 1.3 GHz
RAM | 256 MB


APC硬件安装要求

有关PowerChute Business Edition代理可使用的UPS、接口扩展器、电缆及环境监测器方面的信息详情，请参阅以下章节：

  • 可支持的UPS型号及附件

  • UPS通信电缆要求

  • 可支持的环境卡


可支持的UPS型号及附件

PowerChute Business Edition代理可管理任一台随机标配软件的UPS，其中包括大部分有串口的可使用高级信号的Smart-UPS® 型号（3kva及以下）。

同样也支持通过APC 生产的8端口UPS接口扩展器或接口扩展卡的基本信号，其均使用串行电缆与主机相连。

在Microsoft® Windows® 操作系统下可使用USB与USB兼容型Smart-UPS型号建立通信。

请参阅我们网站上软件下载页面“兼容的硬件”。


UPS通信电缆要求

PowerChute代理通过通信电缆与UPS建立通信，其一端连接UPS，另一端连接安装有PowerChute代理的计算机通信端口上。

UPS型号 | APC通信电缆产品号
Smart-UPS | 940-0024（高级信号）
USB兼容型Smart-UPS | 标准USB电缆
8端口UPS接口扩展器 | 940-0020（基本端口连接） 940-0024（高级端口连接）
接口扩展卡 | 940-0020（基础信号）


可支持的环境卡

PowerChute代理可管理并报告固件版本号S或更高版本的环境监测卡(AP9612TH)状态。


PowerChute Business Edition安装之前

在您进行安装前，请留意以下安装过程的信息。

  • 安装备份 default.cmd或default.sh文件

  • 升级PowerChute Business Edition

  • 用户名和 密码中不允许的字符

  • 断电时关闭系统


安装备份 default.cmd或default.sh文件

当您升级PowerChute时，default.cmd文件(Windows系统）或default.sh文件（Linux及Solaris系统）将备份为 _default_backup.bak文件，保存在cmdfiles目录下。


升级PowerChute Business Edition

这里所指的“升级”表示的是，您仅需安装新版本PowerChute以覆盖旧版本（即保留您原有的配置设置），而无需卸载PowerChute。

您无法将PowerChute单节点代理免费版升级至5节点豪华版。

参见 操作问题。

若您无法确定您用于的PowerChute版本是否可以进行升级，请联系APC全球客户支持部门(http://www.apc.com/support/)。


用户名和 密码中不允许的字符

您不能在用户名和密码字段中使用冒号(:)、引号(�)、问号(?)、星号(*),、与号(&)、空格( )及双字节/单字节日语或中文字符，但可以使用单引号或撇号(�)。


断电时关闭系统

安装系统基于“电源故障时使电脑尽可能长时间保持运行”配置PowerChute关闭方式。在实际操作中，这也意味着当UPS的剩余运行时间只有5分钟时代理启动关闭。

（电源故障时，“低电”、“UPS内部温度超出范围”或“电池运行时，UPS通信丢失”等事件均能触发系统关闭。


安装问题

本节讲述PowerChute Business Edition安装过程中可能会发生的各种疑难问题：

请参见Linuxreadme.txt、Solaris_x86ReadMe.txt和SolarisReadMe.txt这三个文件，获取相关操作系统信息。

  • 安装有PowerChute plus的消息

  • PowerChute Business Edition代理安装过程中可能会出现的安装消息

  • Windows Server 2003 x64 Editions不兼容消息

  • Windows Vista或Windows 2008下不能发送消息

  • 安装程序不能自动检测系统UPS

  • Windows系统下的UPS通信检查

  • 安装旧版本


安装有PowerChute plus的消息

PowerChute Business Edition单节点版和PowerChute plus不可在同台计算机上同时使用。当您试图安装任何PowerChute Business Edition代理且安装程序检测到计算机上已安装有PowerChute plus时：

  • 若PowerChute plus版本为5.x，则提示您“程序自动卸载PowerChute plus”，点击“是（Yes）”进行卸载。

  • 若PowerChute plus版本为4.x则您会收到消息提示“安装程序无法卸载PowerChute plus”。您必须通过操作系统中的卸载程序卸载PowerChute plus。


PowerChute Business Edition代理安装过程中可能会出现的安装消息

当您安装PowerChute Business Edition代理时可能会出现下列消息（按字母顺序排列）。

请注意：
若问题持续存在，请与APC全球客户支持部门联系。
(http://www.apc.com/support/)

消息 | 说明
一个未能识别的程序要访问您的计算机 | Windows Vista安全功能消息，在用户帐户控制(UAC) 启用后出现。点击“允许（Allow）” 继续安装。
无法停止UPS 服务，请重新启动并尝试再次安装 | 安装程序无法停止Windows下的内置UPS服务。在重新安装PowerChute代理前，请重新启动计算机。
安装<Agent>服务时遇到错误，请重新启动并尝试再次安装 | 安装程序无法安装PowerChute 服务。确保计算机以前没有安装任何PowerChute文件且使用可支持的操作系统。 请参阅APC网站上最新版PowerChute Business Edition操作系统与处理器兼容表（APC产品号990-3058，www.apc.com）再次尝试安装。
尝试加载dll: <dll identification>出错<identification> | 安装程序无法加载确定的DLL文件。请在再次尝试安装前： 确保计算机使用支持的操作系统。请参阅APC网站 上最新版PowerChute Business Edition操作系统与 处理器兼容表（APC产品号990-3058， www.apc.com）。 确保计算机满足PowerChute Business Edition代理 要求中所列配置要求。
无法加载必需的资源 | 安装程序无法加载DLL文件、纯InstallShield 资源及其它PowerChute 组件安装所需资源。请在确保计算机有足够的可用内存后再次尝试安装。请参阅系统安装要求一节。
密码必须使用3-16字符长度 | 密码字段必须使用3-16个字符长度。
用户名长度必须为3-16个字符 | 用户名必须使用3-16个字符。
安装运行PowerChute Business Edition要求使用管理员权限，请注销，然后使用管理员权限帐号重新运行 | 在您安装PowerChute组件前必须使用管理员权限访问计算机。
安装程序无法确定所选路径是否有效，请在本地硬盘上选择目录 | 您无法在网络驱动器或其它非本地硬盘驱动器上安装PowerChute。
安装程序无法重启Native Windows UPS服务，您必须手动重启该服务，或重启电脑，激活电源保护功能 | Windows UPS服务无法重新启动。例如，为安装PowerChute Business Edition新版本而需卸载其旧版本时，该服务停止运行。请手动重新启动该服务或重启计算机。
两个密码必须相符，才可以继续 | 您在密码字段和确认密码字段所输入的密码必须相互匹配。
Windows需要您的许可以继续 | 为Windows Vista安全功能消息，点击“继续”


Windows Server 2003 x64 Editions不兼容消息

当您在Windows Server 2003 x64 Editions下使用USB模式安装PowerChute代理时，请忽略警告消息“您正在安装的软件没有通过Windows徽标测试，无法验证它同此Windows版本的兼容性。”


Windows Vista或Windows 2008下不能发送消息

Windows Vista和Windows 2008没有其他Windows版本自带的信使服务。该服务的缺失禁止PowerChute Business Edition向本地服务器和远程服务器发送消息模式。若您计算机上有其它可从命令文件或批处理文件调用的信使系统，则可作为信使服务发送的一种的解决方案。


安装程序不能自动检测系统UPS

若PowerChute Business Edition代理没有自动检测到UPS，请使用以下故障排除检查表。

请注意：
安装程序无法检测由基础信号电缆连接的设备，因此在安装过程中，需指定通过接口扩展卡或8端口接口扩展器等基本端口连接的端口及UPS类型。若自动检测在高级信号或USB通讯下失败，请使用本节中介绍的故障排除方式。

若为Windows系统，请使用以下检查表：

  • 若有类似终端模拟器等其它服务使用UPS连接的COM端口，则停止该服务或将UPS连接至其它COM端口，并使用“运行检测” 按钮使安装程序重新搜索UPS。

  • 确保APC PBE代理服务然后重新运行。

  • 确保您使用正确的电缆并牢固连接，请参阅UPS通信电缆要求一节。若进行过任何修改，请先停止APC PBE代理服务然后重新运行。

  • 若您使用USB电缆，

    • 确保通信端口设置为USB。（若要更换串行端口到USB的连接，则您必须重新安装PowerChute Business Edition代理。）

    • 可通过Windows控制面板检查USB设备，请选择“管理工具”-“计算机管理”-“HID”，若HID或HID下面未显示驱动程序American Power Conversion USB UPS，请确保您计算机上的USB端口已启用。若您使用USB集线器（不推荐使用），则确保集线器已连接电源，检查集线器文档确定是否需要适配器，确保链路中最后一根USB电缆与UPS相连接，且确保所有位于UPS上游的USB设备已建立通信。

  • 若安装或连接下列设备，请检查其配置：

    • 网络管理卡必须完全配置且正常运行。

    • 若您使用PowerChute Business Edition代理监测接口扩展卡或8端口接口扩展器基本端口，则确保您使用正确的电缆（即UPS通信电缆要求中所列电缆），且安装扩展卡或扩展器时指定“简单信号附件”。若您不确定应指定何种类型的附件，请使用正确的设置重新安装扩展卡或扩展器。

  • 若要确定USB连接是否有问题，则用其它USB端口或USB电缆，也可使用终端模拟器确定是否连接正常，请参阅Windows系统下的UPS通信检查。

请注意：
若本节中所列故障排解方式仍未能解决问题，请联系APC全球客户支持部门(http://www.apc.com/support/)。


Windows系统下的UPS通信检查

若要检查使用高级信号的UPS与支持的Windows操作系统的计算机间的连接是否正常，可使用终端模拟程序。下列过程描述了超级终端的使用方法。

  1. 确保无其它服务上用通信端口。

  2. 打开超级终端：开始>程序（或所有程序）>附件> 通讯。

  3. 在“连接描述”对话框中键入名称以定义超级终端连接，然后点击“确定”。

    请注意：
    若显示“...必须安装调制解调器”，则忽略该消息。

  4. 在“连接到”对话框的“连接时使用”字段中，选择UPS使用的串行端口，点击“确定”。

  5. 在“端口设置”对话框中，确保该端口设置为“安装程序不能自动检测系统UPS”中为Windows系统所列设置。

  6. 当显示空屏时，键入大写字母Y。

    • 若屏幕上显示字母SM（智能模式），串行通信连接正常。

    • 若未显示SM，则键入大写字母A。若屏幕上显示OK确定，则UPS可接收信号，但无法进行发送。

      • 串行电缆可能有问题，请更换。
      • 计算机串行端口可能无法接收信号，因为端口存在中断冲突或故障。请尝试使用其它计算机。
      • UPS可能有问题，请尝试使用另一台APC UPS。

请注意：
若问题持续存在，请联系APC全球支持部门(http://www.apc.com/support/)。


安装旧版本

请先卸载当前PowerChute Business Edition代理版本再安装其旧版本。若您未先卸载当前版本，则安装过程可能损坏您正在安装的版本，并保留未使用或未删除的文件。


启动PowerChute Business Edition代理

请参见Linuxreadme.txt、Solaris_x86ReadMe.txt和SolarisReadMe.txt这三个文件，获取相关操作系统信息。

在Windows下完成安装后，PowerChute Business Edition代理自动开始运行。代理会在每次启动操作系统时自动运行。若要在终止PowerChute Business Edition代理后重新手动启动，则在文件系统任何位置的shell提示符内输入以下命令：

<pcbe_agent_directory>/bin/startup start


停止PowerChute Business Edition代理

请参见Linuxreadme.txt、Solaris_x86ReadMe.txt和SolarisReadMe.txt这三个文件，获取相关操作系统信息。

若要在Windows下终止运行中的PowerChute Business Edition代理，则在文件系统任意位置输入以下命令：

<pcbe_agent_directory>/bin/startup stop


卸载PowerChute Business Edition

  • Windows系统相关问题


Windows系统相关问题

当您在Windows系统下卸载PowerChute Business Edition时可能会出现以下问题：

  • Native UPS服务可能无法重启，请参阅错误消息“安装程序无法重启Native Windows UPS服务，您必须手动重启该服务，或重启电脑，激活电源保护功能”说明。

  • 若您从Windows操作系统下卸载PowerChute，虽能还原Native Windows UPS服务，但需进行配置以自动启动。

  • 卸载PowerChute Business Edition后，您可能需要手动删除一些文件或文件夹。若卸载后依然存在安装文件夹，应手动删除连同文件夹在内的所有内容。（默认文件夹\program files\APC\PowerChute Business Edition或指定安装路径的文件夹）。若PowerChute Business Edition是唯一安装的APC 产品，则也应一并删除APC文件夹。

  • 若在您尝试卸载PowerChute Business Edition代理时出现下述消息，则代理可能没有安装或未能响应：
    Error encountered while removing the Agent service. Please reboot after setup exits（移除代理服务时存在错误，请退出卸载程序并重启电脑。）

  • 若您的计算机为Windows 2003 Web Edition操作系统， 则在卸载PowerChute Business Edition时部分文件无法删除，但不会对计算机系统操作产生影响。

  • 若当您卸载PowerChute Business Edition代理时，Windows事件查看器中正打开PowerChute Business Edition事件，则您可能会看到下述令人误解的错误消息：
    InstallShield Wizard installed PowerChute Business Edition properly.（InstallShield向导已正确安装PowerChute Business Edition。）
    此处“安装”其实应为“卸载”。


操作问题

本节将论述影响PowerChute Business Edition使用的相关问题。

  • 所有操作系统的已知问题

  • Windows已知问题

  • 使用Microsoft Internet Explorer的已知问题


所有操作系统的已知问题

  • 并非总是记录UPS自检

  • 带外管理访问导致通信丢失事件


并非总是记录UPS自检

PowerChute事件日志并非总是记录UPS自检事件。

始终不记录由UPS前端面板触发的自检，有时也不记录由PowerChute或APC附件触发的自检。


带外管理访问导致通信丢失事件

当APC带外管理卡尝试获取UPS信息时，可能会导致PowerChute代理记录UPS通信丢失事件日志及随后产生的UPS通信已建立事件日志。


Windows已知问题

  • 待机模式暂时禁用代理

  • i iKernel.exe应用程序出错

  • 待机模式延迟预定关机时间


待机模式暂时禁用代理

当计算机处于待机模式时，PowerChute代理Windows服务不运行。


iKernel.exe应用程序出错

在Windows XP系统下完成PowerChute代理卸载后，“iKernel.exe - Application Error（iKernel.exe - 应用程序出错）” 对话框可能会显示以下错误：

The instruction at “0x771c741a”referenced memory at "00163b60". The memory could not be "read".Click on OK to terminate the program”

若要更正该问题，请从Microsoft Web页面http://www.microsoft.com/downloads/details.aspx?FamilyID=9cf87cda-c7f3-41a2-8ea3-cc4f03ff0e31&DisplayLang=en下载补丁并进行安装。尽管Web页面上文章显示为“DirectX可能造成DVD Players无法运行的相关问题 ”，但这个补丁和该问题相关。


待机模式延迟预定关机时间

若您的Windows计算机在（通过关机日程表命令）预定关机时处于待机状态，则在待机模式结束后才启动关机，即使已超过预定关机时间。

例如，若关机时间预定设置为晚上7点至上午7点，且计算机在晚上7点仍处于待机状态，则那个时候计算机不会自动关闭。但如果计算机在晚上9时恢复正常运行，则会在待机模式结束后关闭计算机。通知显示晚上7点开始关机，计算机将在一分钟后关闭，并再12个小时后再次开启。


使用Microsoft Internet Explorer的已知问题

  • 活动脚本的禁用导致PowerChute登录发生故障

  • “在IFRAME中加载程序和文件”禁用时的安全警报

  • PowerChute Business Edition代理的用户界面失真

  • 不支持检查网页内的“每次访问此页面时检查”选项


活动脚本的禁用导致PowerChute登录发生故障

若您禁用Internet Explorerr内的活动脚本：

  • 您无法登录到PowerChute Business Edition代理。

  • PowerChute Business Edition代理登录屏幕内的ActiveX控件标记为不安全。

如果活动脚本禁用，请启用。在Internet Explorer 6.0中，您可按如下方式启用活动脚本：

  1. 选择Internet Explorer“工具”菜单内的“Internet选项”。

  2. 选中“安全”选项卡，打开“自定义级别”设置。

  3. 在“脚本”选项下，启用靠近列表末端位置的“活动脚本”。


“在IFRAME中加载程序和文件”禁用时的安全警报

若禁用Internet Explorer内的“在IFRAME中加载程序和文件”选项，则在您登录PowerChute Business Edition代理时会显示安全警报。

如果“IFRAME中加载程序和文件”被禁用，请启用。在Internet Explorer 6.0中，您可按如下方式启用该选项：

  1. 选择Internet Explorer“工具”菜单内的“Internet选项”。

  2. 选中“安全”选项卡，打开“自定义级别”设置。

  3. 在“其他”选项下，启用“在IFRAME中加载程序和文件”。


PowerChute Business Edition代理的用户界面失真

在您启用Internet Explorer“不使用网页中指定的颜色”时，PowerChute Business Edition代理的用户界面会失真。

如果“不使用网页中指定的颜色”被禁用，请启用。在Internet Explorer 6.0中，您可按如下方式禁用该选项：

  1. 选择Internet Explorer“工具”菜单内的“Internet选项”。

  2. 选中“常规”选项卡，点击“辅助功能...”。

  3. 取消“不使用网页中指定的颜色”复选框标记。


不支持检查网页内的“每次访问此页面时检查”选项

Internet Explorer Web浏览器检查所存网页的较新版本的方式中，PowerChute Business Edition代理不支持“每次访问此页时检查”。

若要更正该问题，则将Internet Explorer 检查所存网页的较新版本的方式配置为“自动”。在Internet Explorer 6.0中，您可按如下方式进行配置：

  1. 选择Internet Explorer“工具”菜单内的“Internet选项”。

  2. 选中“常规” 选项卡，点击“Internet临时文件”区域内的“设置...”按钮。

  3. 选中“自动”。


Third-Party Software - 第三方软件

Portions of this software are copyrighted as follows:

  • Copyright (c) 1996 Jef Poskanzer

  • Copyright (c) 2000 The Apache Software Foundation

  • Copyright (c) 2000-2002 Brett McLaughlin & Jason Hunter

  • Copyright (c) 1993-2003 Chad Z. Hower (Kudzu) and the Indy Pit Crew

  • Copyright (c) 1998-2004 The OpenSSL Project

  • Copyright (c) 1995-1998 Eric Young

This product includes software developed by ACME Labs (http://www.acme.com)

Copyright (C) 1996 by Jef Poskanzer <jef@acme.com>. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Visit the ACME Labs Java page for up-to-date versions of this and other fine Java utilities: http://www.acme.com/java/

This product includes software developed by the Apache Software Foundation (http://www.apache.org/).

The Apache Software License, Version 1.1

Copyright (c) 2000 The Apache Software Foundation. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. The end-user documentation included with the redistribution, if any, must include the following acknowledgment: "This product includes software developed by the Apache Software Foundation (http://www.apache.org/)."

Alternately, this acknowledgment may appear in the software itself, if and wherever such third-party acknowledgments normally appear.
  1. The names "Apache" and "Apache Software Foundation" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact apache@apache.org.

  2. Products derived from this software may not be called "Apache", nor may "Apache" appear in their name, without prior written permission of the Apache Software Foundation.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the Apache Software Foundation. For more information on the Apache Software Foundation, please see <http://www.apache.org/>.

Portions of this software are based upon public domain software originally written at the National Center for Supercomputing Applications, University of Illinois, Urbana-Champaign.

This product includes software developed by the JDOM Project
(http://www.jdom.org/).

Copyright (C) 2000-2002 Brett McLaughlin & Jason Hunter. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the disclaimer that follows these conditions in the documentation and/or other materials provided with the distribution.

  3. The name "JDOM" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact license@jdom.org.

  4. Products derived from this software may not be called "JDOM", nor may "JDOM" appear in their name, without prior written permission from the JDOM Project Management (pm@jdom.org).

In addition, we request (but do not require) that you include in the end-user documentation provided with the redistribution and/or in the software itself an acknowledgement equivalent to the following:

"This product includes software developed by the
JDOM Project (http://www.jdom.org/)."

Alternatively, the acknowledgment may be graphical using the logos available at http://www.jdom.org/images/logos.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE JDOM AUTHORS OR THE PROJECT CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This software consists of voluntary contributions made by many individuals on behalf of the JDOM Project and was originally created by Brett McLaughlin <brett@jdom.org> and Jason Hunter <jhunter@jdom.org>. For more information on the JDOM Project, please see <http://www.jdom.org/>.

Portions of this software are Copyright (c) 1993 - 2003, Chad Z. Hower (Kudzu) and the Indy Pit Crew - http://www.IndyProject.org/

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation, about box and/or other materials provided with the distribution.

  • No personal names or organizations names associated with the Indy project may be used to endorse or promote products derived from this software without specific prior written permission of the specific individual or organization.

THIS SOFTWARE IS PROVIDED BY Chad Z. Hower (Kudzu) and the Indy Pit Crew "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)

Copyright (c) 1998-2004 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)"
  1. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.

  2. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.

  3. Redistributions of any form whatsoever must retain the following acknowledgment:

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)

Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young's, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used.

This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

"This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)"

The word 'cryptographic' can be left out if the rouines from the library being used are not cryptographic related :-).
  1. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

"This product includes software written by Tim Hudson (tjh@cryptsoft.com)"

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The licence and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution licence [including the GNU Public Licence.]