QuickAdmin v2.0 Documentation

QuickAdmin v2.0

QuickAdmin is a feature rich .NET component which aims to satisfy all your Web Database Administration needs.

Getting started

We recommend using a diagram of the table structure you wish to edit - it helps to visualise the relationships. Below is a diagram of the Products table from the IBuySpy Store, which we will be using for this demo.

To initialise QuickAdmin follow the instructions below:

  • Open Visual Studio .NET.
  • Create your new web project, or connect to an existing one.
  • Make the toolbox visible (this may require you to click View > Toolbox).
  • Right-click on the toolbox and click Customise Toolbox.
  • Click on the .NET Framework Components tab, and then click Browse.
  • Browse to your installation directory (probably C:\Program Files\Common Files\Cambro\QuickAdmin), and select the Cambro.Web.QuickAdmin.dll. Click Open, then OK.
  • A number of controls will have been added to your toolbox.
  • To organise the controls, drag the Admin control ( [image]) onto a new aspx page.
  • After a few seconds the controls will be organised in several tabs.
  • QuickAdmin is now ready for configuration.

Configuration

Right-click on the QuickAdmin control, and click Property Builder.

The dialog box pictured below will apear. This will enable you to configure QuickAdmin's database connection.

  • Choose your database type (SQL or OLEDB), and enter the connection string.
  • Enter the name of the table you want to edit in the Database Table textbox, and enter the name of the primary key column in the DataField textbox.
    (Note: if you have a joint primary key of two columns, specify the second in the DataField2 textbox)
    For the demo, the Database Table is 'Products' and the DataField is 'ProductID'.
  • Click on the Check Connection button to ensure the connection is working.
  • Click OK.

Right-click on the QuickAdmin control and choose Step 2/3 - Other Properties. This enables you to change the global QuickAdmin settings, and the default functionality (Search, Add, Edit, Delete, etc.) that QuickAdmin will expose. When you are finished, click OK.

Right-click on the QuickAdmin control and choose Step 3/3 - Templates Introduction.

Templates

There are five templates:

  • Simple Search - Defines the fields to search with the simple, full-text search (add one control per field)
    • Search a field in the local table with the Simple Local Search ( [image]) control
    • Search a field in a linked table with the Simple One-to-Many Search ( [image]) control
    • Search a field in a many-many linked table with the Simple Many-to-Many Search ( [image]) control
  • Advanced Search (optional) - Defines the fields on which to carry out an advanced search:
    • Search the local table using the Advanced Local Search ( [image]) controls
    • Search a linked table using the Advanced One-to-Many Search ( [image]) controls
    • Search a many-many linked table using the Advanced Many-to-Many Search ( [image]) controls
  • Results - This template should hold a single ResultsDataGrid ( [image]) control. This control displays the results of the search.
  • View - This template determines the controls present in the View, Edit and Add pages:
    • Edit a field in the local table with the Local Edit ( [image]) controls
    • Edit a field in a linked table with the One-to-Many Edit ( [image]) controls
    • Edit a field in a many-many linked table with the Many-to-Many Edit ( [image]) controls
  • Data (optional) - The DataList ( [image]) control allows you to create simple data lists for use in various controls.
    This enables you to map a set of integer values in the database to string reprasentations in a drop-down or other control.

Simple Search Template

Right-click on the Admin panel and choose Edit Template > Simple Search

Text based fields (varchar, text, memo etc.) may be included in the simple search by adding a Simple Search control to the template. Add one Simple Search control for each field to be included in the search.

For fields that are in the local table, drag a Simple Local Search ( [image]) control from the toolbox (above right) into the template (above left). The control will appear in the template as below:

Right-click on the control and select Property Builder. You will be presented with the following dialog box:

In the Local Field textbox, enter the name of the field to be included in the search. For this demo, enter 'ModelName', and then click OK. The control should change to show it has been correctly configured, as below:

If you are following the IBuySpy demo, add Simple Local Search ( [image]) controls for the ModelName and Description columns.

Now drag a Simple One2Many Search ( [image]) control to the template. Open the property builder and set the values as below. If you view the database structure at the top of this page you will see how the link between the Products and Categories tables is created. We specify that the CategoryID field in the Products table is associated with the CategoryID field in the Categories table, and we specify that the field to be included in the simple search is CategoryName.

Configuration of the Simple Search is complete. We'll move onto the advanced search template. Right click on the template header, and choose Edit Template > Advanced Search.

Advanced Search Template

Above left is Advanced search toolbox tab. Drag a LocalTextBox ( [image]) into the Advanced Search Template and open the property puilder. This contains more options than in the case of the Simple controls.

  • As before, the field to be searched should be entered in the LocalField box.
  • The Title box enables you to specify the title of the Advanced Search Control (displayed in the left column of the advanced search panel).
  • The Match Multiplier is used in a fuzzy search to weight the ranking.
  • The Quotes check-box should be checked if the LocalField is text-based, and requires quotes in the SQL query.

After completing the advanced search property builder, the control will look as below:

Now for a slightly more complex Advanced Search control - drag a One2ManyDropDownList ( [image]) into the template and open the property builder.

You will be presented with the above dialog. Here the default value for Quotes is false, as the Local Field in such a relationship is usually an integer. The Foreign Group Fields will be described later in this document. When the above is complete, click OK.

For all tables which are linked to the local table in a One-to-Many relationship, you can use the Advanced One-to-Many Search ( [image]) controls to search them. For the field above, the current control could be replaced with any one of: One2ManyCheckBoxList ( [image]), One2ManyListBox ( [image]), One2ManyRadioButtonList ( [image]) or a One2ManyTextBox ( [image]).

Create another couple of Advanced Search controls, one to search the Model Number ( [image]), and another to search the price of the product and return any within a specified range ( [image]).

Results Template

Drag the ResultsDataGrid ( [image]) control into the template:

Again, right-click and choose Property Builder. The most important setting for the ResultsDataGrid is the Data Key Field, which is the primary key of your local table. You should enter 'ProductID' in the case of this demo. If you have a joint primary key you can specify the second key in the Data Key Field 2 box.

After setting the key field(s), the columns visible to the user must be added. Click to the Columns tab on the left of the dialog, and you will be presented with the following:

The ResultsDataGrid is similar to the DataGrid control with a few extras. The supported column types are Results Column, Hyperlink Column and Template Column.

Results Column

The most regularly used is the Results Column, which displays as a generic column in the grid. Select Results Column, and add it to the Selected Columnns list by clicking the arrow button. Ensuring the column you have just added is selected, enter the following information in the dialog:

Click OK, and the ResultsDataGrid will render the first 100 records from the database. Add two more columns, one for ModelName, the other for ModelNumber.

You can also add a column for the CategoryName, as this is in a table linked by a search control (see 'Important Note' below).

Important note

The columns that are available for display in the Results Data Grid are restricted to those in tables that are linked in the Search controls.

This means that if you want to display a field in a linked table, you need to ensure that at least one search control defines the link to the table which contains the field. (Only One-to-Many and Many-to-Many search controls create links to other tables).

The other options in this dialog are explained below:

  • Footer Text - If the Show Footer check-box is checked on the General page of the ResultsDataGrid property designer, this text appears at the bottom of the results column.
  • Header Image - If specified, this displays an image in the header instead of the text
  • Sort Expression - If the Allow Sorting check-box is checked on the General page of the ResultsDataGrid property designer, this field determines on which field to sort. If specified, the header will appear as a link that changes the sorting.
  • Visible - This shows and hides the column.
  • Table - This must be specified if the Data Field specified an ambiguous column name (one that appears in more than one table - e.g. CategoryID in the demo).
  • Data Format String - Use this to format the results.
  • Tool Tip - This is displayed in a tool-tip when the mouse is hovered over the column.
  • DataSet to bind to - This field is used to bind a DataSet to the column - it will be explained later in the document.
  • Allow Click Through To View Page - If checked, this renders as a link to the View/Edit page.
  • Text Or Memo Field – If this database field is a large text type (Text in SQL, Memo in Access), this should be checked.

HyperLink Column

Another useful column is the HyperLink column. See below for an example relevant to this demo:

The search results are products on the IBuySpy Store Demo. A relavent link would be to the product on the website itself. Complete the column as in the image above.

Several additional properties are available for the HyperLink column:

  • Text and URL - Specifies the Text or URL properties of the link without binding to the data.
  • Data Text Field and Data URL Field - Specified the field in the results set to bind to either the Text or URL property of the link.
  • Data Text Field Table and Data URL Field Table - These should be specified if either the Data Text Field or Data URL Field specify an ambiguous column name (a column name that appears in two linked tables).
  • Data Text Format and Data URL Format - Use these to format the Text or URL of the link.
  • Target - This is the target html propery of the link - e.g. which window the link should open in. Set to '_blank' for a new window.

Paging

Moving on, we look at the possibilities of paging:

QuickAdmin looks after the paging for you; all you need to do is specify what sort of paging you want. Here, we've specified paging by Page Numbers, showing the navigation buttons at the bottom of the page.

View Template

Finally, you need to create the View/Add/Edit part of QuickAdmin. This is the part where users get to view, change and add new records to the database. It is entirely up to you what the users are able to do to the database and you’ll see how easy it is. Firstly, here are all the controls you have to choose from:

To create the View template, there are a couple of important properties to be aware of. Each Edit control has an Addable and Editable property. If a Edit control is Addable, a value can be set in Add mode, otherwise the field is hidden. If a control is Editable, it will be editable in Edit mode, otherwise its value will just be displayed, but cannot be changed. Below is the finished View template.

Once you are done, select the Template, Right-click and choose End Template Editing. Right-clicking on the Admin panel now will enable you to Show and Hide the Advanced Search controls, change the rendering mode from Search to Results, View, Add and Edit, depending on your settings. When you are happy, right-click on the page and select View in Browser – you will now have a fully working QuickAdmin page for the Products table of the IBuySpy Store.


QuickAdmin v2.0 Documentation

QuickAdmin v2.0

QuickAdmin is a feature rich .NET component which aims to satisfy all your Web Database Administration needs.

Advanced Configuration

DataLists

DataLists are remarkably easy to use but very powerful. Provided with your Install are some IBuySpy Demos. If you haven’t installed this Demo from Microsoft it is well worth it; if you don’t want to install it, follow this walk-through anyway, as it is not crucial to actually complete this demo to understand how these controls work.

Right Click on your QuickAdmin panel in design-mode and click Edit Template – Data.

You will be presented with an Empty Template. Drag the DataLists control from the toolbox (left) into the Empty Template. You will be presented with something resembling the right image.

As it says on the DataLists control, you must add Items to this Controls Collection by clicking on the Items | (Collection) row in the properties window and clicking the button which appears on the right. You will be presented with a dialog box. Click on the Add Button and it will look something like the image below:

In the case of the Reviews page from the IBuySpy Store, based on an integer value coming out of the database in the range 1 to 5, we want to display a graphic. We need to therefore create 5 different ListItems. Firstly, we add a value of 1 to the Value field. We then add an image tag:
<img src='http://www.ibuyspystore.com/images/ReviewRating1.gif' border=0> into the Text Field.

This is repeated for all the rest of the values between 1 and 5 with the text changing to …ReviewRatingx.gif…. where x is the Value in the database.

(Note – these images are being called from the Microsoft site. For faster download speed etc… it is probably best to reference a local copy. Also, you obviously won’t get the images if you are not connected to the internet)

Once you’ve added all the ListItems, click OK. Retuning to the Design page, you should now see your DataLists rendered differently:

Finally, to use your DataLists, you can use any control which has the DataSet property. Just set the DataSet to equal the ID of your DataLists. This can be done in the ResultsColumn, Edit Control and Search Controls.

(Note – here we have used html, which will render onto the page and call the image from the IBuySpy site. If you try and use an EditDropDownList or LocalDropDownList you’ll see that the text will appear in the dropdown and not the image as ‘text’ is treated as text. An EditRadioList or LocalCheckBoxList will work as it is written directly to the page and is parsed as html. If it was crucial to use a DropDown, simply setting the text of value 5 to be ‘Fantastic’, value 1 to be ‘Awful’ would work fine.)

Foreign Group Fields

On occasion, you want to create links between two tables – in this demo of the Territories page in the Northwind database, each territory has at least one Employee assigned to it. When you create a link between the two tables you can either choose to display the Employees FirstName or LastName, but not both. This becomes a major dilemma if you have more than few employees. You’re bound to get multiples of Jones’ or Smith’s or James’. This is where the ForeignGroupFields come in. Firstly, look at the Many2ManyCheckBoxList in the Advanced Controls on the Territories page. You only get the surname. Right Click and open the Property Builder. You should be presented with the dialog below:

The way the Foreign Group Fields are used here are this: "SELECT ForeignGroupFields AS ForeignDataField, ForeignKeyField FROM ForeignTable". Even if you don’t know SQL, you can see how useful this is. You could put not only the FirstName and LastName in, but their unique ID, age, position, title – anything in the Employees Table. Your only consideration is that the ForeignDataField is not the name of any other field. Below is how the above dialog can be changed to produce their Full Name in a EditListBox, Many2ManyCheckBoxList etc...

Rolling-out to a different Server

I’m going to show you a cunning way to use a different Database Connnection String on your live site compared to your development environment. Firstly, you need to create yourself a new class. Right click on you solution and click Add | Add Class. Call your new class QuickAdminPage. When it opens, you’ll already have had some code generated for you. You need your class to inherit from Page so on the line:

public class QuickAdminPage

change to:

public class QuickAdminPage : System.Web.UI.Page

Delete:

public QuickAdmin()
{
    //
    // TODO: Add constructor logic here
    //
}

Add:

using System.Web;
using Cambro.Web.QuickAdmin;

to the top of the page.
Create a new Method:

public void SQLInit(object sender, System.EventArgs e)
{
    switch (System.Environment.MachineName)
    {
        case "TESTMACHINE":
            ((Admin)sender).SqlDBConnStr = "Data Source=xxx.cambro.net; Initial Catalog=Store; User Id=xxx; Password=yyy;";
            break;
        default:
            ((Admin)sender).SqlDBConnStr = "Data Source=yyy.cambro.net; Initial Catalog=Store; User Id=xxx; Password=yyy;";
            break;
    }
}

where TESTMACHINE is replaced with the name of your machine or the machine which the test site runs on, and you place the correct SQL or OLE DB connection string in that case statement. Likewise, you replace the second SQL or OLE DB connection string with the connection to the server which is used for your main sites.

All that you need to do now is use this class. In the HTML view of your pages, you need to change the

<%@ Page trace=false language="c#" AutoEventWireup="false" %>

To:

<%@ Page trace=false language="c#" AutoEventWireup="false" Inherits="YourNamespace.QuickAdminPage" %>

Where ‘YourNamespace’ is the namespace in your class file.

Finally, you need to use the function. This is where events come in…..

Web Control Events

The Admin Control of QuickAdmin is a Web Control, so has all the usual Web Control events associated with it. Because it does some useful data manipulation, it is important to be able to step in when QuickAdmin is about to delete a record, for example. It fires other, special events, at important moments.

Carrying on with the above example, we need to fire the SQLInit function every time that QuickAdmin loads in the page, and before any Database manipulation occurs. When better, than when QuickAdmin is initialised? – let’s use the OnInit event.

If you are continuing from the above example, you’ll need to finish with the following steps. Otherwise, just read this example and move on to the next event example.

Move into design view of one of your QuickAdmin web forms. Select the Admin Control on the page, and then view the Properties. At the top of the Properties window there will be a fire bolt. Click on this. You will be presented with a list of events. In the Misc Category, click on the space to the right of Init. From the DropDown, choose SQLInit. Now, every time QuickAdmin runs, it will choose one of two connections to your database, depending on the server it is running on. To do this for every page, you need to include the inherits="..." from above and hook up the SQLInit to the OnInit of QuickAdmin.

(Note: This example can also be done for OLEDB connections)

(Note: If you provide a SQL connection or OLEDB connection when you design QuickAdmin, you will still be able to use the design-time support. Any Connections will be overridden by SQLInit when QuickAdmin runs on your website.)

QuickAdmin Events

Doing certain things, such as discovering the sort of search the user has done, how many results the user will be presented with, what record is being deleted or whether the user has permission to change specific data can be crucial to ensure users cannot view, manipulate or delete information they do not have rights to. Basic permissions such as showing the add button so the user can go into add mode, or not showing the delete button so no records can be removed can be set at design-time, but how can you dynamically change these based on the user, or what is being viewed by that user?

On the website, there are some advanced demos which use events to create this functionality. Below are some examples:

This example when fired by the OnSearched event, tells the user if they have done a fuzzy search with no text in the simple search textbox that the results will all have rank of zero.

public void DoMySearched(object sender, Cambro.Web.QuickAdmin.SearchedEventArgs e)
{
       if (e.SearchType == SearchCriteria.Fuzzy && e.SimpleSearchText == "")
       {
        e.DisplayMessage = true;
        e.MessageLocation = Location.Popup;
        e.MessageText = "Oops!\\nAn empty search in Fuzzy search mode returns 0 ranking for all records!";
       }
}

This method is fired by the OnViewing event. If the user selects to view a record with PrimaryID = 2, which is the ID of the present user, they are not allowed to edit it. (Note: 'PrimaryID = 2' does not need to be hardcoded, it could come from a cookie or session).

public void DoMyViewing(object sender, Cambro.Web.QuickAdmin.ViewingEventArgs e)
{
    if (e.PrimaryID == "2")
    {
        e.AllowEdit = false;
        e.MessageText = "<b>Sorry Andrew, you can't edit your own record.</b>";
        e.MessageLocation = Location.Top;
    }
    else
    {
        e.AllowEdit = true;
        e.MessageLocation = Location.Top;
        e.MessageText = "The Employees you manage Andrew can be edited.";
    }
    e.DisplayMessage = true;
}

When this function is fired by the OnSearching event, it determines all the users associated with the present user (Id = 2) and only returns those records.

public void DoMySearch(object sender, Cambro.Web.QuickAdmin.SearchingEventArgs e)
{
      e.Results = 40;
      e.WhereClause="(Employees.EmployeeID = 2 OR Employees.ReportsTo = 2)";
}

There are more of these listed on the site, under Advanced Demos.

Traversing the Hierarchy

In these events, you may want to find out the exact value of a Search Control or View Control. What’s the best way of doing this? Using the QuickAdmin events, you can navigate the Control Collection from the Admin Control like so:

private void Admin1_Adding(object sender, Cambro.Web.QuickAdmin.AddingEventArgs e)
{
    for ( int i = 0 ; i < ((Admin)sender).ViewContainer.Controls.Count ; i++ )
    {
        Control c = (Control)((Admin)sender).ViewContainer.Controls[i]
        // Do whatever you want here
    }

}

Or

private void Admin1_Searching(object sender, Cambro.Web.QuickAdmin.SearchingEventArgs e)
{
    for ( int i = 0 ; i < ((Admin)sender).SearchContainer.Controls.Count ; i++ )
    {
        Control c = (Control)((Admin)sender).SearchContainer.Controls[i]
        // Do whatever you want here
    }
}

Customising the appearance of your QuickAdmin

We have provided you with the style sheet we use for our QuickAdmin pages. This can be customised easily to fit any website scheme. All of the QuickAdmin Search and View controls can be tweaked to fit your style too, as well as the ResultsDataGrid which is styled exactly as the DataGrid can be. To change the layout of the Advanced or Edit Controls is trickier, but should not be a problem for anyone with knowledge of HTML.

All Edit and search Controls are rendered as a table row:

<tr><td class=lefttitle>Title</td><td class=rightvalues>Control</td></tr>

To customise this, you can place just inside the <AdvancedSearch> tag:

<tr><td><table>

half way down:

</table></td><td><table>

and at the bottom:

</table></td></tr>

The Advanced Search Controls will then be rendered in two columns.

This however causes problems with Visual Studio .NET.

To prevent problems, use Literal Controls which can be found in the Web Forms tab of the Toolbox. These should be dragged into the Template where necessary and edited using the Properties Window.

Creating your own Controls

QuickAdmin has been designed in such a way that it is very easy to tailor to your needs. What happens if none of the Search Controls supplied by QuickAdmin do the search that you want to do? What happens when you want to use an Edit Control in QuickAdmin which uses the Html Edit Control supplied by another company? Simple – create your own control.

Creating an Edit Control

A few people have said that the Calendar Control supplied by Microsoft is all very well, but not only does it do postbacks every time you click on it, but it takes ages to get to the date you want to get to, even if you are only a year away. After telling a couple of people how easy it would be to create a control to do enable quick date selection, I did it myself. It was easy – if you knew how everything worked.

Here goes nothing…

The Interfaces:

  • IBindable – ensures values can be bound from the database
  • IResetable – ensures the records can be cleared
  • IDate – tells QuickAdmin to handle the output as a date
  • ILocal – tells quickAdmin that this references a field in the local table.

Right, firstly we are not going to re-invent the wheel, we are going to use an existing Edit Control Template which comes with QuickAdmin, which happens to be called EditControl. We are going to implement all the above Interfaces:

public class EditDateSpecial : EditControl, IDate, IResetable, IBindable, ILocal
{

}

That’s a start. Now we need to work out what we need. I wanted to have one DropDown which displays a list of years and another which displays all the months. We also want a Calendar control, bearing in mind we want to be able to select dates. I want to give the person using this control some flexibility, so let them choose the range of years which will appear. Also, I want to let them specify what date to start the calendar on.

private DropDownList Months;
private DropDownList Years;
public int StartYear = 1900;
public int EndYear = 2010;
private Calendar Cal;
public DateTime StartDate;

Next, we want to create the constructor, initialise all the controls, add them to the controls collection of this control and set up a couple of events to fire when the choices in the drop downs change.

public EditDateSpecial() : base()
{
    Cal = new Calendar();
    Months = new DropDownList();
    Years = new DropDownList();
    Months.SelectedIndexChanged += new EventHandler(ChangeMonths);
    Years.SelectedIndexChanged += new EventHandler(ChangeYears);
    Months.AutoPostBack = true;
    Years.AutoPostBack = true;
    this.Controls.Add(Cal);
    this.Controls.Add(new LiteralControl("<BR>"));
    this.Controls.Add(Months);
    this.Controls.Add(Years);
}

Another easy part is to generate the lists for the two drop downs. I do this on OnLoad.

protected override void OnLoad(EventArgs e)
{
    base.OnLoad(e);
    if (Months.Items.Count == 0)
        AddMonths();
    if (Years.Items.Count == 0)
        AddYears();
}
private void AddYears()
{
    int Counter = StartYear;
    while (Counter <= EndYear)
    {
        Years.Items.Add(new ListItem(Counter.ToString(),Counter.ToString()));
        Counter++;
    }
    Years.Items.FindByText(Cal.TodaysDate.Year.ToString()).Selected = true;
}

private void AddMonths()
{
    Months.Items.Add(new ListItem("January","1"));
    Months.Items.Add(new ListItem("February","2"));
    Months.Items.Add(new ListItem("March","3"));
    Months.Items.Add(new ListItem("April","4"));
    Months.Items.Add(new ListItem("May","5"));
    Months.Items.Add(new ListItem("June","6"));
    Months.Items.Add(new ListItem("July","7"));
    Months.Items.Add(new ListItem("August","8"));
    Months.Items.Add(new ListItem("September","9"));
    Months.Items.Add(new ListItem("October","10"));
    Months.Items.Add(new ListItem("November","11"));
    Months.Items.Add(new ListItem("December","12"));
    Months.Items.FindByValue(Cal.TodaysDate.Month.ToString()).Selected = true;
}

Next, in the constructor, we mentioned two event handlers – ChangeMonths and ChangeYears. Now to write these functions. All that happens when the event is fired, is that TodaysDate property of the Calendar is changed by the month or year. Easy…

public void ChangeMonths(object o, EventArgs e)
{
    Cal.TodaysDate = new DateTime(Cal.TodaysDate.Year,System.Int32.Parse(Months.SelectedItem.Value),Cal.TodaysDate.Day);
}

public void ChangeYears(object o, EventArgs e)
{
    Cal.TodaysDate = new DateTime(System.Int32.Parse(Years.SelectedItem.Text),Cal.TodaysDate.Month,Cal.TodaysDate.Day);
}

Now, that has all seemed remarkably easy hasn’t it? Next comes a slightly more taxing, but by no means difficult part. Firstly, QuickAdmin will ask our control at various points during its life for a date to store in the database. How do we tell it what date to use? There is a textValue property which is called by QuickAdmin to return a string which, as we are using a IDate, will be stored in the database as a date. It is as simple as:

public new string textValue
{
    get { return Cal.SelectedDate.ToString(); }
    set { Cal.SelectedDate = System.DateTime.Parse(value); }
}

We use the new keyword to override the implementation by the base EditControl we have inherited from. Next, we have to handle a string coming out of the database which is a date. Most of the time it is a date in a string representation, but sometimes it is null or an empty string. We need to be aware of all of the possibilities to ensure the Control will not fail. Also, how does the Calendar Control handle nulls itself? Well, over time, I noticed that if you submit a Calendar Control not having selected anything, the date is 01/01/0001. So, we can now write our Bind function:

public new void Bind(string bound)
{
    try
    {
        if (bound == null || bound == "")
        {
            if (StartDate == new DateTime(0001,01,01))
            {
                Cal.TodaysDate = System.DateTime.Now;
                Cal.SelectedDate = new DateTime(0001,01,01);
            }
            else
            {
                Cal.TodaysDate = StartDate;
            }
            RealValue = bound;
        }
        else
        {
            Cal.SelectedDate = System.DateTime.Parse(bound);
            Cal.TodaysDate = System.DateTime.Parse(bound);
        }
    }
    catch{}
}

Mentioned above is something I’ve used called RealValue, which I use to keep track of what was originally set as the date of the Calendar Control. It is a private string.
Finally, the most taxing, and once you’ve seen it you’ll realise that it really isn’t. The overridden Render function. This is where you can fit your control into the QuickAdmin ‘framework’ seamlessly. First, the easy half…

protected override void Render(HtmlTextWriter w)
{
    if (this.ParentAdmin.Mode == Admin.Mode.Edit && Editable == true || this.ParentAdmin.Mode == Admin.Mode.Add && Addable == true)
    {
        w.Write("" +Title+ " ");
        base.Render(w);
        w.Write(" ");
    }

Simple isn’t it? Next, the ‘hard’ bit.

else
    {
        w.Write("" +Title+ " ");
        try
        {
            if ((RealValue == null || RealValue == "") && Cal.SelectedDate == new DateTime(0001,01,01))
                w.Write("[null]");
            else if (Cal.SelectedDate != new DateTime(0001,01,01))
                w.Write(Cal.SelectedDate.ToShortDateString());
        }
        catch{}
        w.Write(" ");
    }
}

If you compile this in your namespace, and reference it in your page, you should be able to start using this control immediately. What next? Maybe you could try to make it possible to extract and add time information to the database too (this is possible, though a little tricky).

Creating a search control

Creating your own Advanced Search controls is as easy as creating any control. The two big hurdles though are the Render function and the ISearchable Interface. The Render function is identical to the top half of the one above if you exclude the ‘if’ statement. This will fit your control into the QuickAdmin framework. The second, and bigger hurdle, is to generate two pieces of SQL which will be used when doing an exact or fuzzy search. I have outlined what they should produce below:

public string MakeRank()
{
    if (Text.Length > 0)
    {
        string RANK = "";
        RANK = " + (CASE WHEN [" + this.ParentAdmin.Table + "].[" + LocalField + "] LIKE '%" + Text + "%' THEN " + Text.Length + " ELSE 0 END) ";
        return RANK;
    }
    return "";
}

As you can see, this is a slightly cut down version of the EditTextBox MakeRank() function. The case statement above is of the format:

Case
When [Expression] Then [Score] (1 or more occurrences)
Else [Score] (Exactly 1 occurrence)
End

and should always be enclosed like so:

"[space]+[space]([Case statement])[space]";

In the event the user has made no changes to the Advanced Control, it should always return an empty string.

The second function looks after the Exact search:

public string MakeExact()
{
    if (Text.Length > 0)
    {
        string temp = "";
        temp = "[" + this.ParentAdmin.Table + "].[" + LocalField + "] LIKE '%" + Text + "%'";
        return "(" + temp + ") AND ";
    }
    else
        return "";
}

There are the same concepts as in the MakeRank() function. In the eventuality that there is no user input, an empty string is returned. The format of a correct statement is:

"([Expression])[space]AND[space]"

Multiple statements can be combined:

"([Expression] OR [Expression2] OR [Expression3])[space]AND[space]"

As before, there is also the IResetable Interface to use and the ILocal Interface (for Local Table Fields), IOne2Many (for Linked Tables) or IMany2Many (for Many2Many relationships).

And Finally...

HTML View Intellisense

If you want the intellisense to appear in the HTML View of your page, you need to add the following to any HTML tag in which the QuickAdmin:Admin tag is nested (i.e. <HTML> or <BODY>)

    XMLNS:QuickAdmin="http://schemas.cambro.net/QuickAdmin/Version2"

where the QuickAdmin= can be replaced by the TagPrefix string which is created at the top of the page when you drag and drop QuickAdmin. (by default this is something like cc1)

Design-Time support for your own Edit & Search Controls

To enable Design-Time support for any of your own QuickAdmin Edit and Search controls, you need to add an attribute to your control. No matter what sort, be it Many2Many or Local, you can use the QuickAdmin Control Property Builder by placing the following above your control in your code:

    [Designer("Cambro.Web.QuickAdmin.Design.SearchDesigner,Cambro.Web.QuickAdmin")]


Cambro.Web.QuickAdmin

Cambro.Web.QuickAdmin Class Library

Cambro.Web.QuickAdmin Namespace

Namespace hierarchy

Classes

Class | Description
AddingEventArgs | Arguments thrown by the OnAdding Event. This Event occurs when the Add button is clicked (when a blank form is presented)
Admin | Control which enables a user to create an administration section for their database
Advanced | Control Class Advanced Contains the Advanced Controls
baseEventArgs | These are the base Event Arguments thrown by all the Events.
DataLists | Summary description for DataList.
Db | Class contains static methods to create Database Queries, Selects etc
DeletedEventArgs | Arguments thrown by the OnDeleted Event. This Event occurs once the record has been Deleted from the database
DeletingEventArgs | Arguments thrown by the OnDeleting Event. This Event occurs before the record is Deleted from the database
EditCheckBoxList | This control creates an edit control which binds fields from a Many to Many relationship, allowing the user to select none, one or many links based on various properties.
EditControl | This Edit Control is a control which can be used to create special Edit Controls. This needs to be inherited and implemented as you like.
EditDate | Control which creates an edit Calendar control bound to the LocalField. This control allows the user to edit the datetime fields of the records in your database table.
EditDropDownList | This control creates an edit control which enables the user to select a value for this field in the relevant record based on the value of a Drop Down List which could come from a linked table or a DataLists Control.
EditFileUpload | An edit control which enables uploading of files to the database. In view mode, if a record exists it will say, otherwise it will say it is empty, and lets the user upload a file in edit mode if they specify one, otherwise the file in the database will be persisited.
EditingEventArgs | Arguments thrown by the OnEditing Event. This Event occurs when the Edit button is clicked (when going into edit mode from view mode)
EditIntBox | This control creates an edit control which allows the user to edit a integer or other numeric field from the database table.
EditListBox | This edit control allows the user to view a list of all the possible Many to Many links from the database and select either one or multiple rows to store in the database
EditNote | This control creates a an edit control of type textbox of size cols x rows. This can be used to edit text/varchar/ntext/memo etc fields from your database. This control allows the user to edit the specified field of any record in view mode.
EditRadioList | Control to create an edit control comprised of a Radio Button List propagated from a user specified DataLists Control.
EditTextBox | Control which creates an edit control of type text box with the text field bound to the LocalField
EditTrueFalse | Control which creates an edit control which is comprised of a True or False Radio Button List. This control enables users to select a true or false value to store in a boolean or bit field.
HyperLinkColumn | Just exactly as Microsoft want it
idEventArgs | Arguments thrown by the Events when QuickAdmin is in Add/Edit/View Modes which enables the user to determine the Record in question.
InsertedEventArgs | Arguments thrown by the OnInserted Event. This Event occurs once the new record has been Inserted into the database
InsertingEventArgs | Arguments thrown by the OnInserting Event. This Event occurs before the new record is Inserted into the database
Local | Class which creates a Control which searches textual data from the LocalField of the Local Table. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.
LocalBetweenDate | Creates a Search control with the ability to select a day, week or month. To select a day, just click the correct day, to select a week click the button to the left of the first day of the week and to select the month, click on the button in the top right. This enables the user to select a range of days and search on the LocalField for a date between those two days. If no selection is made the no filtering by this date is done, if any selection is made then all the records which have a Date in the LocalField which is between the date(s) specified will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalBetweenDateTwice | Creates a Search control with the ability to select a range of dates using two Calendar controls. In the event that no selection is made, the records are not filtered by the Date. In the event that the 'Start Date' Calendar control only is clicked, then all records in which the date is on or after the selected date will be returned. Likewise, only selecting the 'End Date' Calendar control will search the LocalField for dates which dates which occur previous to the selected date. In the event that both calendar controls have dates specified, then records will only be returned if the LocalField value occurs between both. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalBetweenValue | Creates a search control which prompts for the user to supply two numeric values to search between. In the case that nothing is entered, this control is ignored. If the first box is filled, and the second is not, only records with values greater than or equal to the value entered will be returned. Likewise, it only the second box is filled, only values which are less than or equal to the entered value will be returned. If both boxes are entered, then values in the range are returned, including values which match the entered values. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalCheckBoxList | This creates a Search Control of Check boxes which is bound from a DataLists Control enabling the user to search the LocalField. i.e. Rather than creating a linked table with a Integer Primary Key and a Text Field with the values 0 - Disabled, 1 - Enabled, 2 - Deleted with the Primary Key stored in the LocalField, a datalist with these values can be created so the user selects from Disabled, Enabled and Deleted and the value is stored locally with the above referenced table never existing. In a Exact search, no selections will return any records that match the rest of the search, one selection will return only the records which match that selection, and multiple selections will return those records that match one of the selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalDropDownList | Control which creates a Drop Down List from a DataList, allowing the user to search on none or one items from the DataList. In an Exact search, no selections will return anything that matches the rest of the search, one selection will restrict the results to the records which match the selection. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier. See LocalCheckBoxList for more information.
LocalIntBox | This control creates a Search Control which searches the LocalField for integer values. If the box is empty, no search is done, otherwise an exact match is required to return any selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalListBox | Control which creates a ListBox from a DataList, allowing the user to select none, one or more records from the listbox. In an Exact search, selecting none returns everything that matches the rest of the search, one returns any record that matches that choice and multiple selections return all the records that match any of the selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier. See LocalCheckBoxList for more information.
LocalOnDate | Creates a Calendar control with the ability to select one date. If no selection is made then the search does not search on the date. If a selection is made, then only the records with that exact date in the LocalField will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalTextBox | Creates a TextBox which allows the user to search on the LocalField for this text. It will only return exact matches and no search is done when the box is empty. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
LocalTrueOrFalse | Creates a Control with a True and a False Check Box, which allows the user to search on bit fields or booleans in the database. In an Exact search, leaving both ticked or unticked returns all records which match the rest of the search. Ticking one and not the other will only return the relevant records. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
Many2Many | Control which searches textual data from a Table linked by a Many to Many relationship to the Local Table. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.
Many2ManyCheckBoxList | Control which creates a Search control containing a Check Box List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If more than one selection is made, any records that match at least one of the records will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
Many2ManyDropDownList | Control which creates a Search control containing a Drop Down List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
Many2ManyListBox | Control which creates a Search control containing a List Box of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If more than one selection is made, any records that match at least one of the records will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
Many2ManyRadioButtonList | Control which creates a Search control containing a Radio Button List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
Many2ManyTextBox | Control which creates a Search Control containing a TextBox. If no text is entered, then the search is not affected by this control. If text is entered, then only records that match the text exactly will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
One2Many | Control which searches a linked table field for textual data when the link is defined by a One to Many relationship. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.
One2ManyCheckBoxList | Check Box List Control which displays values from a linked table in a checkbox list to the user. If no Check Boxes are ticked, the search is not affected. If one box is ticked, only records which match that selection are returned, if multiple are ticked then any records that match any of the selections are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
One2ManyDropDownList | This control creates a Search control which searches a linked table. A list of the possible values are displayed in a Drop Down List for the user to select from. In the event that no selections are made, the search is not affected. If an item in the list is selected, then only records that match that selection are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
One2ManyListBox | This control creates a Search control which extracts values from a linked table and displays them in a list box. In the event that no selections are made, this control does not affect the search. If one selection is made, then only records that match that selection will be returned. If multiple selections are made, then any record that matches any of the selections will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
One2ManyRadioButtonList | This control creates a Search control which searches a linked table and displays the possible links in a Radio Button List. If No selections are made, the search is not affected. If one selection is made then only records that match that selection are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
One2ManyTextBox | Control which allows the user to search on text values in a One2Many Table. This search control does not search when the text box is empty, and only returns results that match exactly if the text box is not empty. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.
ResettingEventArgs | Arguments thrown by the OnResetting Event. This Event occurs when the Reset button is clicked, but before everything is Reset
ResultsColumn | Control which inherits from BoundColumn
ResultsControl | Control which contains and controls the ResultsDataGrid
ResultsDataGrid | Customised DataGrid which enables Paging and Sorting based on the search type, and adds a Rank Field if necessary
SearchControl | Controls whic contains the Simple and Advanced Search Controls
SearchedEventArgs | Arguments thrown by the OnSearched Event. This Event occurs when the Search button is clicked and after the search is done
SearchingEventArgs | Arguments thrown by the OnSearching Event. This Event occurs just before a Search is done, and before the Results have been propagated.
Simple | Simple Control Class which enables Text searching on a number of Fields in the database
StrMan | Class Containing Static Functions
TemplateColumn | Just exactly as Microsoft want it
UpdatedEventArgs | Arguments thrown by the OnUpdated Event. This Event occurs once the new record has been Updated in the database
UpdatingEventArgs | Arguments thrown by the OnUpdating Event. This Event occurs before the record being edited is Updated in the database
ViewControl | Control which contains and controls the View, Edit and Add Functionality
ViewingEventArgs | Arguments thrown by the OnViewing Event. This Event occurs when a link in the DataGrid is clicked and QuickAdmin goes into View Mode.

Interfaces

Interface | Description
IBindable | Interface to be implemented by all Controls to be used in the View/Edit/Delete part of QuickAdmin
IDataList | Interface implemented by all Local Controls which can be bound to a DataList
IDate | This interface should be implemented by any edit control which returns a date. It is processed so the date is formatted in the ISO Standard
IGroupFields This interface can be implemented by any Advanced Search or Edit Control which wants to be able extract multiple fields from a linked table to display in a ListControl. The code to use the ForeignGroupFields is as follows
            "SELECT "+ForeignGroupFields+" AS ["+ForeignDataField+"],[" + ForeignKeyField + "] FROM [" + ForeignTable + "] ORDER BY [" + ForeignDataField + "]"
ILocal | Interface for Control which has its value coming from the Local Table
IMany2Many | The Interface should be used to implement Controls with One-Many-One Relationships
IOne2Many | This Interface should be implemented on Controls in Many-One Relationships
IResetable | Interface which should be implemented by both the Advanced Controls and the Add/Edit/View Controls so they can be reset on a new search or on a click of the add button.
ISearchable | Interface implemented by all Simple and Advanced Controls
ISetToNull | This interface should be used by any edit control which in the eventuality that an empty string is returned, should allow the user to specify if it will store the value in the database as a NULL.

Delegates

Delegate | Description
AddingEventHandler | Handler for the OnAdding Event
DeletedEventHandler | Handler for the OnDeleted Event
DeletingEventHandler | Handler for the OnDeleting Event
EditingEventHandler | Handler for the OnEditing Event
InsertedEventHandler | Handler for the OnInserted Event
InsertingEventHandler | Handler for the OnInserting Event
ResettingEventHandler | Handler for the OnResetting Event
SearchedEventHandler | Handler for the OnResetting Event
SearchingEventHandler | Handler for the OnSearching Event
UpdatedEventHandler | Handler for the OnUpdated Event
UpdatingEventHandler | Handler for the OnInserting Event
ViewingEventHandler | Handler for the OnViewing Event

Enumerations

Enumeration | Description
Admin.ActionType | The ActionType exposed by myAdmin.Action This shows you which button was clicked or whether there was a postback etc...
Admin.Mode | Enum Defining the modes the QuickAdmin Control can be in
Location | Where the message should be displayed
SearchCriteria | Enumeration for SearchType


baseEventArgs Class

These are the base Event Arguments thrown by all the Events.

For a list of all members of this type, see baseEventArgs Members.

System.Object
EventArgs
baseEventArgs

[Visual Basic]
Public Class baseEventArgs
   Inherits EventArgs
[C#]
public class baseEventArgs : EventArgs

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

baseEventArgs Members | Cambro.Web.QuickAdmin Namespace

Generated from assembly Cambro.Web.QuickAdmin [2.0.1.23600]


baseEventArgs Members

Public Instance Constructors

baseEventArgs Constructor

Public Instance Properties

DisplayMessage | Should we prompt the user?
MessageLocation | Where should the message be displayed
MessageText | String to prompt the user with

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

baseEventArgs Class | Cambro.Web.QuickAdmin Namespace


baseEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public baseEventArgs();

See Also

baseEventArgs Class | baseEventArgs Members | Cambro.Web.QuickAdmin Namespace


baseEventArgs Properties

The properties of the baseEventArgs class are listed below. For a complete list of baseEventArgs class members, see the baseEventArgs Members topic.

Public Instance Properties

DisplayMessage | Should we prompt the user?
MessageLocation | Where should the message be displayed
MessageText | String to prompt the user with

See Also

baseEventArgs Class | Cambro.Web.QuickAdmin Namespace


baseEventArgs.DisplayMessage Property

Should we prompt the user?

[Visual Basic]
Public Property DisplayMessage As Boolean
[C#]
public bool DisplayMessage {get; set;}

See Also

baseEventArgs Class | baseEventArgs Members | Cambro.Web.QuickAdmin Namespace


baseEventArgs.MessageLocation Property

Where should the message be displayed

[Visual Basic]
Public Property MessageLocation As Cambro.Web.QuickAdmin.Location
[C#]
public Location MessageLocation {get; set;}

See Also

baseEventArgs Class | baseEventArgs Members | Cambro.Web.QuickAdmin Namespace


baseEventArgs.MessageText Property

String to prompt the user with

[Visual Basic]
Public Property MessageText As String
[C#]
public string MessageText {get; set;}

See Also

baseEventArgs Class | baseEventArgs Members | Cambro.Web.QuickAdmin Namespace


idEventArgs Class

Arguments thrown by the Events when QuickAdmin is in Add/Edit/View Modes which enables the user to determine the Record in question.

For a list of all members of this type, see idEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs

[Visual Basic]
Public Class idEventArgs
   Inherits baseEventArgs
[C#]
public class idEventArgs : baseEventArgs

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

idEventArgs Members | Cambro.Web.QuickAdmin Namespace


idEventArgs Members

Public Instance Constructors

idEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

idEventArgs Class | Cambro.Web.QuickAdmin Namespace


idEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public idEventArgs();

See Also

idEventArgs Class | idEventArgs Members | Cambro.Web.QuickAdmin Namespace


idEventArgs Properties

The properties of the idEventArgs class are listed below. For a complete list of idEventArgs class members, see the idEventArgs Members topic.

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID | The Second halp of the Joint Primary Key

See Also

idEventArgs Class | Cambro.Web.QuickAdmin Namespace


idEventArgs.PrimaryID Property

The Primary Key of this table or first half of a Joint Primary Key

[Visual Basic]
Public Property PrimaryID As String
[C#]
public string PrimaryID {get; set;}

See Also

idEventArgs Class | idEventArgs Members | Cambro.Web.QuickAdmin Namespace


idEventArgs.SecondaryID Property

The Second halp of the Joint Primary Key

[Visual Basic]
Public Property SecondaryID As String
[C#]
public string SecondaryID {get; set;}

See Also

idEventArgs Class | idEventArgs Members | Cambro.Web.QuickAdmin Namespace


AddingEventArgs Class

Arguments thrown by the OnAdding Event. This Event occurs when the Add button is clicked (when a blank form is presented)

For a list of all members of this type, see AddingEventArgs Members.

System.Object
EventArgs
baseEventArgs
AddingEventArgs

[Visual Basic]
Public Class AddingEventArgs
   Inherits baseEventArgs
[C#]
public class AddingEventArgs : baseEventArgs

Remarks

This group of event arguments enables the user of QuickAdmin to do a number of things. Display a message to the user

  • At the top of QuickAdmin
  • At the bootom of QuickAdmin
  • In a Pop-Up
Edit the state of the EditControls in Add Mode
  • Set default values for you EditControls in Add Mode. See below for an example of removing all Employees from the EditDropDownList apart from the user who is currently logged on.

Example

            public void Adding(object sender, Cambro.Web.QuickAdmin.AddingEventArgs e)
            {
                EditDropDownList MyDDL = (EditDropDownList) myAdmin.ViewContainer.FindControl("Editdropdownlist2");
                ListItem Temp = MyDDL.Items.FindByValue(HttpContext.Current.User.Identity);
                MyDDL.Items.Clear();
                MyDDL.Items.Add(Temp);
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

AddingEventArgs Members | Cambro.Web.QuickAdmin Namespace


AddingEventArgs Members

Public Instance Constructors

AddingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

AddingEventArgs Class | Cambro.Web.QuickAdmin Namespace


AddingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public AddingEventArgs();

See Also

AddingEventArgs Class | AddingEventArgs Members | Cambro.Web.QuickAdmin Namespace


DeletedEventArgs Class

Arguments thrown by the OnDeleted Event. This Event occurs once the record has been Deleted from the database

For a list of all members of this type, see DeletedEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
DeletedEventArgs

[Visual Basic]
Public Class DeletedEventArgs
   Inherits idEventArgs
[C#]
public class DeletedEventArgs : idEventArgs

Remarks

This event allows the Administrator to display messages to the user about the record that has been deleted. It is also possible here to delete related records from the database which may rely on this Primary Key (If referential integrity is not turned on).

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

DeletedEventArgs Members | Cambro.Web.QuickAdmin Namespace


DeletedEventArgs Members

Public Instance Constructors

DeletedEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DeletedEventArgs Class | Cambro.Web.QuickAdmin Namespace


DeletedEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public DeletedEventArgs();

See Also

DeletedEventArgs Class | DeletedEventArgs Members | Cambro.Web.QuickAdmin Namespace


DeletingEventArgs Class

Arguments thrown by the OnDeleting Event. This Event occurs before the record is Deleted from the database

For a list of all members of this type, see DeletingEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
DeletingEventArgs

[Visual Basic]
Public Class DeletingEventArgs
   Inherits idEventArgs
[C#]
public class DeletingEventArgs : idEventArgs

Remarks

This event is useful if, for some reason, it was necessary to prevent records being deleted from the database because of the value of one of the local fields, or even a value from a Many-to-Many relationship. It is also possible here, as the Administrator has access to the Key value, to delete records which rely on this record and may prevent it's deletion due to referential integrity.

Example

            public void Deleting(object sender, Cambro.Web.QuickAdmin.DeletingEventArgs e)
            {
                EditDropDownList MyDDL = (EditDropDownList) myAdmin.ViewContainer.FindControl("Editdropdownlist1");
                if (MyDDL.Items.FindByValue("2").Selected == true)
                {
                    e.Execute = false;
                    e.MessageText = "Sorry, you cannot delete a record from the database where you are not the Line-Manager.";
                    e.MessageLocation = Location.Popup;
                    e.DisplayMessage = true;
                }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

DeletingEventArgs Members | Cambro.Web.QuickAdmin Namespace


DeletingEventArgs Members

Public Instance Constructors

DeletingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DeletingEventArgs Class | Cambro.Web.QuickAdmin Namespace


DeletingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public DeletingEventArgs();

See Also

DeletingEventArgs Class | DeletingEventArgs Members | Cambro.Web.QuickAdmin Namespace


DeletingEventArgs Properties

The properties of the DeletingEventArgs class are listed below. For a complete list of DeletingEventArgs class members, see the DeletingEventArgs Members topic.

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

See Also

DeletingEventArgs Class | Cambro.Web.QuickAdmin Namespace


DeletingEventArgs.Execute Property

Should this command complete?

[Visual Basic]
Public Property Execute As Boolean
[C#]
public bool Execute {get; set;}

See Also

DeletingEventArgs Class | DeletingEventArgs Members | Cambro.Web.QuickAdmin Namespace


EditingEventArgs Class

Arguments thrown by the OnEditing Event. This Event occurs when the Edit button is clicked (when going into edit mode from view mode)

For a list of all members of this type, see EditingEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
EditingEventArgs

[Visual Basic]
Public Class EditingEventArgs
   Inherits idEventArgs
[C#]
public class EditingEventArgs : idEventArgs

Remarks

The OnEditing event enables you to have more control over who can edit and delete records from the database. In the example below, if the user is Editing his own record, he can't Delete it.

Example

            public void Editing(object sender, Cambro.Web.QuickAdmin.EditingEventArgs e)
            {
                if (e.PrimaryID != HttpContext.Current.User.Identity.ToString())
                {
                    e.AllowDelete = false;
                    e.DisplayMessage = true;
                    e.MessageText = "You cannot delete your own record.";
                }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditingEventArgs Members | Cambro.Web.QuickAdmin Namespace


EditingEventArgs Members

Public Instance Constructors

EditingEventArgs Constructor

Public Instance Properties

AllowDelete | Should the user be allowed to delete this record, or should the delete button be hidden?
AllowSave | Should the user be allowed to save any changes to this record, or should the save button be hidden?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

EditingEventArgs Class | Cambro.Web.QuickAdmin Namespace


EditingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditingEventArgs();

See Also

EditingEventArgs Class | EditingEventArgs Members | Cambro.Web.QuickAdmin Namespace


EditingEventArgs Properties

The properties of the EditingEventArgs class are listed below. For a complete list of EditingEventArgs class members, see the EditingEventArgs Members topic.

Public Instance Properties

AllowDelete | Should the user be allowed to delete this record, or should the delete button be hidden?
AllowSave | Should the user be allowed to save any changes to this record, or should the save button be hidden?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

See Also

EditingEventArgs Class | Cambro.Web.QuickAdmin Namespace


EditingEventArgs.AllowDelete Property

Should the user be allowed to delete this record, or should the delete button be hidden?

[Visual Basic]
Public Property AllowDelete As Boolean
[C#]
public bool AllowDelete {get; set;}

See Also

EditingEventArgs Class | EditingEventArgs Members | Cambro.Web.QuickAdmin Namespace


EditingEventArgs.AllowSave Property

Should the user be allowed to save any changes to this record, or should the save button be hidden?

[Visual Basic]
Public Property AllowSave As Boolean
[C#]
public bool AllowSave {get; set;}

See Also

EditingEventArgs Class | EditingEventArgs Members | Cambro.Web.QuickAdmin Namespace


InsertedEventArgs Class

Arguments thrown by the OnInserted Event. This Event occurs once the new record has been Inserted into the database

For a list of all members of this type, see InsertedEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
InsertedEventArgs

[Visual Basic]
Public Class InsertedEventArgs
   Inherits idEventArgs
[C#]
public class InsertedEventArgs : idEventArgs

Remarks

This event is a useful way of determining the Primary (or Joint) Key from the newly inserted record, so default attributes of an added article (for example) can be set.

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

InsertedEventArgs Members | Cambro.Web.QuickAdmin Namespace


InsertedEventArgs Members

Public Instance Constructors

InsertedEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InsertedEventArgs Class | Cambro.Web.QuickAdmin Namespace


InsertedEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public InsertedEventArgs();

See Also

InsertedEventArgs Class | InsertedEventArgs Members | Cambro.Web.QuickAdmin Namespace


InsertingEventArgs Class

Arguments thrown by the OnInserting Event. This Event occurs before the new record is Inserted into the database

For a list of all members of this type, see InsertingEventArgs Members.

System.Object
EventArgs
baseEventArgs
InsertingEventArgs

[Visual Basic]
Public Class InsertingEventArgs
   Inherits baseEventArgs
[C#]
public class InsertingEventArgs : baseEventArgs

Remarks

This is useful to check what the user has entered in the form, and to stop the record from being inserted in the database, especially it is difficult to construct a validator for the criteria. Below is an example from the Employees Demo, which determines if the LineManager of the inserted record is the Line manager entering the employee (this can also be done a different way OnAdding by removing all but the correct Line manager from the list [and even turning the Control Addable=false if necessary]).

Example

            public void Inserting(object sender, Cambro.Web.QuickAdmin.InsertingEventArgs e)
            {
                EditDropDownList MyDDL = (EditDropDownList) myAdmin.ViewContainer.FindControl("Editdropdownlist1");
                if (MyDDL.Items.FindByValue("2").Selected == false)
                {
                    e.Execute = false;
                    e.MessageText = "Sorry, you have to Add an Employee with\\nyourself as their Line-Manager";
                    e.MessageLocation = Location.Popup;
                    e.DisplayMessage = true;
                }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

InsertingEventArgs Members | Cambro.Web.QuickAdmin Namespace


InsertingEventArgs Members

Public Instance Constructors

InsertingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InsertingEventArgs Class | Cambro.Web.QuickAdmin Namespace


InsertingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public InsertingEventArgs();

See Also

InsertingEventArgs Class | InsertingEventArgs Members | Cambro.Web.QuickAdmin Namespace


InsertingEventArgs Properties

The properties of the InsertingEventArgs class are listed below. For a complete list of InsertingEventArgs class members, see the InsertingEventArgs Members topic.

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with

See Also

InsertingEventArgs Class | Cambro.Web.QuickAdmin Namespace


InsertingEventArgs.Execute Property

Should this command complete?

[Visual Basic]
Public Property Execute As Boolean
[C#]
public bool Execute {get; set;}

See Also

InsertingEventArgs Class | InsertingEventArgs Members | Cambro.Web.QuickAdmin Namespace


ResettingEventArgs Class

Arguments thrown by the OnResetting Event. This Event occurs when the Reset button is clicked, but before everything is Reset

For a list of all members of this type, see ResettingEventArgs Members.

System.Object
EventArgs
baseEventArgs
ResettingEventArgs

[Visual Basic]
Public Class ResettingEventArgs
   Inherits baseEventArgs
[C#]
public class ResettingEventArgs : baseEventArgs

Remarks

One of the simpler events, lets the administrator prompt the user with a message which can be positioned at a specific Location.

Example

            public void Resetting(object sender, Cambro.Web.QuickAdmin.ResettingEventArgs e)
            {
                e.DisplayMessage = true;
                e.MessageText = "You have reset all Search variables.";
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ResettingEventArgs Members | Cambro.Web.QuickAdmin Namespace


ResettingEventArgs Members

Public Instance Constructors

ResettingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ResettingEventArgs Class | Cambro.Web.QuickAdmin Namespace


ResettingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public ResettingEventArgs();

See Also

ResettingEventArgs Class | ResettingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs Class

Arguments thrown by the OnSearched Event. This Event occurs when the Search button is clicked and after the search is done

For a list of all members of this type, see SearchedEventArgs Members.

System.Object
EventArgs
baseEventArgs
SearchedEventArgs

[Visual Basic]
Public Class SearchedEventArgs
   Inherits baseEventArgs
[C#]
public class SearchedEventArgs : baseEventArgs

Remarks

Another useful event, enables the user to be told information about the search.

Example

            public void Searched(object sender, Cambro.Web.QuickAdmin.SearchedEventArgs e)
            {
                if (e.Results == 0)
                {
                    e.MessageLocation = Location.Popup;
                    e.MessageText = "Oh Dear! Your search returned no results.\\nTry a less specific search.";
                }
                else if (e.Results > 20)
                {
                    e.MessageLocation = Location.Popup;
                    e.MessageText = "You returned " + e.Results + " results \\nYou may want to refine your search";
                }
                if (e.MessageText != "")
                    e.DisplayMessage = true;
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs Members

Public Instance Constructors

SearchedEventArgs Constructor

Public Instance Properties

AllowPaging | Should the ResultsDataGrid Page or not?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PageNumber | Page number if paging;
PageSize | Page size of the ResultsGrid
Results | The number of records in the database which have been returned.
SearchType | Enumeration to Allow the Administrator to determine the type of search that was made.
SimpleSearchText | Text in the Simple Search Box
SqlString | The Query that was run on the database based on the search.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SearchedEventArgs Class | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public SearchedEventArgs();

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs Properties

The properties of the SearchedEventArgs class are listed below. For a complete list of SearchedEventArgs class members, see the SearchedEventArgs Members topic.

Public Instance Properties

AllowPaging | Should the ResultsDataGrid Page or not?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PageNumber | Page number if paging;
PageSize | Page size of the ResultsGrid
Results | The number of records in the database which have been returned.
SearchType | Enumeration to Allow the Administrator to determine the type of search that was made.
SimpleSearchText | Text in the Simple Search Box
SqlString | The Query that was run on the database based on the search.

See Also

SearchedEventArgs Class | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.AllowPaging Property

Should the ResultsDataGrid Page or not?

[Visual Basic]
Public Property AllowPaging As Boolean
[C#]
public bool AllowPaging {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.PageNumber Property

Page number if paging;

[Visual Basic]
Public Property PageNumber As Integer
[C#]
public int PageNumber {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.PageSize Property

Page size of the ResultsGrid

[Visual Basic]
Public Property PageSize As Integer
[C#]
public int PageSize {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.Results Property

The number of records in the database which have been returned.

[Visual Basic]
Public Property Results As Integer
[C#]
public int Results {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.SearchType Property

Enumeration to Allow the Administrator to determine the type of search that was made.

[Visual Basic]
Public Property SearchType As Cambro.Web.QuickAdmin.SearchCriteria
[C#]
public SearchCriteria SearchType {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.SimpleSearchText Property

Text in the Simple Search Box

[Visual Basic]
Public Property SimpleSearchText As String
[C#]
public string SimpleSearchText {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchedEventArgs.SqlString Property

The Query that was run on the database based on the search.

[Visual Basic]
Public Property SqlString As String
[C#]
public string SqlString {get; set;}

See Also

SearchedEventArgs Class | SearchedEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs Class

Arguments thrown by the OnSearching Event. This Event occurs just before a Search is done, and before the Results have been propagated.

For a list of all members of this type, see SearchingEventArgs Members.

System.Object
EventArgs
baseEventArgs
SearchingEventArgs

[Visual Basic]
Public Class SearchingEventArgs
   Inherits baseEventArgs
[C#]
public class SearchingEventArgs : baseEventArgs

Remarks

The user can manipulate the search and prompt the user to enable better use of the search facility

Example

            public void Searching(object sender, Cambro.Web.QuickAdmin.SearchingEventArgs e)
            {
                if (e.SimpleSearchText == "" && e.SearchType == SearchCriteria.Fuzzy)
                {
                    e.MessageText = "Search Terminated. You did a Fuzzy Search  with no Search Text!.";
                    e.MessageText += "Search again entering some text.";
                    e.MessageLocation = Location.Popup;
                    e.DisplayMessage = true;
                    e.Execute = false;
                }
                else
                {
                    e.SortOrder = "EmployeeID DESC";
                    e.WhereClause="(Employees.EmployeeID = "+Request.QueryString["Emp"]+" OR Employees.ReportsTo = "+Request.QueryString["Emp"]+")";
                }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs Members

Public Instance Constructors

SearchingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
Results | Number of results to return
SearchType | Enumeration to allow the administrator to change the type of search
SimpleSearchText | Text in the Simple Search Box
SortOrder | Statement to be appended to the end of the SQL Select Query. This would be statements such as "Employees.EmployeeID ASC". Ensure you have specified a Table if the same field name occurs in two tables.
WhereClause | Text to add to the Where Clause of the search which is added: "AND (WhereClause)"

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SearchingEventArgs Class | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public SearchingEventArgs();

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs Properties

The properties of the SearchingEventArgs class are listed below. For a complete list of SearchingEventArgs class members, see the SearchingEventArgs Members topic.

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
Results | Number of results to return
SearchType | Enumeration to allow the administrator to change the type of search
SimpleSearchText | Text in the Simple Search Box
SortOrder | Statement to be appended to the end of the SQL Select Query. This would be statements such as "Employees.EmployeeID ASC". Ensure you have specified a Table if the same field name occurs in two tables.
WhereClause | Text to add to the Where Clause of the search which is added: "AND (WhereClause)"

See Also

SearchingEventArgs Class | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.Execute Property

Should this command complete?

[Visual Basic]
Public Property Execute As Boolean
[C#]
public bool Execute {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.Results Property

Number of results to return

[Visual Basic]
Public Property Results As Integer
[C#]
public int Results {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.SearchType Property

Enumeration to allow the administrator to change the type of search

[Visual Basic]
Public Property SearchType As Cambro.Web.QuickAdmin.SearchCriteria
[C#]
public SearchCriteria SearchType {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.SimpleSearchText Property

Text in the Simple Search Box

[Visual Basic]
Public Property SimpleSearchText As String
[C#]
public string SimpleSearchText {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.SortOrder Property

Statement to be appended to the end of the SQL Select Query. This would be statements such as "Employees.EmployeeID ASC". Ensure you have specified a Table if the same field name occurs in two tables.

[Visual Basic]
Public Property SortOrder As String
[C#]
public string SortOrder {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


SearchingEventArgs.WhereClause Property

Text to add to the Where Clause of the search which is added: "AND (WhereClause)"

[Visual Basic]
Public Property WhereClause As String
[C#]
public string WhereClause {get; set;}

See Also

SearchingEventArgs Class | SearchingEventArgs Members | Cambro.Web.QuickAdmin Namespace


UpdatedEventArgs Class

Arguments thrown by the OnUpdated Event. This Event occurs once the new record has been Updated in the database

For a list of all members of this type, see UpdatedEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
UpdatedEventArgs

[Visual Basic]
Public Class UpdatedEventArgs
   Inherits idEventArgs
[C#]
public class UpdatedEventArgs : idEventArgs

Remarks

This event enables the administrator to display messages to the user and determine the Primary (or joint) Key of the Updated record.

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

UpdatedEventArgs Members | Cambro.Web.QuickAdmin Namespace


UpdatedEventArgs Members

Public Instance Constructors

UpdatedEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

UpdatedEventArgs Class | Cambro.Web.QuickAdmin Namespace


UpdatedEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public UpdatedEventArgs();

See Also

UpdatedEventArgs Class | UpdatedEventArgs Members | Cambro.Web.QuickAdmin Namespace


UpdatingEventArgs Class

Arguments thrown by the OnUpdating Event. This Event occurs before the record being edited is Updated in the database

For a list of all members of this type, see UpdatingEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
UpdatingEventArgs

[Visual Basic]
Public Class UpdatingEventArgs
   Inherits idEventArgs
[C#]
public class UpdatingEventArgs : idEventArgs

Remarks

This event is fired when the save button has been clicked on a record already present in the database i.e. before an update query is called. Setting values of the Event Arguments enables the user to stop updates, display messages and edit the data being stored.

Example

            public void Updating(object sender, Cambro.Web.QuickAdmin.UpdatingEventArgs e)
            {
                EditDropDownList MyDDL = (EditDropDownList) myAdmin.ViewContainer.FindControl("Editdropdownlist1");
                if (MyDDL.Items.FindByValue("2").Selected == false)
                {
                    e.Execute = false;
                    e.MessageText = "Sorry, you cannot change the value of the Line-Manager from yourself.";
                    e.MessageLocation = Location.Popup;
                    e.DisplayMessage = true;
                }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

UpdatingEventArgs Members | Cambro.Web.QuickAdmin Namespace


UpdatingEventArgs Members

Public Instance Constructors

UpdatingEventArgs Constructor

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

UpdatingEventArgs Class | Cambro.Web.QuickAdmin Namespace


UpdatingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public UpdatingEventArgs();

See Also

UpdatingEventArgs Class | UpdatingEventArgs Members | Cambro.Web.QuickAdmin Namespace


UpdatingEventArgs Properties

The properties of the UpdatingEventArgs class are listed below. For a complete list of UpdatingEventArgs class members, see the UpdatingEventArgs Members topic.

Public Instance Properties

DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
Execute | Should this command complete?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

See Also

UpdatingEventArgs Class | Cambro.Web.QuickAdmin Namespace


UpdatingEventArgs.Execute Property

Should this command complete?

[Visual Basic]
Public Property Execute As Boolean
[C#]
public bool Execute {get; set;}

See Also

UpdatingEventArgs Class | UpdatingEventArgs Members | Cambro.Web.QuickAdmin Namespace


ViewingEventArgs Class

Arguments thrown by the OnViewing Event. This Event occurs when a link in the DataGrid is clicked and QuickAdmin goes into View Mode.

For a list of all members of this type, see ViewingEventArgs Members.

System.Object
EventArgs
baseEventArgs
idEventArgs
ViewingEventArgs

[Visual Basic]
Public Class ViewingEventArgs
   Inherits idEventArgs
[C#]
public class ViewingEventArgs : idEventArgs

Remarks

This event allows you to change the buttons presented to the user in View Mode, determine the record the user is viewing and change/hide values or controls from the user.

Example

            public void Viewing(object sender, Cambro.Web.QuickAdmin.ViewingEventArgs e)
            {
                if (e.PrimaryID != HttpContext.Current.User.Identity.ToString())
                    e.AllowEdit = true;
                else
                    e.AllowEdit = false;
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ViewingEventArgs Members | Cambro.Web.QuickAdmin Namespace


ViewingEventArgs Members

Public Instance Constructors

ViewingEventArgs Constructor

Public Instance Properties

AllowEdit | Should the user be allowed to edit this record?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ViewingEventArgs Class | Cambro.Web.QuickAdmin Namespace


ViewingEventArgs Constructor

[Visual Basic]
Public Sub New()
[C#]
public ViewingEventArgs();

See Also

ViewingEventArgs Class | ViewingEventArgs Members | Cambro.Web.QuickAdmin Namespace


ViewingEventArgs Properties

The properties of the ViewingEventArgs class are listed below. For a complete list of ViewingEventArgs class members, see the ViewingEventArgs Members topic.

Public Instance Properties

AllowEdit | Should the user be allowed to edit this record?
DisplayMessage (inherited from baseEventArgs) | Should we prompt the user?
MessageLocation (inherited from baseEventArgs) | Where should the message be displayed
MessageText (inherited from baseEventArgs) | String to prompt the user with
PrimaryID (inherited from idEventArgs) | The Primary Key of this table or first half of a Joint Primary Key
SecondaryID (inherited from idEventArgs) | The Second halp of the Joint Primary Key

See Also

ViewingEventArgs Class | Cambro.Web.QuickAdmin Namespace


ViewingEventArgs.AllowEdit Property

Should the user be allowed to edit this record?

[Visual Basic]
Public Property AllowEdit As Boolean
[C#]
public bool AllowEdit {get; set;}

See Also

ViewingEventArgs Class | ViewingEventArgs Members | Cambro.Web.QuickAdmin Namespace


Admin Class

Control which enables a user to create an administration section for their database

For a list of all members of this type, see Admin Members.

System.Object
Control
WebControl
Admin

[Visual Basic]
Public Class Admin
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, INamingContainer
[C#]
public class Admin : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, INamingContainer

Remarks

This Control contains the individual parts of the QuickAdmin system. These are:

  • SearchControl - The Control that contains the Simple and Advanced Controls
  • ResultsControl - The Control that contains the ResultsDataGrid
  • ViewControl - The Control that contains the Edit Controls

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Admin Members | Cambro.Web.QuickAdmin Namespace


Admin Members

Public Instance Constructors

Admin Constructor

Public Instance Fields

Action | What occurred to produce this page? Button Click? Postback?
DataContainer | The Control that contains the DataLists
ResultsContainer | The Control that contains the ResultsDataGrid
SearchContainer | The Control that Contains the Simple and Advanced Search Controls
ViewContainer | The Control that contains the Edit Controls.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
AddButton | Is the user allowed to add a new record to the database? Default False
AddButtonText | Leaving this property as an empty string will leave the default value of the Add Button Text. Change to any text or html you want to display instead of the standard Add Button Text.
AddHeaderText | Leaving this property as an empty string will leave the default value of the Add Header. Change to any text or html you want to display instead of the standard Add Header.
AdminMode | What Mode is the Admin Control in?
AdvancedSearch | ITemplate for AdvancedSearch Object
AdvancedSearchHeaderText | Leaving this property as an empty string will leave the default value of the Advanced Search Header. Change to any text or html you want to display instead of the standard Advanced Search Header.
AllowFuzzy | Is the user allowed to do a Fuzzy Search? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoInc | Is the Table Auto-Incrementing the Primary Key? Default True
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CancelAddButtonText | Leaving this property as an empty string will leave the default value of the Cancel Button Text in Add Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.
CancelButtonText | Leaving this property as an empty string will leave the default value of the Cancel Button Text in Edit Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Data | ITemplate for Data Object
DataField | The Primary Key Field of the Local Table.
DataField2 | In the case of Joint Primary Key this should be the second Key Field
DataField2IsString | In the case of a Joint Primary Key, is the second part a string? Default False
DataFieldIsString | Is the Primary Key of the table a string? Default False
DefaultSearch | This enables the Administrator to specify the type of search to be the default to appear when the page first loads and when the Reset Button is clicked. Default Search is Exact.
DeleteButton | Is the user allowed to delete a database object? Default False If set to true, a Delete button will appear in Edit Mode enabling the user to delete the record.
DeleteButtonText | Leaving this property as an empty string will leave the default value of the Delete Button Text. Change to any text or html you want to display instead of the standard Delete Button Text.
DoneButtonText | Leaving this property as an empty string will leave the default value of the Done Button Text. Change to any text or html you want to display instead of the standard Done Button Text.
EditButton | Is the user allowed to edit any of the database records? Default True When set to true, in view mode an Edit button will appear allowing them to click through to Edit Mode.
EditButtonText | Leaving this property as an empty string will leave the default value of the Edit Button Text. Change to any text or html you want to display instead of the standard Edit Button Text.
EditHeaderText | Leaving this property as an empty string will leave the default value of the Edit Header. Change to any text or html you want to display instead of the standard Edit Header.
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
ImmediateResults | If set to true, this property will cause a Search to be run immediately. Default False
IsUniqueIdentifier | Is the Primary Key a Unique Identifier?
NamingContainer (inherited from System.Web.UI.Control) |
OleDBConnStr | The OLE Database Connection String. Use this string if your database is not a SQL Database.
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
PrimaryID | The Primary Key of the Local Table
RegistrationKey | This is the registration key - If you do not have one, please go to www.quickadmin.net.
ResetButtonText | Leaving this property as an empty string will leave the default value of the Reset Button Text. Change to any text or html you want to display instead of the standard Reset Button Text.
Results | ITemplate for ResultsControl Object
ResultsHeaderText | Leaving this property as an empty string will leave the default value of the Results Header. Change to any text or html you want to display instead of the standard Results Header.
SaveButtonText | Leaving this property as an empty string will leave the default value of the Save Button Text. Change to any text or html you want to display instead of the standard Save Button Text.
SearchButtonText | Leaving this property as an empty string will leave the default value of the Search Button Text. Change to any text or html you want to display instead of the standard Search Button Text.
SecondaryID | If the Primary Key is a Joint Key, this is the second half
ShowAdvanced | Allows you to set whether the Advanced Controls are made visible or not to the user by default.
ShowButtonsAtTop | Should the Buttons used in Add/Edit/View modes also appear at the top of the page. Default False
SimpleSearch | ITemplate for SimpleSearch Object
SimpleSearchHeaderText | Leaving this property as an empty string will leave the default value of the Simple Search Header. Change to any text or html you want to display instead of the standard Simple Search Header.
Site (inherited from System.Web.UI.Control) |
SkipView | Should View Mode be Skipped? Clicking a record in Results Mode will advanced QuickAdmin to Edit Mode if this is set to true and back to Results on a Save.
SqlDBConnStr | The Microsoft SQL Database Connection String. Use this string if you are using a SQL Database
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
Table | The Local Table which is the Table you want to Administrate with this version of QuickAdmin
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
View | ITemplate for View Object
ViewHeaderText | Leaving this property as an empty string will leave the default value of the View Header. Change to any text or html you want to display instead of the standard View Header.
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Public Instance Events

Adding | The Event fired when QuickAdmin has gone into Add Mode
Deleted | The Event fired when a record has been deleted
Deleting | The Event fired when a record is about to be deleted
Editing | The Event fired when QuickAdmin has gone into Edit Mode
Inserted | The Event fired when a record has been inserted
Inserting | The Event fired when a record is about to be inserted
Resetting | The Event fired when the Search Controls are about to be reset
Searched | The Event fired when the database has been searched
Searching | The Event fired when the database is about to be searched
Updated | The Event fired when a record has been updated
Updating | The Event fired when a record is about to be updated
Viewing | The Event fired when QuickAdmin is going into View Mode

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnAdding | The OnAdding event occurs when the Add page is to be shown
OnBubbleEvent | Event which enables the bubbling of events from the ViewContainer and SearchContainer
OnDataBinding (inherited from Control) |
OnDeleted | The OnDeleting event occurs when a record has been deleted from the database
OnDeleting | The OnDeleting event occurs when a record is about to be deleted from the database
OnEditing | The OnEditing event occurs when the edit button is clicked and the Edit Page is to be displayed
OnInit | Function which Controls the Mode and Status of the Admin Control and deals with all postbacks
OnInserted | The OnInserted event occurs when a record has been inserted into the database
OnInserting | The OnInserting Event occurs when before a record is stored in the database
OnLoad | Process Data which requires to look at the ViewState
OnPreRender | Overridden OnPreRender
OnResetting | The OnResetting Event occurs when the reset button is pressed
OnSearched | The OnSearched Event occurs when a search has been completed
OnSearching | The OnSearching Event occurs when the search button has been clicked, but before the search is done
OnUnload (inherited from Control) |
OnUpdated | The OnUpdated Event occurs after a record in the database has been updated
OnUpdating | The OnUpdating Event occurs before a record in the database has been updated
OnViewing | The OnViewing Event occurs when a record in the Results Data Grid has been selected and the page goes into View Mode
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to create table tags around children
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Admin Class | Cambro.Web.QuickAdmin Namespace


Admin Constructor

[Visual Basic]
Public Sub New()
[C#]
public Admin();

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin Fields

The fields of the Admin class are listed below. For a complete list of Admin class members, see the Admin Members topic.

Public Instance Fields

Action | What occurred to produce this page? Button Click? Postback?
DataContainer | The Control that contains the DataLists
ResultsContainer | The Control that contains the ResultsDataGrid
SearchContainer | The Control that Contains the Simple and Advanced Search Controls
ViewContainer | The Control that contains the Edit Controls.

See Also

Admin Class | Cambro.Web.QuickAdmin Namespace


Admin.Action Field

What occurred to produce this page? Button Click? Postback?

[Visual Basic]
Public Action As Cambro.Web.QuickAdmin.Admin.ActionType
[C#]
public ActionType Action;

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DataContainer Field

The Control that contains the DataLists

[Visual Basic]
Public DataContainer As System.Web.UI.Control
[C#]
public Control DataContainer;

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ResultsContainer Field

The Control that contains the ResultsDataGrid

[Visual Basic]
Public ResultsContainer As Cambro.Web.QuickAdmin.ResultsControl
[C#]
public ResultsControl ResultsContainer;

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SearchContainer Field

The Control that Contains the Simple and Advanced Search Controls

[Visual Basic]
Public SearchContainer As Cambro.Web.QuickAdmin.SearchControl
[C#]
public SearchControl SearchContainer;

Remarks

use SearchContainer.SimpleContainer to access the Simple Controls and use SearchContainer.AdvancedContainer to access the Advanced Controls. For example, to determine the Text which has been entered on the Simple Search, assuming myAdmin is your Admin Control

            myAdmin.SearchContainer.SimpleContainer.SearchBox.Text

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ViewContainer Field

The Control that contains the Edit Controls.

[Visual Basic]
Public ViewContainer As Cambro.Web.QuickAdmin.ViewControl
[C#]
public ViewControl ViewContainer;

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin Properties

The properties of the Admin class are listed below. For a complete list of Admin class members, see the Admin Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
AddButton | Is the user allowed to add a new record to the database? Default False
AddButtonText | Leaving this property as an empty string will leave the default value of the Add Button Text. Change to any text or html you want to display instead of the standard Add Button Text.
AddHeaderText | Leaving this property as an empty string will leave the default value of the Add Header. Change to any text or html you want to display instead of the standard Add Header.
AdminMode | What Mode is the Admin Control in?
AdvancedSearch | ITemplate for AdvancedSearch Object
AdvancedSearchHeaderText | Leaving this property as an empty string will leave the default value of the Advanced Search Header. Change to any text or html you want to display instead of the standard Advanced Search Header.
AllowFuzzy | Is the user allowed to do a Fuzzy Search? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoInc | Is the Table Auto-Incrementing the Primary Key? Default True
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CancelAddButtonText | Leaving this property as an empty string will leave the default value of the Cancel Button Text in Add Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.
CancelButtonText | Leaving this property as an empty string will leave the default value of the Cancel Button Text in Edit Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Data | ITemplate for Data Object
DataField | The Primary Key Field of the Local Table.
DataField2 | In the case of Joint Primary Key this should be the second Key Field
DataField2IsString | In the case of a Joint Primary Key, is the second part a string? Default False
DataFieldIsString | Is the Primary Key of the table a string? Default False
DefaultSearch | This enables the Administrator to specify the type of search to be the default to appear when the page first loads and when the Reset Button is clicked. Default Search is Exact.
DeleteButton | Is the user allowed to delete a database object? Default False If set to true, a Delete button will appear in Edit Mode enabling the user to delete the record.
DeleteButtonText | Leaving this property as an empty string will leave the default value of the Delete Button Text. Change to any text or html you want to display instead of the standard Delete Button Text.
DoneButtonText | Leaving this property as an empty string will leave the default value of the Done Button Text. Change to any text or html you want to display instead of the standard Done Button Text.
EditButton | Is the user allowed to edit any of the database records? Default True When set to true, in view mode an Edit button will appear allowing them to click through to Edit Mode.
EditButtonText | Leaving this property as an empty string will leave the default value of the Edit Button Text. Change to any text or html you want to display instead of the standard Edit Button Text.
EditHeaderText | Leaving this property as an empty string will leave the default value of the Edit Header. Change to any text or html you want to display instead of the standard Edit Header.
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
ImmediateResults | If set to true, this property will cause a Search to be run immediately. Default False
IsUniqueIdentifier | Is the Primary Key a Unique Identifier?
NamingContainer (inherited from System.Web.UI.Control) |
OleDBConnStr | The OLE Database Connection String. Use this string if your database is not a SQL Database.
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
PrimaryID | The Primary Key of the Local Table
RegistrationKey | This is the registration key - If you do not have one, please go to www.quickadmin.net.
ResetButtonText | Leaving this property as an empty string will leave the default value of the Reset Button Text. Change to any text or html you want to display instead of the standard Reset Button Text.
Results | ITemplate for ResultsControl Object
ResultsHeaderText | Leaving this property as an empty string will leave the default value of the Results Header. Change to any text or html you want to display instead of the standard Results Header.
SaveButtonText | Leaving this property as an empty string will leave the default value of the Save Button Text. Change to any text or html you want to display instead of the standard Save Button Text.
SearchButtonText | Leaving this property as an empty string will leave the default value of the Search Button Text. Change to any text or html you want to display instead of the standard Search Button Text.
SecondaryID | If the Primary Key is a Joint Key, this is the second half
ShowAdvanced | Allows you to set whether the Advanced Controls are made visible or not to the user by default.
ShowButtonsAtTop | Should the Buttons used in Add/Edit/View modes also appear at the top of the page. Default False
SimpleSearch | ITemplate for SimpleSearch Object
SimpleSearchHeaderText | Leaving this property as an empty string will leave the default value of the Simple Search Header. Change to any text or html you want to display instead of the standard Simple Search Header.
Site (inherited from System.Web.UI.Control) |
SkipView | Should View Mode be Skipped? Clicking a record in Results Mode will advanced QuickAdmin to Edit Mode if this is set to true and back to Results on a Save.
SqlDBConnStr | The Microsoft SQL Database Connection String. Use this string if you are using a SQL Database
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
Table | The Local Table which is the Table you want to Administrate with this version of QuickAdmin
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
View | ITemplate for View Object
ViewHeaderText | Leaving this property as an empty string will leave the default value of the View Header. Change to any text or html you want to display instead of the standard View Header.
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Admin Class | Cambro.Web.QuickAdmin Namespace


Admin.AddButton Property

Is the user allowed to add a new record to the database? Default False

[Visual Basic]
Public Property AddButton As Boolean
[C#]
public bool AddButton {get; set;}

Remarks

Care should be Taken when using this Field as, if the AutoInc Field is set to false, the ID to be inserted into the Database will have to be either entered manually by the User or placed into the correct Control by some code. If entered by the user, there should be Validators to ensure the ID is of the correct type and that it doesn't already exist.

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AddButtonText Property

Leaving this property as an empty string will leave the default value of the Add Button Text. Change to any text or html you want to display instead of the standard Add Button Text.

[Visual Basic]
Public Property AddButtonText As String
[C#]
public string AddButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AddHeaderText Property

Leaving this property as an empty string will leave the default value of the Add Header. Change to any text or html you want to display instead of the standard Add Header.

[Visual Basic]
Public Property AddHeaderText As String
[C#]
public string AddHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AdminMode Property

What Mode is the Admin Control in?

[Visual Basic]
Public ReadOnly Property AdminMode As Cambro.Web.QuickAdmin.Admin.Mode
[C#]
public Admin.Mode AdminMode {get;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AdvancedSearch Property

ITemplate for AdvancedSearch Object

[Visual Basic]
Public Property AdvancedSearch As System.Web.UI.ITemplate
[C#]
public System.Web.UI.ITemplate AdvancedSearch {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AdvancedSearchHeaderText Property

Leaving this property as an empty string will leave the default value of the Advanced Search Header. Change to any text or html you want to display instead of the standard Advanced Search Header.

[Visual Basic]
Public Property AdvancedSearchHeaderText As String
[C#]
public string AdvancedSearchHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AllowFuzzy Property

Is the user allowed to do a Fuzzy Search? Default True

[Visual Basic]
Public Property AllowFuzzy As Boolean
[C#]
public bool AllowFuzzy {get; set;}

Remarks

If set to true, this enables the user to choose between doing a Fuzzy or Exact search on the database table. If set to false, the DefaultSearch Field can be set to Fuzzy to force the user to search using Fuzzy mode, or Exact to only do Exact matching.

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.AutoInc Property

Is the Table Auto-Incrementing the Primary Key? Default True

[Visual Basic]
Public Property AutoInc As Boolean
[C#]
public bool AutoInc {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.CancelAddButtonText Property

Leaving this property as an empty string will leave the default value of the Cancel Button Text in Add Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.

[Visual Basic]
Public Property CancelAddButtonText As String
[C#]
public string CancelAddButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.CancelButtonText Property

Leaving this property as an empty string will leave the default value of the Cancel Button Text in Edit Mode. Change to any text or html you want to display instead of the standard Cancel Button Text.

[Visual Basic]
Public Property CancelButtonText As String
[C#]
public string CancelButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Data Property

ITemplate for Data Object

[Visual Basic]
Public Property Data As System.Web.UI.ITemplate
[C#]
public System.Web.UI.ITemplate Data {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DataField Property

The Primary Key Field of the Local Table.

[Visual Basic]
Public Property DataField As String
[C#]
public string DataField {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DataField2 Property

In the case of Joint Primary Key this should be the second Key Field

[Visual Basic]
Public Property DataField2 As String
[C#]
public string DataField2 {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DataField2IsString Property

In the case of a Joint Primary Key, is the second part a string? Default False

[Visual Basic]
Public Property DataField2IsString As Boolean
[C#]
public bool DataField2IsString {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DataFieldIsString Property

Is the Primary Key of the table a string? Default False

[Visual Basic]
Public Property DataFieldIsString As Boolean
[C#]
public bool DataFieldIsString {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DefaultSearch Property

This enables the Administrator to specify the type of search to be the default to appear when the page first loads and when the Reset Button is clicked. Default Search is Exact.

[Visual Basic]
Public Property DefaultSearch As Cambro.Web.QuickAdmin.SearchCriteria
[C#]
public SearchCriteria DefaultSearch {get; set;}

Remarks

This term overrules the AllowFuzzy Field, so the Fuzzy Check Box is not shown though the default search run is Fuzzy. In this case, there is no way to revert to Exact matching. When AllowFuzzy is False and DefaultSearch is Exact, only Exact Matching can take place. If AllowFuzzy = True, no matter what DefaultSearch is set to, both types of searching can be done.

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DeleteButton Property

Is the user allowed to delete a database object? Default False If set to true, a Delete button will appear in Edit Mode enabling the user to delete the record.

[Visual Basic]
Public Property DeleteButton As Boolean
[C#]
public bool DeleteButton {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DeleteButtonText Property

Leaving this property as an empty string will leave the default value of the Delete Button Text. Change to any text or html you want to display instead of the standard Delete Button Text.

[Visual Basic]
Public Property DeleteButtonText As String
[C#]
public string DeleteButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.DoneButtonText Property

Leaving this property as an empty string will leave the default value of the Done Button Text. Change to any text or html you want to display instead of the standard Done Button Text.

[Visual Basic]
Public Property DoneButtonText As String
[C#]
public string DoneButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.EditButton Property

Is the user allowed to edit any of the database records? Default True When set to true, in view mode an Edit button will appear allowing them to click through to Edit Mode.

[Visual Basic]
Public Property EditButton As Boolean
[C#]
public bool EditButton {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.EditButtonText Property

Leaving this property as an empty string will leave the default value of the Edit Button Text. Change to any text or html you want to display instead of the standard Edit Button Text.

[Visual Basic]
Public Property EditButtonText As String
[C#]
public string EditButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.EditHeaderText Property

Leaving this property as an empty string will leave the default value of the Edit Header. Change to any text or html you want to display instead of the standard Edit Header.

[Visual Basic]
Public Property EditHeaderText As String
[C#]
public string EditHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ImmediateResults Property

If set to true, this property will cause a Search to be run immediately. Default False

[Visual Basic]
Public Property ImmediateResults As Boolean
[C#]
public bool ImmediateResults {get; set;}

Remarks

Care should be taken when using this Field as, if the DefaultSearch is set to Fuzzy and no values are set for the search, there will be no results returned.

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.IsUniqueIdentifier Property

Is the Primary Key a Unique Identifier?

[Visual Basic]
Public Property IsUniqueIdentifier As Boolean
[C#]
public bool IsUniqueIdentifier {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OleDBConnStr Property

The OLE Database Connection String. Use this string if your database is not a SQL Database.

[Visual Basic]
Public Property OleDBConnStr As String
[C#]
public string OleDBConnStr {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.PrimaryID Property

The Primary Key of the Local Table

[Visual Basic]
Public ReadOnly Property PrimaryID As String
[C#]
public string PrimaryID {get;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.RegistrationKey Property

This is the registration key - If you do not have one, please go to www.quickadmin.net.

[Visual Basic]
Public Property RegistrationKey As String
[C#]
public string RegistrationKey {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ResetButtonText Property

Leaving this property as an empty string will leave the default value of the Reset Button Text. Change to any text or html you want to display instead of the standard Reset Button Text.

[Visual Basic]
Public Property ResetButtonText As String
[C#]
public string ResetButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Results Property

ITemplate for ResultsControl Object

[Visual Basic]
Public Property Results As System.Web.UI.ITemplate
[C#]
public System.Web.UI.ITemplate Results {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ResultsHeaderText Property

Leaving this property as an empty string will leave the default value of the Results Header. Change to any text or html you want to display instead of the standard Results Header.

[Visual Basic]
Public Property ResultsHeaderText As String
[C#]
public string ResultsHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SaveButtonText Property

Leaving this property as an empty string will leave the default value of the Save Button Text. Change to any text or html you want to display instead of the standard Save Button Text.

[Visual Basic]
Public Property SaveButtonText As String
[C#]
public string SaveButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SearchButtonText Property

Leaving this property as an empty string will leave the default value of the Search Button Text. Change to any text or html you want to display instead of the standard Search Button Text.

[Visual Basic]
Public Property SearchButtonText As String
[C#]
public string SearchButtonText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SecondaryID Property

If the Primary Key is a Joint Key, this is the second half

[Visual Basic]
Public ReadOnly Property SecondaryID As String
[C#]
public string SecondaryID {get;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ShowAdvanced Property

Allows you to set whether the Advanced Controls are made visible or not to the user by default.

[Visual Basic]
Public Property ShowAdvanced As Boolean
[C#]
public bool ShowAdvanced {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ShowButtonsAtTop Property

Should the Buttons used in Add/Edit/View modes also appear at the top of the page. Default False

[Visual Basic]
Public Property ShowButtonsAtTop As Boolean
[C#]
public bool ShowButtonsAtTop {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SimpleSearch Property

ITemplate for SimpleSearch Object

[Visual Basic]
Public Property SimpleSearch As System.Web.UI.ITemplate
[C#]
public System.Web.UI.ITemplate SimpleSearch {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SimpleSearchHeaderText Property

Leaving this property as an empty string will leave the default value of the Simple Search Header. Change to any text or html you want to display instead of the standard Simple Search Header.

[Visual Basic]
Public Property SimpleSearchHeaderText As String
[C#]
public string SimpleSearchHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SkipView Property

Should View Mode be Skipped? Clicking a record in Results Mode will advanced QuickAdmin to Edit Mode if this is set to true and back to Results on a Save.

[Visual Basic]
Public Property SkipView As Boolean
[C#]
public bool SkipView {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.SqlDBConnStr Property

The Microsoft SQL Database Connection String. Use this string if you are using a SQL Database

[Visual Basic]
Public Property SqlDBConnStr As String
[C#]
public string SqlDBConnStr {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Table Property

The Local Table which is the Table you want to Administrate with this version of QuickAdmin

[Visual Basic]
Public Property Table As String
[C#]
public string Table {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.View Property

ITemplate for View Object

[Visual Basic]
Public Property View As System.Web.UI.ITemplate
[C#]
public System.Web.UI.ITemplate View {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.ViewHeaderText Property

Leaving this property as an empty string will leave the default value of the View Header. Change to any text or html you want to display instead of the standard View Header.

[Visual Basic]
Public Property ViewHeaderText As String
[C#]
public string ViewHeaderText {get; set;}

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin Methods

The methods of the Admin class are listed below. For a complete list of Admin class members, see the Admin Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnAdding | The OnAdding event occurs when the Add page is to be shown
OnBubbleEvent | Event which enables the bubbling of events from the ViewContainer and SearchContainer
OnDataBinding (inherited from Control) |
OnDeleted | The OnDeleting event occurs when a record has been deleted from the database
OnDeleting | The OnDeleting event occurs when a record is about to be deleted from the database
OnEditing | The OnEditing event occurs when the edit button is clicked and the Edit Page is to be displayed
OnInit | Function which Controls the Mode and Status of the Admin Control and deals with all postbacks
OnInserted | The OnInserted event occurs when a record has been inserted into the database
OnInserting | The OnInserting Event occurs when before a record is stored in the database
OnLoad | Process Data which requires to look at the ViewState
OnPreRender | Overridden OnPreRender
OnResetting | The OnResetting Event occurs when the reset button is pressed
OnSearched | The OnSearched Event occurs when a search has been completed
OnSearching | The OnSearching Event occurs when the search button has been clicked, but before the search is done
OnUnload (inherited from Control) |
OnUpdated | The OnUpdated Event occurs after a record in the database has been updated
OnUpdating | The OnUpdating Event occurs before a record in the database has been updated
OnViewing | The OnViewing Event occurs when a record in the Results Data Grid has been selected and the page goes into View Mode
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to create table tags around children
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Admin Class | Cambro.Web.QuickAdmin Namespace


Admin.OnAdding Method

The OnAdding event occurs when the Add page is to be shown

[Visual Basic]
Overridable Protected Sub OnAdding( _
   ByVal e As Cambro.Web.QuickAdmin.AddingEventArgs _
)
[C#]
protected virtual void OnAdding(
   AddingEventArgs e
);

Parameters

e

AddingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnBubbleEvent Method

Event which enables the bubbling of events from the ViewContainer and SearchContainer

[Visual Basic]
Overrides Protected Function OnBubbleEvent( _
   ByVal source As Object, _
   ByVal e As System.EventArgs _
) As Boolean
[C#]
protected override bool OnBubbleEvent(
   object source,
   EventArgs e
);

Parameters

source

e

Return Value

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnDeleted Method

The OnDeleting event occurs when a record has been deleted from the database

[Visual Basic]
Overridable Protected Sub OnDeleted( _
   ByVal e As Cambro.Web.QuickAdmin.DeletedEventArgs _
)
[C#]
protected virtual void OnDeleted(
   DeletedEventArgs e
);

Parameters

e

DeletedEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnDeleting Method

The OnDeleting event occurs when a record is about to be deleted from the database

[Visual Basic]
Overridable Protected Sub OnDeleting( _
   ByVal e As Cambro.Web.QuickAdmin.DeletingEventArgs _
)
[C#]
protected virtual void OnDeleting(
   DeletingEventArgs e
);

Parameters

e

DeletingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnEditing Method

The OnEditing event occurs when the edit button is clicked and the Edit Page is to be displayed

[Visual Basic]
Overridable Protected Sub OnEditing( _
   ByVal e As Cambro.Web.QuickAdmin.EditingEventArgs _
)
[C#]
protected virtual void OnEditing(
   EditingEventArgs e
);

Parameters

e

EditingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnInit Method

Function which Controls the Mode and Status of the Admin Control and deals with all postbacks

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnInserted Method

The OnInserted event occurs when a record has been inserted into the database

[Visual Basic]
Overridable Protected Sub OnInserted( _
   ByVal e As Cambro.Web.QuickAdmin.InsertedEventArgs _
)
[C#]
protected virtual void OnInserted(
   InsertedEventArgs e
);

Parameters

e

InsertedEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnInserting Method

The OnInserting Event occurs when before a record is stored in the database

[Visual Basic]
Overridable Protected Sub OnInserting( _
   ByVal e As Cambro.Web.QuickAdmin.InsertingEventArgs _
)
[C#]
protected virtual void OnInserting(
   InsertingEventArgs e
);

Parameters

e

InsertingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnLoad Method

Process Data which requires to look at the ViewState

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnResetting Method

The OnResetting Event occurs when the reset button is pressed

[Visual Basic]
Overridable Protected Sub OnResetting( _
   ByVal e As Cambro.Web.QuickAdmin.ResettingEventArgs _
)
[C#]
protected virtual void OnResetting(
   ResettingEventArgs e
);

Parameters

e

ResettingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnSearched Method

The OnSearched Event occurs when a search has been completed

[Visual Basic]
Overridable Protected Sub OnSearched( _
   ByVal e As Cambro.Web.QuickAdmin.SearchedEventArgs _
)
[C#]
protected virtual void OnSearched(
   SearchedEventArgs e
);

Parameters

e

SearchedEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnSearching Method

The OnSearching Event occurs when the search button has been clicked, but before the search is done

[Visual Basic]
Overridable Protected Sub OnSearching( _
   ByVal e As Cambro.Web.QuickAdmin.SearchingEventArgs _
)
[C#]
protected virtual void OnSearching(
   SearchingEventArgs e
);

Parameters

e

SearchingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnUpdated Method

The OnUpdated Event occurs after a record in the database has been updated

[Visual Basic]
Overridable Protected Sub OnUpdated( _
   ByVal e As Cambro.Web.QuickAdmin.UpdatedEventArgs _
)
[C#]
protected virtual void OnUpdated(
   UpdatedEventArgs e
);

Parameters

e

UpdatedEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnUpdating Method

The OnUpdating Event occurs before a record in the database has been updated

[Visual Basic]
Overridable Protected Sub OnUpdating( _
   ByVal e As Cambro.Web.QuickAdmin.UpdatingEventArgs _
)
[C#]
protected virtual void OnUpdating(
   UpdatingEventArgs e
);

Parameters

e

UpdatingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.OnViewing Method

The OnViewing Event occurs when a record in the Results Data Grid has been selected and the page goes into View Mode

[Visual Basic]
Overridable Protected Sub OnViewing( _
   ByVal e As Cambro.Web.QuickAdmin.ViewingEventArgs _
)
[C#]
protected virtual void OnViewing(
   ViewingEventArgs e
);

Parameters

e

ViewingEventArgs e

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Render Method

Overridden Render to create table tags around children

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin Events

The events of the Admin class are listed below. For a complete list of Admin class members, see the Admin Members topic.

Public Instance Events

Adding | The Event fired when QuickAdmin has gone into Add Mode
Deleted | The Event fired when a record has been deleted
Deleting | The Event fired when a record is about to be deleted
Editing | The Event fired when QuickAdmin has gone into Edit Mode
Inserted | The Event fired when a record has been inserted
Inserting | The Event fired when a record is about to be inserted
Resetting | The Event fired when the Search Controls are about to be reset
Searched | The Event fired when the database has been searched
Searching | The Event fired when the database is about to be searched
Updated | The Event fired when a record has been updated
Updating | The Event fired when a record is about to be updated
Viewing | The Event fired when QuickAdmin is going into View Mode

See Also

Admin Class | Cambro.Web.QuickAdmin Namespace


Admin.Adding Event

The Event fired when QuickAdmin has gone into Add Mode

[Visual Basic]
Public Adding As Cambro.Web.QuickAdmin.AddingEventHandler
[C#]
public AddingEventHandler Adding;

Event Data

The event handler receives a AddingEventArgs containing data related to the Adding event. The following AddingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
MessageLocation |
MessageText |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Deleted Event

The Event fired when a record has been deleted

[Visual Basic]
Public Deleted As Cambro.Web.QuickAdmin.DeletedEventHandler
[C#]
public DeletedEventHandler Deleted;

Event Data

The event handler receives a DeletedEventArgs containing data related to the Deleted event. The following DeletedEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Deleting Event

The Event fired when a record is about to be deleted

[Visual Basic]
Public Deleting As Cambro.Web.QuickAdmin.DeletingEventHandler
[C#]
public DeletingEventHandler Deleting;

Event Data

The event handler receives a DeletingEventArgs containing data related to the Deleting event. The following DeletingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
Execute | Should this command complete?
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Editing Event

The Event fired when QuickAdmin has gone into Edit Mode

[Visual Basic]
Public Editing As Cambro.Web.QuickAdmin.EditingEventHandler
[C#]
public EditingEventHandler Editing;

Event Data

The event handler receives a EditingEventArgs containing data related to the Editing event. The following EditingEventArgs properties provide information specific to this event.

Property | Description
AllowDelete | Should the user be allowed to delete this record, or should the delete button be hidden?
AllowSave | Should the user be allowed to save any changes to this record, or should the save button be hidden?
DisplayMessage |
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Inserted Event

The Event fired when a record has been inserted

[Visual Basic]
Public Inserted As Cambro.Web.QuickAdmin.InsertedEventHandler
[C#]
public InsertedEventHandler Inserted;

Event Data

The event handler receives a InsertedEventArgs containing data related to the Inserted event. The following InsertedEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Inserting Event

The Event fired when a record is about to be inserted

[Visual Basic]
Public Inserting As Cambro.Web.QuickAdmin.InsertingEventHandler
[C#]
public InsertingEventHandler Inserting;

Event Data

The event handler receives a InsertingEventArgs containing data related to the Inserting event. The following InsertingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
Execute | Should this command complete?
MessageLocation |
MessageText |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Resetting Event

The Event fired when the Search Controls are about to be reset

[Visual Basic]
Public Resetting As Cambro.Web.QuickAdmin.ResettingEventHandler
[C#]
public ResettingEventHandler Resetting;

Event Data

The event handler receives a ResettingEventArgs containing data related to the Resetting event. The following ResettingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
MessageLocation |
MessageText |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Searched Event

The Event fired when the database has been searched

[Visual Basic]
Public Searched As Cambro.Web.QuickAdmin.SearchedEventHandler
[C#]
public SearchedEventHandler Searched;

Event Data

The event handler receives a SearchedEventArgs containing data related to the Searched event. The following SearchedEventArgs properties provide information specific to this event.

Property | Description
AllowPaging | Should the ResultsDataGrid Page or not?
DisplayMessage |
MessageLocation |
MessageText |
PageNumber | Page number if paging;
PageSize | Page size of the ResultsGrid
Results | The number of records in the database which have been returned.
SearchType | Enumeration to Allow the Administrator to determine the type of search that was made.
SimpleSearchText | Text in the Simple Search Box
SqlString | The Query that was run on the database based on the search.

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Searching Event

The Event fired when the database is about to be searched

[Visual Basic]
Public Searching As Cambro.Web.QuickAdmin.SearchingEventHandler
[C#]
public SearchingEventHandler Searching;

Event Data

The event handler receives a SearchingEventArgs containing data related to the Searching event. The following SearchingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
Execute | Should this command complete?
MessageLocation |
MessageText |
Results | Number of results to return
SearchType | Enumeration to allow the administrator to change the type of search
SimpleSearchText | Text in the Simple Search Box
SortOrder | Statement to be appended to the end of the SQL Select Query. This would be statements such as "Employees.EmployeeID ASC". Ensure you have specified a Table if the same field name occurs in two tables.
WhereClause | Text to add to the Where Clause of the search which is added: "AND (WhereClause)"

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Updated Event

The Event fired when a record has been updated

[Visual Basic]
Public Updated As Cambro.Web.QuickAdmin.UpdatedEventHandler
[C#]
public UpdatedEventHandler Updated;

Event Data

The event handler receives a UpdatedEventArgs containing data related to the Updated event. The following UpdatedEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Updating Event

The Event fired when a record is about to be updated

[Visual Basic]
Public Updating As Cambro.Web.QuickAdmin.UpdatingEventHandler
[C#]
public UpdatingEventHandler Updating;

Event Data

The event handler receives a UpdatingEventArgs containing data related to the Updating event. The following UpdatingEventArgs properties provide information specific to this event.

Property | Description
DisplayMessage |
Execute | Should this command complete?
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Admin.Viewing Event

The Event fired when QuickAdmin is going into View Mode

[Visual Basic]
Public Viewing As Cambro.Web.QuickAdmin.ViewingEventHandler
[C#]
public ViewingEventHandler Viewing;

Event Data

The event handler receives a ViewingEventArgs containing data related to the Viewing event. The following ViewingEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Should the user be allowed to edit this record?
DisplayMessage |
MessageLocation |
MessageText |
PrimaryID |
SecondaryID |

See Also

Admin Class | Admin Members | Cambro.Web.QuickAdmin Namespace


Advanced Class

Control Class Advanced Contains the Advanced Controls

For a list of all members of this type, see Advanced Members.

System.Object
Control
Advanced

[Visual Basic]
Public Class Advanced
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor
[C#]
public class Advanced : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Advanced Members | Cambro.Web.QuickAdmin Namespace


Advanced Members

Public Instance Constructors

Advanced Constructor

Public Instance Fields

ParentSearch The Parent SearchControl to this Advanced Control

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
EnableViewState (inherited from System.Web.UI.Control)
ID (inherited from System.Web.UI.Control)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
Site (inherited from System.Web.UI.Control)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)

Public Instance Methods

DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
RenderControl (inherited from Control)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overridden OnInit used to create links to the Parent and Child Controls
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render Function enabling the user to hide and show the Advanced Controls
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Advanced Class | Cambro.Web.QuickAdmin Namespace


Advanced Constructor

[Visual Basic]
Public Sub New()
[C#]
public Advanced();

See Also

Advanced Class | Advanced Members | Cambro.Web.QuickAdmin Namespace


Advanced Fields

The fields of the Advanced class are listed below. For a complete list of Advanced class members, see the Advanced Members topic.

Public Instance Fields

ParentSearch The Parent SearchControl to this Advanced Control

See Also

Advanced Class | Cambro.Web.QuickAdmin Namespace


Advanced.ParentSearch Field

The Parent SearchControl to this Advanced Control

[Visual Basic]
Public ParentSearch As Cambro.Web.QuickAdmin.SearchControl
[C#]
public SearchControl ParentSearch;

See Also

Advanced Class | Advanced Members | Cambro.Web.QuickAdmin Namespace


Advanced Methods

The methods of the Advanced class are listed below. For a complete list of Advanced class members, see the Advanced Members topic.

Public Instance Methods

DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
RenderControl (inherited from Control)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overridden OnInit used to create links to the Parent and Child Controls
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render Function enabling the user to hide and show the Advanced Controls
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Advanced Class | Cambro.Web.QuickAdmin Namespace


Advanced.OnInit Method

Overridden OnInit used to create links to the Parent and Child Controls

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Advanced Class | Advanced Members | Cambro.Web.QuickAdmin Namespace


Advanced.Render Method

Overridden Render Function enabling the user to hide and show the Advanced Controls

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

Advanced Class | Advanced Members | Cambro.Web.QuickAdmin Namespace


DataLists Class

Summary description for DataList.

For a list of all members of this type, see DataLists Members.

System.Object
Control
WebControl
ListControl
DataLists

[Visual Basic]
Public Class DataLists
   Inherits ListControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor
[C#]
public class DataLists : ListControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

DataLists Members | Cambro.Web.QuickAdmin Namespace


DataLists Members

Public Instance Constructors

DataLists Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl)
Attributes (inherited from System.Web.UI.WebControls.WebControl)
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl)
BackColor (inherited from System.Web.UI.WebControls.WebControl)
BindingContainer (inherited from System.Web.UI.Control)
BorderColor (inherited from System.Web.UI.WebControls.WebControl)
BorderStyle (inherited from System.Web.UI.WebControls.WebControl)
BorderWidth (inherited from System.Web.UI.WebControls.WebControl)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
ControlStyle (inherited from System.Web.UI.WebControls.WebControl)
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl)
CssClass (inherited from System.Web.UI.WebControls.WebControl)
DataMember (inherited from System.Web.UI.WebControls.ListControl)
DataSource (inherited from System.Web.UI.WebControls.ListControl)
DataTextField (inherited from System.Web.UI.WebControls.ListControl)
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl)
DataValueField (inherited from System.Web.UI.WebControls.ListControl)
Enabled (inherited from System.Web.UI.WebControls.WebControl)
EnableViewState (inherited from System.Web.UI.Control)
Font (inherited from System.Web.UI.WebControls.WebControl)
ForeColor (inherited from System.Web.UI.WebControls.WebControl)
Height (inherited from System.Web.UI.WebControls.WebControl)
ID (inherited from System.Web.UI.Control)
Items (inherited from System.Web.UI.WebControls.ListControl)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl)
SelectedItem (inherited from System.Web.UI.WebControls.ListControl)
Site (inherited from System.Web.UI.Control)
Style (inherited from System.Web.UI.WebControls.WebControl)
TabIndex (inherited from System.Web.UI.WebControls.WebControl)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
ToolTip (inherited from System.Web.UI.WebControls.WebControl)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)
Width (inherited from System.Web.UI.WebControls.WebControl)

Public Instance Methods

ApplyStyle (inherited from WebControl)
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad (inherited from Control) |
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | The Render is function is overriden to prevent this ListControl from rendering.
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

DataLists Class | Cambro.Web.QuickAdmin Namespace


DataLists Constructor

[Visual Basic]
Public Sub New()
[C#]
public DataLists();

See Also

DataLists Class | DataLists Members | Cambro.Web.QuickAdmin Namespace


DataLists Methods

The methods of the DataLists class are listed below. For a complete list of DataLists class members, see the DataLists Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad (inherited from Control) |
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | The Render is function is overriden to prevent this ListControl from rendering.
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

DataLists Class | Cambro.Web.QuickAdmin Namespace


DataLists.Render Method

The Render is function is overriden to prevent this ListControl from rendering.

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal e As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter e
);

Parameters

e

See Also

DataLists Class | DataLists Members | Cambro.Web.QuickAdmin Namespace


ResultsControl Class

Control which contains and controls the ResultsDataGrid

For a list of all members of this type, see ResultsControl Members.

System.Object
Control
ResultsControl

[Visual Basic]
Public Class ResultsControl
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor
[C#]
public class ResultsControl : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl Members

Public Instance Constructors

ResultsControl Constructor

Public Instance Fields

ParentAdmin | The Parent Admin Control of this ResultsControl
ResultsGrid | This is the ResultsDataGrid contained by the Results Control

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
EnableViewState (inherited from System.Web.UI.Control)
ID (inherited from System.Web.UI.Control)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
Site (inherited from System.Web.UI.Control)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)

Public Instance Methods

AddButton | Add the ResultsControl Add Button
AllFields | Returns all the Fields to be rendered of the datagrid
DataBind (inherited from Control) |
Dispose (inherited from Control) |
DoSearch | Fill the ResultsControl if the search functionality is not used
DoSort | Sort the ResultsControl if no Search is used
Equals (inherited from Object) |
fff | Empty Event Handler
Fields | Function to Return the Fields required by the ResultsDataGrid
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Add the Literal Control which displays "No ResultsControl Found" to the ResultsControl Control
OnLoad | Should I show the add button and Footer (depends on whether Search == null or not)
OnPreRender | Overridden OnPreRender which either shows or hides the Add Button if necessary
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to add a Header Row of 'ResultsControl'
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

ResultsControl Class | Cambro.Web.QuickAdmin Namespace


ResultsControl Constructor

[Visual Basic]
Public Sub New()
[C#]
public ResultsControl();

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl Fields

The fields of the ResultsControl class are listed below. For a complete list of ResultsControl class members, see the ResultsControl Members topic.

Public Instance Fields

ParentAdmin | The Parent Admin Control of this ResultsControl
ResultsGrid | This is the ResultsDataGrid contained by the Results Control

See Also

ResultsControl Class | Cambro.Web.QuickAdmin Namespace


ResultsControl.ParentAdmin Field

The Parent Admin Control of this ResultsControl

[Visual Basic]
Public ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin;

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.ResultsGrid Field

This is the ResultsDataGrid contained by the Results Control

[Visual Basic]
Public ResultsGrid As Cambro.Web.QuickAdmin.ResultsDataGrid
[C#]
public ResultsDataGrid ResultsGrid;

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl Methods

The methods of the ResultsControl class are listed below. For a complete list of ResultsControl class members, see the ResultsControl Members topic.

Public Instance Methods

AddButton | Add the ResultsControl Add Button
AllFields | Returns all the Fields to be rendered of the datagrid
DataBind (inherited from Control) |
Dispose (inherited from Control) |
DoSearch | Fill the ResultsControl if the search functionality is not used
DoSort | Sort the ResultsControl if no Search is used
Equals (inherited from Object) |
fff | Empty Event Handler
Fields | Function to Return the Fields required by the ResultsDataGrid
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Add the Literal Control which displays "No ResultsControl Found" to the ResultsControl Control
OnLoad | Should I show the add button and Footer (depends on whether Search == null or not)
OnPreRender | Overridden OnPreRender which either shows or hides the Add Button if necessary
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to add a Header Row of 'ResultsControl'
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

ResultsControl Class | Cambro.Web.QuickAdmin Namespace


ResultsControl.AddButton Method

Add the ResultsControl Add Button

[Visual Basic]
Public Sub AddButton()
[C#]
public void AddButton();

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.AllFields Method

Returns all the Fields to be rendered of the datagrid

[Visual Basic]
Public Function AllFields( _
   ByVal ThisJoin As String _
) As String
[C#]
public string AllFields(
   string ThisJoin
);

Return Value

a string with comma separated fields

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.DoSearch Method

Fill the ResultsControl if the search functionality is not used

[Visual Basic]
Public Sub DoSearch()
[C#]
public void DoSearch();

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.DoSort Method

Sort the ResultsControl if no Search is used

[Visual Basic]
Public Sub DoSort( _
   ByVal b As Object, _
   ByVal e As System.Web.UI.WebControls.DataGridSortCommandEventArgs _
)
[C#]
public void DoSort(
   object b,
   DataGridSortCommandEventArgs e
);

Parameters

b

e

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.fff Method

Empty Event Handler

[Visual Basic]
Public Sub fff( _
   ByVal o As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public void fff(
   object o,
   EventArgs e
);

Parameters

o

e

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.Fields Method

Function to Return the Fields required by the ResultsDataGrid

[Visual Basic]
Public Function Fields( _
   ByVal ThisJoin As String _
) As String
[C#]
public string Fields(
   string ThisJoin
);

Return Value

String containing Comma Separated Fields

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.OnBubble Method

Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control

[Visual Basic]
Overridable Protected Sub OnBubble( _
   ByVal e As System.EventArgs _
)
[C#]
protected virtual void OnBubble(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.OnInit Method

Add the Literal Control which displays "No ResultsControl Found" to the ResultsControl Control

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.OnLoad Method

Should I show the add button and Footer (depends on whether Search == null or not)

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.OnPreRender Method

Overridden OnPreRender which either shows or hides the Add Button if necessary

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


ResultsControl.Render Method

Overridden Render to add a Header Row of 'ResultsControl'

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

ResultsControl Class | ResultsControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl Class

Controls whic contains the Simple and Advanced Search Controls

For a list of all members of this type, see SearchControl Members.

System.Object
Control
SearchControl

[Visual Basic]
Public Class SearchControl
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor
[C#]
public class SearchControl : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl Members

Public Instance Constructors

SearchControl Constructor

Public Instance Fields

AdvancedContainer | Control that contains the Advanced Controls
ParentAdmin | The Parent Admin Control of this SearchControl
SimpleContainer | Control that contains the Simple Controls

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
EnableViewState (inherited from System.Web.UI.Control)
ID (inherited from System.Web.UI.Control)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
Site (inherited from System.Web.UI.Control)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MoreOr | Takes a string which may or may not contain spaces and slices it into single words and creates the Where statement
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overridden OnInit used to create links to the Parent and Child Controls
OnLoad | Overridden OnPreRender determines the Status of the Admin Control and Search or Resets based on this
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control) |
DoSearch | Function which executes the SQL queries based on the state of the Admin Control and the Search Type
RemovedControl (inherited from Control) |

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

SearchControl Class | Cambro.Web.QuickAdmin Namespace


SearchControl Constructor

[Visual Basic]
Public Sub New()
[C#]
public SearchControl();

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl Fields

The fields of the SearchControl class are listed below. For a complete list of SearchControl class members, see the SearchControl Members topic.

Public Instance Fields

AdvancedContainer | Control that contains the Advanced Controls
ParentAdmin | The Parent Admin Control of this SearchControl
SimpleContainer | Control that contains the Simple Controls

See Also

SearchControl Class | Cambro.Web.QuickAdmin Namespace


SearchControl.AdvancedContainer Field

Control that contains the Advanced Controls

[Visual Basic]
Public AdvancedContainer As Cambro.Web.QuickAdmin.Advanced
[C#]
public Advanced AdvancedContainer;

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.ParentAdmin Field

The Parent Admin Control of this SearchControl

[Visual Basic]
Public ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin;

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.SimpleContainer Field

Control that contains the Simple Controls

[Visual Basic]
Public SimpleContainer As Cambro.Web.QuickAdmin.Simple
[C#]
public Simple SimpleContainer;

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl Methods

The methods of the SearchControl class are listed below. For a complete list of SearchControl class members, see the SearchControl Members topic.

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MoreOr | Takes a string which may or may not contain spaces and slices it into single words and creates the Where statement
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overridden OnInit used to create links to the Parent and Child Controls
OnLoad | Overridden OnPreRender determines the Status of the Admin Control and Search or Resets based on this
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control) |
DoSearch | Function which executes the SQL queries based on the state of the Admin Control and the Search Type
RemovedControl (inherited from Control) |

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

SearchControl Class | Cambro.Web.QuickAdmin Namespace


SearchControl.DoSearch Method

Function which executes the SQL queries based on the state of the Admin Control and the Search Type

[Visual Basic]
Protected Friend Sub DoSearch()
[C#]
protected internal void DoSearch();

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.MoreOr Method

Takes a string which may or may not contain spaces and slices it into single words and creates the Where statement

[Visual Basic]
Public Function MoreOr( _
   ByVal Text As String, _
   ByVal LocalField As String _
) As String
[C#]
public string MoreOr(
   string Text,
   string LocalField
);

Parameters

Text

The String which may or may not contain spaces

LocalField

The Field which may equal one of these words

Return Value

A Where Clause for use in the SQL statement

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.OnBubble Method

Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control

[Visual Basic]
Overridable Protected Sub OnBubble( _
   ByVal e As System.EventArgs _
)
[C#]
protected virtual void OnBubble(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.OnInit Method

Overridden OnInit used to create links to the Parent and Child Controls

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


SearchControl.OnLoad Method

Overridden OnPreRender determines the Status of the Admin Control and Search or Resets based on this

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

SearchControl Class | SearchControl Members | Cambro.Web.QuickAdmin Namespace


Simple Class

Simple Control Class which enables Text searching on a number of Fields in the database

For a list of all members of this type, see Simple Members.

System.Object
Control
Simple

[Visual Basic]
Public Class Simple
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor
[C#]
public class Simple : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Simple Members | Cambro.Web.QuickAdmin Namespace


Simple Members

Public Instance Constructors

Simple Constructor

Public Instance Fields

ParentSearch | The Parent SearchControl to this Simple Control
SearchBox | The TextBox which contains the Search Text

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
EnableViewState (inherited from System.Web.UI.Control)
ID (inherited from System.Web.UI.Control)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
Site (inherited from System.Web.UI.Control)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | Empty Event Handler
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Initiation Function which creates the buttons of the Control
OnLoad | Overriden OnPreRender which checks to see if it is necessary for an Add Button
OnPreRender | Overridden OnPreRender which either shows or hides the Add Button
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control) |
MakeExact | Protected Function which creates the Exact Query String
MakeRank | Protected Function which creates the Ranked Search Strings for each of the Fields being Searched
RemovedControl (inherited from Control) |

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Simple Class | Cambro.Web.QuickAdmin Namespace


Simple Constructor

[Visual Basic]
Public Sub New()
[C#]
public Simple();

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple Fields

The fields of the Simple class are listed below. For a complete list of Simple class members, see the Simple Members topic.

Public Instance Fields

ParentSearch | The Parent SearchControl to this Simple Control
SearchBox | The TextBox which contains the Search Text

See Also

Simple Class | Cambro.Web.QuickAdmin Namespace


Simple.ParentSearch Field

The Parent SearchControl to this Simple Control

[Visual Basic]
Public ParentSearch As Cambro.Web.QuickAdmin.SearchControl
[C#]
public SearchControl ParentSearch;

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.SearchBox Field

The TextBox which contains the Search Text

[Visual Basic]
Public SearchBox As System.Web.UI.WebControls.TextBox
[C#]
public TextBox SearchBox;

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple Methods

The methods of the Simple class are listed below. For a complete list of Simple class members, see the Simple Members topic.

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | Empty Event Handler
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Initiation Function which creates the buttons of the Control
OnLoad | Overriden OnPreRender which checks to see if it is necessary for an Add Button
OnPreRender | Overridden OnPreRender which either shows or hides the Add Button
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control) |
MakeExact | Protected Function which creates the Exact Query String
MakeRank | Protected Function which creates the Ranked Search Strings for each of the Fields being Searched
RemovedControl (inherited from Control) |

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Simple Class | Cambro.Web.QuickAdmin Namespace


Simple.fff Method

Empty Event Handler

[Visual Basic]
Public Sub fff( _
   ByVal o As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public void fff(
   object o,
   EventArgs e
);

Parameters

o

e

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.MakeExact Method

Protected Function which creates the Exact Query String

[Visual Basic]
Protected Friend Function MakeExact( _
   ByVal BoxText As String, _
   ByVal Field As String _
) As String
[C#]
protected internal string MakeExact(
   string BoxText,
   string Field
);

Parameters

BoxText

String representing the contents of the Simple Search TextBox

Field

String representing the Field being searched on

Return Value

The Exact Query

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.MakeRank Method

Protected Function which creates the Ranked Search Strings for each of the Fields being Searched

[Visual Basic]
Protected Friend Function MakeRank( _
   ByVal BoxText As String, _
   ByVal Field As String, _
   ByVal MatchMultiplier As Integer _
) As String
[C#]
protected internal string MakeRank(
   string BoxText,
   string Field,
   int MatchMultiplier
);

Parameters

BoxText

String representing the contents of the Simple Search TextBox

Field

String representing the Field being searched on

MatchMultiplier

The Match Multiplier for the Control

Return Value

A Case statement for this particular Text Value and Field

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.OnInit Method

Initiation Function which creates the buttons of the Control

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.OnLoad Method

Overriden OnPreRender which checks to see if it is necessary for an Add Button

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


Simple.OnPreRender Method

Overridden OnPreRender which either shows or hides the Add Button

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Simple Class | Simple Members | Cambro.Web.QuickAdmin Namespace


ViewControl Class

Control which contains and controls the View, Edit and Add Functionality

For a list of all members of this type, see ViewControl Members.

System.Object
Control
ViewControl

[Visual Basic]
Public Class ViewControl
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor
[C#]
public class ViewControl : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl Members

Public Instance Constructors

ViewControl Constructor Function to Initiate the various buttons

Public Instance Fields

ParentAdmin This is the Parent Admin Control of this ViewControl

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control)
ClientID (inherited from System.Web.UI.Control)
Controls (inherited from System.Web.UI.Control)
EnableViewState (inherited from System.Web.UI.Control)
ID (inherited from System.Web.UI.Control)
NamingContainer (inherited from System.Web.UI.Control)
Page (inherited from System.Web.UI.Control)
Parent (inherited from System.Web.UI.Control)
Site (inherited from System.Web.UI.Control)
TemplateSourceDirectory (inherited from System.Web.UI.Control)
UniqueID (inherited from System.Web.UI.Control)
Visible (inherited from System.Web.UI.Control)

Public Instance Methods

Bind | Called to bind the values of the record to the controls in Edit or View Mode
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | Empty Event Handler
Fields | Function to get the Field of all the child controls
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetID | Gets the ID of the Record in Edit or View Mode
GetType (inherited from Object) |
HasControls (inherited from Control) |
Refresh | This function can be used to rebind the values of the View/Edit pages. Should be used if an update has been done to this Record not directly by using QuickAdmin.
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SaveNew | Called when a new record needs to be saved to the database
SaveOld | Called when an existing record needs to be updated in the database
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Update | Called when the EditNote Field has had it's update button clicked

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Add Child Controls on Init so they can process their post data
OnLoad | Overridden OnPreRender controls the save and update queries, and which buttons are displayed
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

ViewControl Class | Cambro.Web.QuickAdmin Namespace


ViewControl Constructor

Function to Initiate the various buttons

[Visual Basic]
Public Sub New()
[C#]
public ViewControl();

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl Fields

The fields of the ViewControl class are listed below. For a complete list of ViewControl class members, see the ViewControl Members topic.

Public Instance Fields

ParentAdmin This is the Parent Admin Control of this ViewControl

See Also

ViewControl Class | Cambro.Web.QuickAdmin Namespace


ViewControl.ParentAdmin Field

This is the Parent Admin Control of this ViewControl

[Visual Basic]
Public ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin;

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl Methods

The methods of the ViewControl class are listed below. For a complete list of ViewControl class members, see the ViewControl Members topic.

Public Instance Methods

Bind | Called to bind the values of the record to the controls in Edit or View Mode
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | Empty Event Handler
Fields | Function to get the Field of all the child controls
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetID | Gets the ID of the Record in Edit or View Mode
GetType (inherited from Object) |
HasControls (inherited from Control) |
Refresh | This function can be used to rebind the values of the View/Edit pages. Should be used if an update has been done to this Record not directly by using QuickAdmin.
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SaveNew | Called when a new record needs to be saved to the database
SaveOld | Called when an existing record needs to be updated in the database
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Update | Called when the EditNote Field has had it's update button clicked

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubble | Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Add Child Controls on Init so they can process their post data
OnLoad | Overridden OnPreRender controls the save and update queries, and which buttons are displayed
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

ViewControl Class | Cambro.Web.QuickAdmin Namespace


ViewControl.Bind Method

Called to bind the values of the record to the controls in Edit or View Mode

[Visual Basic]
Public Sub Bind()
[C#]
public void Bind();

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.fff Method

Empty Event Handler

[Visual Basic]
Public Sub fff( _
   ByVal o As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public void fff(
   object o,
   EventArgs e
);

Parameters

o

e

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.Fields Method

Function to get the Field of all the child controls

[Visual Basic]
Public Function Fields() As String
[C#]
public string Fields();

Return Value

String with comma separated values

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.GetID Method

Gets the ID of the Record in Edit or View Mode

[Visual Basic]
Public Function GetID( _
   ByVal T As Cambro.Web.QuickAdmin.Admin _
) As String
[C#]
public string GetID(
   Admin T
);

Parameters

T

Return Value

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.OnBubble Method

Bubble Event used to bubble events from the ViewControl and SearchControl to the Admin Control

[Visual Basic]
Overridable Protected Sub OnBubble( _
   ByVal e As System.EventArgs _
)
[C#]
protected virtual void OnBubble(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.OnInit Method

Add Child Controls on Init so they can process their post data

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.OnLoad Method

Overridden OnPreRender controls the save and update queries, and which buttons are displayed

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.Refresh Method

This function can be used to rebind the values of the View/Edit pages. Should be used if an update has been done to this Record not directly by using QuickAdmin.

[Visual Basic]
Public Sub Refresh()
[C#]
public void Refresh();

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.Reset Method

Reset Inherited from IResetable

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.SaveNew Method

Called when a new record needs to be saved to the database

[Visual Basic]
Public Sub SaveNew( _
   ByVal T As Cambro.Web.QuickAdmin.Admin _
)
[C#]
public void SaveNew(
   Admin T
);

Parameters

T

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.SaveOld Method

Called when an existing record needs to be updated in the database

[Visual Basic]
Public Sub SaveOld( _
   ByVal T As Cambro.Web.QuickAdmin.Admin _
)
[C#]
public void SaveOld(
   Admin T
);

Parameters

T

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


ViewControl.Update Method

Called when the EditNote Field has had it's update button clicked

[Visual Basic]
Public Sub Update( _
   ByVal T As Cambro.Web.QuickAdmin.Admin _
)
[C#]
public void Update(
   Admin T
);

Parameters

T

See Also

ViewControl Class | ViewControl Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList Class

This control creates an edit control which binds fields from a Many to Many relationship, allowing the user to select none, one or many links based on various properties.

For a list of all members of this type, see EditCheckBoxList Members.

System.Object
Control
WebControl
EditCheckBoxList

[Visual Basic]
Public Class EditCheckBoxList
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable, IMany2Many, IOne2Many, IGroupFields
[C#]
public class EditCheckBoxList : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable, IMany2Many, IOne2Many, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList Members

Public Instance Constructors

EditCheckBoxList Constructor Initiating a False Check Box List

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should these Checkboxes appear in Add mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BetweenText | String to display between each value
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CheckBackColor | The Check Box List CheckBackColor Properties
CheckBorderColor | The Check Box List CheckBorderColor Properties
CheckBorderStyle | The Check Box List CheckBorderStyle Properties
CheckBorderWidth | The Check Box List CheckBorderWidth Properties
CheckCellPadding | The Check Box List CheckCellPadding Properties
CheckCellSpacing | The Check Box List CheckCellSpacing Properties
CheckCssClass | The Check Box List CheckCssClass Properties
CheckFont | The Check Box List CheckFont Properties
CheckForeColor | The Check Box List CheckForeColor Properties
CheckHeight | The Check Box List CheckHeight Properties
CheckStyle | The Check Box List CheckStyle Properties
CheckTextAlign | The Check Box List CheckTextAlign Properties
CheckToolTip | The Check Box List CheckToolTip Properties
CheckWidth | The Check Box List CheckWidth Properties
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Are these Checkboxes editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Key Field
IntermediateLocalKey | The Key which references the Local Table Key Field
IntermediateTable | The Intermediate Table Name
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns | The Check Box List RepeatColumns Properties
RepeatDirection | The Check Box List RepeatDirection Properties
RepeatLayout | The Check Box List RepeatLayout Properties
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Checkboxes
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Boxes
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Determines the check boxes which have been checked
MergeStyle (inherited from WebControl) |
Remove | Determines the check boxes which have been unchecked
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList Constructor

Initiating a False Check Box List

[Visual Basic]
Public Sub New()
[C#]
public EditCheckBoxList();

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList Properties

The properties of the EditCheckBoxList class are listed below. For a complete list of EditCheckBoxList class members, see the EditCheckBoxList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should these Checkboxes appear in Add mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BetweenText | String to display between each value
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CheckBackColor | The Check Box List CheckBackColor Properties
CheckBorderColor | The Check Box List CheckBorderColor Properties
CheckBorderStyle | The Check Box List CheckBorderStyle Properties
CheckBorderWidth | The Check Box List CheckBorderWidth Properties
CheckCellPadding | The Check Box List CheckCellPadding Properties
CheckCellSpacing | The Check Box List CheckCellSpacing Properties
CheckCssClass | The Check Box List CheckCssClass Properties
CheckFont | The Check Box List CheckFont Properties
CheckForeColor | The Check Box List CheckForeColor Properties
CheckHeight | The Check Box List CheckHeight Properties
CheckStyle | The Check Box List CheckStyle Properties
CheckTextAlign | The Check Box List CheckTextAlign Properties
CheckToolTip | The Check Box List CheckToolTip Properties
CheckWidth | The Check Box List CheckWidth Properties
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Are these Checkboxes editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Key Field
IntermediateLocalKey | The Key which references the Local Table Key Field
IntermediateTable | The Intermediate Table Name
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns | The Check Box List RepeatColumns Properties
RepeatDirection | The Check Box List RepeatDirection Properties
RepeatLayout | The Check Box List RepeatLayout Properties
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Checkboxes
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Addable Property

Should these Checkboxes appear in Add mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.BetweenText Property

String to display between each value

[Visual Basic]
Public Property BetweenText As String
[C#]
public string BetweenText {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckBackColor Property

The Check Box List CheckBackColor Properties

[Visual Basic]
Public Property CheckBackColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckBackColor {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckBorderColor Property

The Check Box List CheckBorderColor Properties

[Visual Basic]
Public Property CheckBorderColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckBorderColor {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckBorderStyle Property

The Check Box List CheckBorderStyle Properties

[Visual Basic]
Public Property CheckBorderStyle As System.Web.UI.WebControls.BorderStyle
[C#]
public System.Web.UI.WebControls.BorderStyle CheckBorderStyle {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckBorderWidth Property

The Check Box List CheckBorderWidth Properties

[Visual Basic]
Public Property CheckBorderWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckBorderWidth {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckCellPadding Property

The Check Box List CheckCellPadding Properties

[Visual Basic]
Public Property CheckCellPadding As Integer
[C#]
public int CheckCellPadding {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckCellSpacing Property

The Check Box List CheckCellSpacing Properties

[Visual Basic]
Public Property CheckCellSpacing As Integer
[C#]
public int CheckCellSpacing {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckCssClass Property

The Check Box List CheckCssClass Properties

[Visual Basic]
Public Property CheckCssClass As String
[C#]
public string CheckCssClass {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckFont Property

The Check Box List CheckFont Properties

[Visual Basic]
Public ReadOnly Property CheckFont As System.Web.UI.WebControls.FontInfo
[C#]
public System.Web.UI.WebControls.FontInfo CheckFont {get;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckForeColor Property

The Check Box List CheckForeColor Properties

[Visual Basic]
Public Property CheckForeColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckForeColor {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckHeight Property

The Check Box List CheckHeight Properties

[Visual Basic]
Public Property CheckHeight As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckHeight {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckStyle Property

The Check Box List CheckStyle Properties

[Visual Basic]
Public ReadOnly Property CheckStyle As System.Web.UI.CssStyleCollection
[C#]
public System.Web.UI.CssStyleCollection CheckStyle {get;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckTextAlign Property

The Check Box List CheckTextAlign Properties

[Visual Basic]
Public Property CheckTextAlign As System.Web.UI.WebControls.TextAlign
[C#]
public System.Web.UI.WebControls.TextAlign CheckTextAlign {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckToolTip Property

The Check Box List CheckToolTip Properties

[Visual Basic]
Public Property CheckToolTip As String
[C#]
public string CheckToolTip {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.CheckWidth Property

The Check Box List CheckWidth Properties

[Visual Basic]
Public Property CheckWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckWidth {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Editable Property

Are these Checkboxes editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.ForeignDataField Property

The Data Field to display from the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.ForeignKeyField Property

The One2Many Key Field

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.IntermediateForeignKey Property

The Key which references the One2Many Table Key Field

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.IntermediateLocalKey Property

The Key which references the Local Table Key Field

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.IntermediateTable Property

The Intermediate Table Name

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.RepeatColumns Property

The Check Box List RepeatColumns Properties

[Visual Basic]
Public Property RepeatColumns As Integer
[C#]
public int RepeatColumns {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.RepeatDirection Property

The Check Box List RepeatDirection Properties

[Visual Basic]
Public Property RepeatDirection As System.Web.UI.WebControls.RepeatDirection
[C#]
public System.Web.UI.WebControls.RepeatDirection RepeatDirection {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.RepeatLayout Property

The Check Box List RepeatLayout Properties

[Visual Basic]
Public Property RepeatLayout As System.Web.UI.WebControls.RepeatLayout
[C#]
public System.Web.UI.WebControls.RepeatLayout RepeatLayout {get; set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Title Property

String to display to the left of the Checkboxes

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList Methods

The methods of the EditCheckBoxList class are listed below. For a complete list of EditCheckBoxList class members, see the EditCheckBoxList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Boxes
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Determines the check boxes which have been checked
MergeStyle (inherited from WebControl) |
Remove | Determines the check boxes which have been unchecked
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Bind Method

Checks the Check Boxes

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String representing the Local Primary Key

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Insert Method

Determines the check boxes which have been checked

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

ArrayList of Strings of the new values to added to the database

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.OnLoad Method

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Remove Method

Determines the check boxes which have been unchecked

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

ArrayList of Strings of the new values be removed from the database

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditCheckBoxList.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditCheckBoxList Class | EditCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


EditControl Class

This Edit Control is a control which can be used to create special Edit Controls. This needs to be inherited and implemented as you like.

For a list of all members of this type, see EditControl Members.

System.Object
Control
EditControl

[Visual Basic]
Public Class EditControl
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IBindable, ILocal, IResetable
[C#]
public class EditControl : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IBindable, ILocal, IResetable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl Members

Public Instance Constructors

EditControl Constructor

Public Instance Properties

Addable | Should this Control appear in Add mode? Default True
BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
Editable | Is this Control editable in Edit mode? Default True
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue |
Title | String to display to the left of the File Upload Box
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |

Public Instance Methods

Bind | Is there something in there?
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overriden OnInit
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

EditControl Class | Cambro.Web.QuickAdmin Namespace


EditControl Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditControl();

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl Properties

The properties of the EditControl class are listed below. For a complete list of EditControl class members, see the EditControl Members topic.

Public Instance Properties

Addable | Should this Control appear in Add mode? Default True
BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
Editable | Is this Control editable in Edit mode? Default True
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue |
Title | String to display to the left of the File Upload Box
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditControl Class | Cambro.Web.QuickAdmin Namespace


EditControl.Addable Property

Should this Control appear in Add mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.Editable Property

Is this Control editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.textValue Property

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.Title Property

String to display to the left of the File Upload Box

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl Methods

The methods of the EditControl class are listed below. For a complete list of EditControl class members, see the EditControl Members topic.

Public Instance Methods

Bind | Is there something in there?
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overriden OnInit
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

EditControl Class | Cambro.Web.QuickAdmin Namespace


EditControl.Bind Method

Is there something in there?

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String representing the Local Primary Key

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.OnInit Method

Overriden OnInit

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditControl.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditControl Class | EditControl Members | Cambro.Web.QuickAdmin Namespace


EditDate Class

Control which creates an edit Calendar control bound to the LocalField. This control allows the user to edit the datetime fields of the records in your database table.

For a list of all members of this type, see EditDate Members.

System.Object
Control
WebControl
Calendar
EditDate

[Visual Basic]
Public Class EditDate
   Inherits Calendar
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, IBindable, ILocal, IDate, IResetable
[C#]
public class EditDate : Calendar, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, IBindable, ILocal, IDate, IResetable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate Members

Public Instance Constructors

EditDate Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Editable | Is this textbox editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the Text of the TextBox
Title | String to display to the left of the Textbox
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditDate Class | Cambro.Web.QuickAdmin Namespace


EditDate Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditDate();

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate Properties

The properties of the EditDate class are listed below. For a complete list of EditDate class members, see the EditDate Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Editable | Is this textbox editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the Text of the TextBox
Title | String to display to the left of the Textbox
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditDate Class | Cambro.Web.QuickAdmin Namespace


EditDate.Addable Property

Should this control appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Editable Property

Is this textbox editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.StartDate Property

The date to be appear on the Calendar Control if no date is selected

[Visual Basic]
Public Property StartDate As Date
[C#]
public System.DateTime StartDate {get; set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.textValue Property

Gets and Sets the Text of the TextBox

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate Methods

The methods of the EditDate class are listed below. For a complete list of EditDate class members, see the EditDate Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditDate Class | Cambro.Web.QuickAdmin Namespace


EditDate.Bind Method

Sets the value of the TextBox to the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String to place in the TextBox

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDate.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditDate Class | EditDate Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList Class

This control creates an edit control which enables the user to select a value for this field in the relevant record based on the value of a Drop Down List which could come from a linked table or a DataLists Control.

For a list of all members of this type, see EditDropDownList Members.

System.Object
Control
WebControl
ListControl
DropDownList
EditDropDownList

[Visual Basic]
Public Class EditDropDownList
   Inherits DropDownList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, IOne2Many, IDataList, IGroupFields
[C#]
public class EditDropDownList : DropDownList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, IOne2Many, IDataList, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList Members

Public Instance Constructors

EditDropDownList Constructor

Public Instance Fields

AddZero Should there be an empty field with value zero inserted into the DropDown

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this Drop Down List appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | ID of the DataList to bind to this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Drop Down List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignDataFields | This property is never used
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignKeyFields | This property is never used
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
Bind | Sepecify the selected from the value of 'bound'
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Override OnLoad to create the Drop Down Data
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditDropDownList Class | Cambro.Web.QuickAdmin Namespace


EditDropDownList Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditDropDownList();

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList Fields

The fields of the EditDropDownList class are listed below. For a complete list of EditDropDownList class members, see the EditDropDownList Members topic.

Public Instance Fields

AddZero Should there be an empty field with value zero inserted into the DropDown

See Also

EditDropDownList Class | Cambro.Web.QuickAdmin Namespace


EditDropDownList.AddZero Field

Should there be an empty field with value zero inserted into the DropDown

[Visual Basic]
Public AddZero As Boolean
[C#]
public bool AddZero;

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList Properties

The properties of the EditDropDownList class are listed below. For a complete list of EditDropDownList class members, see the EditDropDownList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this Drop Down List appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | ID of the DataList to bind to this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Drop Down List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignDataFields | This property is never used
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignKeyFields | This property is never used
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditDropDownList Class | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Addable Property

Should this Drop Down List appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.DataSet Property

ID of the DataList to bind to this control

[Visual Basic]
NotOverridable Public Property DataSet As String
[C#]
public string DataSet {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Editable Property

Is this Drop Down List editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignDataField Property

The Data Field to display from the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignDataFields Property

This property is never used

[Visual Basic]
Public Property ForeignDataFields As String
[C#]
public string ForeignDataFields {get; set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignKeyField Property

The One2Many Key Field

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignKeyFields Property

This property is never used

[Visual Basic]
Public Property ForeignKeyFields As String
[C#]
public string ForeignKeyFields {get; set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList Methods

The methods of the EditDropDownList class are listed below. For a complete list of EditDropDownList class members, see the EditDropDownList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
Bind | Sepecify the selected from the value of 'bound'
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Override OnLoad to create the Drop Down Data
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditDropDownList Class | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Bind Method

Sepecify the selected from the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal Texts As String _
)
[C#]
public final void Bind(
   string Texts
);

Parameters

Texts

String in the Drop Down List

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.BindDataSet Method

This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control

            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);

[Visual Basic]
NotOverridable Public Sub BindDataSet()
[C#]
public final void BindDataSet();

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.OnLoad Method

Override OnLoad to create the Drop Down Data

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditDropDownList.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditDropDownList Class | EditDropDownList Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload Class

An edit control which enables uploading of files to the database. In view mode, if a record exists it will say, otherwise it will say it is empty, and lets the user upload a file in edit mode if they specify one, otherwise the file in the database will be persisited.

For a list of all members of this type, see EditFileUpload Members.

System.Object
Control
WebControl
EditFileUpload

[Visual Basic]
Public Class EditFileUpload
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable
[C#]
public class EditFileUpload : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload Members

Public Instance Constructors

EditFileUpload Constructor Adding Controls

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should these Checkboxes appear in Edit mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Are these Checkboxes editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue |
Title | String to display to the left of the File Upload Box
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Is there something in there?
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overriden OnInit
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditFileUpload Class | Cambro.Web.QuickAdmin Namespace


EditFileUpload Constructor

Adding Controls

[Visual Basic]
Public Sub New()
[C#]
public EditFileUpload();

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload Properties

The properties of the EditFileUpload class are listed below. For a complete list of EditFileUpload class members, see the EditFileUpload Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should these Checkboxes appear in Edit mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Are these Checkboxes editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue |
Title | String to display to the left of the File Upload Box
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditFileUpload Class | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Addable Property

Should these Checkboxes appear in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Editable Property

Are these Checkboxes editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.textValue Property

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Title Property

String to display to the left of the File Upload Box

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload Methods

The methods of the EditFileUpload class are listed below. For a complete list of EditFileUpload class members, see the EditFileUpload Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Is there something in there?
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Overriden OnInit
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditFileUpload Class | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Bind Method

Is there something in there?

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String representing the Local Primary Key

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.OnInit Method

Overriden OnInit

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Render Method

Overridden Render

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditFileUpload.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditFileUpload Class | EditFileUpload Members | Cambro.Web.QuickAdmin Namespace


EditIntBox Class

This control creates an edit control which allows the user to edit a integer or other numeric field from the database table.

For a list of all members of this type, see EditIntBox Members.

System.Object
Control
WebControl
TextBox
EditIntBox

[Visual Basic]
Public Class EditIntBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, ISetToNull
[C#]
public class EditIntBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, ISetToNull

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox Members

Public Instance Constructors

EditIntBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Is this Text Box editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditIntBox Class | Cambro.Web.QuickAdmin Namespace


EditIntBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditIntBox();

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox Properties

The properties of the EditIntBox class are listed below. For a complete list of EditIntBox class members, see the EditIntBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Is this Text Box editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditIntBox Class | Cambro.Web.QuickAdmin Namespace


EditIntBox.Addable Property

Should this control appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Editable Property

Is this Text Box editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.SetToNullIfEmpty Property

If this field is empty, set the value to null in the database

[Visual Basic]
NotOverridable Public Property SetToNullIfEmpty As Boolean
[C#]
public bool SetToNullIfEmpty {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox Methods

The methods of the EditIntBox class are listed below. For a complete list of EditIntBox class members, see the EditIntBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditIntBox Class | Cambro.Web.QuickAdmin Namespace


EditIntBox.Bind Method

Sets the value of the TextBox to the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String to place in the TextBox

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditIntBox.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditIntBox Class | EditIntBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox Class

This edit control allows the user to view a list of all the possible Many to Many links from the database and select either one or multiple rows to store in the database

For a list of all members of this type, see EditListBox Members.

System.Object
Control
WebControl
EditListBox

[Visual Basic]
Public Class EditListBox
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable, IMany2Many, IOne2Many, IGroupFields
[C#]
public class EditListBox : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IBindable, ILocal, IResetable, IMany2Many, IOne2Many, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox Members

Public Instance Constructors

EditListBox Constructor Initiating a False Check Box List

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this List Box appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BetweenText | String to display between each value
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Should this List Box be editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Key Field
IntermediateLocalKey | The Key which references the Local Table Key Field
IntermediateTable | The Intermediate Table Name
ListBackColor | The Check Box List CheckBackColor Properties
ListBorderColor | The List Box CheckBorderColor Properties
ListBorderStyle | The List Box CheckBorderStyle Properties
ListBorderWidth | The List Box CheckBorderWidth Properties
ListControlStyle | The List Box CheckBorderStyle Properties
ListCssClass | The List Box CheckCssClass Properties
ListFont | The List Box CheckFont Properties
ListForeColor | The List Box CheckForeColor Properties
ListHeight | The List Box CheckHeight Properties
ListRows | The List Box RepeatColumns Properties
ListStyle | The List Box CheckStyle Properties
ListWidth | The List Box CheckWidth Properties
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectionMode | Repeat Direction???
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Checkboxes
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Boxes
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Determines the check boxes which have been checked
MergeStyle (inherited from WebControl) |
Remove | Determines the check boxes which have been unchecked
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditListBox Class | Cambro.Web.QuickAdmin Namespace


EditListBox Constructor

Initiating a False Check Box List

[Visual Basic]
Public Sub New()
[C#]
public EditListBox();

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox Properties

The properties of the EditListBox class are listed below. For a complete list of EditListBox class members, see the EditListBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this List Box appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BetweenText | String to display between each value
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Should this List Box be editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | The Data Field to display from the One2Many Table
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The One2Many Key Field
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Key Field
IntermediateLocalKey | The Key which references the Local Table Key Field
IntermediateTable | The Intermediate Table Name
ListBackColor | The Check Box List CheckBackColor Properties
ListBorderColor | The List Box CheckBorderColor Properties
ListBorderStyle | The List Box CheckBorderStyle Properties
ListBorderWidth | The List Box CheckBorderWidth Properties
ListControlStyle | The List Box CheckBorderStyle Properties
ListCssClass | The List Box CheckCssClass Properties
ListFont | The List Box CheckFont Properties
ListForeColor | The List Box CheckForeColor Properties
ListHeight | The List Box CheckHeight Properties
ListRows | The List Box RepeatColumns Properties
ListStyle | The List Box CheckStyle Properties
ListWidth | The List Box CheckWidth Properties
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
SelectionMode | Repeat Direction???
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Checkboxes
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditListBox Class | Cambro.Web.QuickAdmin Namespace


EditListBox.Addable Property

Should this List Box appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.BetweenText Property

String to display between each value

[Visual Basic]
Public Property BetweenText As String
[C#]
public string BetweenText {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Editable Property

Should this List Box be editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ForeignDataField Property

The Data Field to display from the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ForeignKeyField Property

The One2Many Key Field

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.IntermediateForeignKey Property

The Key which references the One2Many Table Key Field

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.IntermediateLocalKey Property

The Key which references the Local Table Key Field

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.IntermediateTable Property

The Intermediate Table Name

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListBackColor Property

The Check Box List CheckBackColor Properties

[Visual Basic]
Public Property ListBackColor As System.Drawing.Color
[C#]
public System.Drawing.Color ListBackColor {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListBorderColor Property

The List Box CheckBorderColor Properties

[Visual Basic]
Public Property ListBorderColor As System.Drawing.Color
[C#]
public System.Drawing.Color ListBorderColor {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListBorderStyle Property

The List Box CheckBorderStyle Properties

[Visual Basic]
Public Property ListBorderStyle As System.Web.UI.WebControls.BorderStyle
[C#]
public System.Web.UI.WebControls.BorderStyle ListBorderStyle {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListBorderWidth Property

The List Box CheckBorderWidth Properties

[Visual Basic]
Public Property ListBorderWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit ListBorderWidth {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListControlStyle Property

The List Box CheckBorderStyle Properties

[Visual Basic]
Public Property ListControlStyle As System.Web.UI.WebControls.Style
[C#]
public System.Web.UI.WebControls.Style ListControlStyle {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListCssClass Property

The List Box CheckCssClass Properties

[Visual Basic]
Public Property ListCssClass As String
[C#]
public string ListCssClass {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListFont Property

The List Box CheckFont Properties

[Visual Basic]
Public ReadOnly Property ListFont As System.Web.UI.WebControls.FontInfo
[C#]
public System.Web.UI.WebControls.FontInfo ListFont {get;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListForeColor Property

The List Box CheckForeColor Properties

[Visual Basic]
Public Property ListForeColor As System.Drawing.Color
[C#]
public System.Drawing.Color ListForeColor {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListHeight Property

The List Box CheckHeight Properties

[Visual Basic]
Public Property ListHeight As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit ListHeight {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListRows Property

The List Box RepeatColumns Properties

[Visual Basic]
Public Property ListRows As Integer
[C#]
public int ListRows {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListStyle Property

The List Box CheckStyle Properties

[Visual Basic]
Public ReadOnly Property ListStyle As System.Web.UI.CssStyleCollection
[C#]
public System.Web.UI.CssStyleCollection ListStyle {get;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ListWidth Property

The List Box CheckWidth Properties

[Visual Basic]
Public Property ListWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit ListWidth {get; set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.SelectionMode Property

Repeat Direction???

[Visual Basic]
Public Property SelectionMode As System.Web.UI.WebControls.ListSelectionMode
[C#]
public System.Web.UI.WebControls.ListSelectionMode SelectionMode {set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Title Property

String to display to the left of the Checkboxes

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox Methods

The methods of the EditListBox class are listed below. For a complete list of EditListBox class members, see the EditListBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Boxes
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Determines the check boxes which have been checked
MergeStyle (inherited from WebControl) |
Remove | Determines the check boxes which have been unchecked
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditListBox Class | Cambro.Web.QuickAdmin Namespace


EditListBox.Bind Method

Checks the Check Boxes

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String representing the Local Primary Key

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Insert Method

Determines the check boxes which have been checked

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

ArrayList of Strings of the new values to added to the database

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.OnLoad Method

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Remove Method

Determines the check boxes which have been unchecked

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

ArrayList of Strings of the new values be removed from the database

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditListBox.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditListBox Class | EditListBox Members | Cambro.Web.QuickAdmin Namespace


EditNote Class

This control creates a an edit control of type textbox of size cols x rows. This can be used to edit text/varchar/ntext/memo etc fields from your database. This control allows the user to edit the specified field of any record in view mode.

For a list of all members of this type, see EditNote Members.

System.Object
Control
EditNote

[Visual Basic]
Public Class EditNote
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IBindable, ILocal, IResetable, ISetToNull
[C#]
public class EditNote : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IBindable, ILocal, IResetable, ISetToNull

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote Members

Public Instance Constructors

EditNote Constructor Basic control creation and addition

Public Instance Properties

Addable | Should this control appear in Add Mode? Default True
BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Columns | The number of Columns to show
Controls (inherited from System.Web.UI.Control) |
Editable | Is this textbox editable in Edit mode? Default True
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default True
Rows | The number of rows to show
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display above the textbox
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
ViewEditable | Will an update button be displayed so this field can be updated in edit mode? Default False
Visible (inherited from System.Web.UI.Control) |

Public Instance Methods

Bind | Sets the value of the TextBox to the value of 'bound'
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | an event which is never fired
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable, Editable or ViewEditable
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

EditNote Class | Cambro.Web.QuickAdmin Namespace


EditNote Constructor

Basic control creation and addition

[Visual Basic]
Public Sub New()
[C#]
public EditNote();

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote Properties

The properties of the EditNote class are listed below. For a complete list of EditNote class members, see the EditNote Members topic.

Public Instance Properties

Addable | Should this control appear in Add Mode? Default True
BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Columns | The number of Columns to show
Controls (inherited from System.Web.UI.Control) |
Editable | Is this textbox editable in Edit mode? Default True
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default True
Rows | The number of rows to show
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
textValue | Gets and Sets the value of the control
Title | String to display above the textbox
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
ViewEditable | Will an update button be displayed so this field can be updated in edit mode? Default False
Visible (inherited from System.Web.UI.Control) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditNote Class | Cambro.Web.QuickAdmin Namespace


EditNote.Addable Property

Should this control appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Columns Property

The number of Columns to show

[Visual Basic]
Public Property Columns As Integer
[C#]
public int Columns {get; set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Editable Property

Is this textbox editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Quotes Property

Should the value be placed inside quotes in the SQL query? Default True

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Rows Property

The number of rows to show

[Visual Basic]
Public Property Rows As Integer
[C#]
public int Rows {get; set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.SetToNullIfEmpty Property

If this field is empty, set the value to null in the database

[Visual Basic]
NotOverridable Public Property SetToNullIfEmpty As Boolean
[C#]
public bool SetToNullIfEmpty {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Title Property

String to display above the textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.ViewEditable Property

Will an update button be displayed so this field can be updated in edit mode? Default False

[Visual Basic]
Public Property ViewEditable As Boolean
[C#]
public bool ViewEditable {get; set;}

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote Methods

The methods of the EditNote class are listed below. For a complete list of EditNote class members, see the EditNote Members topic.

Public Instance Methods

Bind | Sets the value of the TextBox to the value of 'bound'
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
fff | an event which is never fired
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable, Editable or ViewEditable
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

EditNote Class | Cambro.Web.QuickAdmin Namespace


EditNote.Bind Method

Sets the value of the TextBox to the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String to place in the TextBox

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.fff Method

an event which is never fired

[Visual Basic]
Public Sub fff( _
   ByVal o As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public void fff(
   object o,
   EventArgs e
);

Parameters

o

e

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable, Editable or ViewEditable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditNote.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditNote Class | EditNote Members | Cambro.Web.QuickAdmin Namespace


EditRadioList Class

Control to create an edit control comprised of a Radio Button List propagated from a user specified DataLists Control.

For a list of all members of this type, see EditRadioList Members.

System.Object
Control
WebControl
ListControl
RadioButtonList
EditRadioList

[Visual Basic]
Public Class EditRadioList
   Inherits RadioButtonList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IBindable, ILocal, IResetable, IDataList
[C#]
public class EditRadioList : RadioButtonList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IBindable, ILocal, IResetable, IDataList

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList Members

Public Instance Constructors

EditRadioList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this Radio Button List appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Radio Button List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
Bind | Checks the Radio Button with the value of 'bound'
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnLoad to Create the List of Items
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditRadioList Class | Cambro.Web.QuickAdmin Namespace


EditRadioList Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditRadioList();

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList Properties

The properties of the EditRadioList class are listed below. For a complete list of EditRadioList class members, see the EditRadioList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this Radio Button List appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Radio Button List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditRadioList Class | Cambro.Web.QuickAdmin Namespace


EditRadioList.Addable Property

Should this Radio Button List appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.DataSet Property

String which contains the ID of the Control which specifies the DataList and ValueList for this control

[Visual Basic]
NotOverridable Public Property DataSet As String
[C#]
public string DataSet {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Editable Property

Is this Radio Button List editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList Methods

The methods of the EditRadioList class are listed below. For a complete list of EditRadioList class members, see the EditRadioList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
Bind | Checks the Radio Button with the value of 'bound'
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnLoad to Create the List of Items
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditRadioList Class | Cambro.Web.QuickAdmin Namespace


EditRadioList.Bind Method

Checks the Radio Button with the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal Texts As String _
)
[C#]
public final void Bind(
   string Texts
);

Parameters

Texts

String representing one of the values of the Radio Button List

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.BindDataSet Method

This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control

            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);

[Visual Basic]
NotOverridable Public Sub BindDataSet()
[C#]
public final void BindDataSet();

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.OnLoad Method

Overridden OnLoad to Create the List of Items

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditRadioList.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditRadioList Class | EditRadioList Members | Cambro.Web.QuickAdmin Namespace


EditTextBox Class

Control which creates an edit control of type text box with the text field bound to the LocalField

For a list of all members of this type, see EditTextBox Members.

System.Object
Control
WebControl
TextBox
EditTextBox

[Visual Basic]
Public Class EditTextBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, ISetToNull
[C#]
public class EditTextBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IBindable, ILocal, IResetable, ISetToNull

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox Members

Public Instance Constructors

EditTextBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Is this textbox editable in Edit mode? Default False
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
HtmlEncode | Should the text of this Field be HtmlEncoded so that Html tags appear as text not formatting? Default False
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MaximumChars | If the TextAreaInView is false, how many characters should be displayed to the user of this field. This defaults to unlimited characters i.e. no trimming occurs
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextAreaInView | Should this be a textarea in View mode? Default False
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
textValue | Gets and Sets the Text of the TextBox
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditTextBox Class | Cambro.Web.QuickAdmin Namespace


EditTextBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public EditTextBox();

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox Properties

The properties of the EditTextBox class are listed below. For a complete list of EditTextBox class members, see the EditTextBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Editable | Is this textbox editable in Edit mode? Default False
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
HtmlEncode | Should the text of this Field be HtmlEncoded so that Html tags appear as text not formatting? Default False
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MaximumChars | If the TextAreaInView is false, how many characters should be displayed to the user of this field. This defaults to unlimited characters i.e. no trimming occurs
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
SetToNullIfEmpty | If this field is empty, set the value to null in the database
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextAreaInView | Should this be a textarea in View mode? Default False
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
textValue | Gets and Sets the Text of the TextBox
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditTextBox Class | Cambro.Web.QuickAdmin Namespace


EditTextBox.Addable Property

Should this control appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Editable Property

Is this textbox editable in Edit mode? Default False

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.HtmlEncode Property

Should the text of this Field be HtmlEncoded so that Html tags appear as text not formatting? Default False

[Visual Basic]
Public Property HtmlEncode As Boolean
[C#]
public bool HtmlEncode {get; set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.MaximumChars Property

If the TextAreaInView is false, how many characters should be displayed to the user of this field. This defaults to unlimited characters i.e. no trimming occurs

[Visual Basic]
Public Property MaximumChars As Integer
[C#]
public int MaximumChars {get; set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Quotes Property

Should the value be placed inside quotes in the SQL query? Default True

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.SetToNullIfEmpty Property

If this field is empty, set the value to null in the database

[Visual Basic]
NotOverridable Public Property SetToNullIfEmpty As Boolean
[C#]
public bool SetToNullIfEmpty {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.TextAreaInView Property

Should this be a textarea in View mode? Default False

[Visual Basic]
Public Property TextAreaInView As Boolean
[C#]
public bool TextAreaInView {get; set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.textValue Property

Gets and Sets the Text of the TextBox

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox Methods

The methods of the EditTextBox class are listed below. For a complete list of EditTextBox class members, see the EditTextBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Sets the value of the TextBox to the value of 'bound'
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditTextBox Class | Cambro.Web.QuickAdmin Namespace


EditTextBox.Bind Method

Sets the value of the TextBox to the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal bound As String _
)
[C#]
public final void Bind(
   string bound
);

Parameters

bound

String to place in the TextBox

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTextBox.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditTextBox Class | EditTextBox Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse Class

Control which creates an edit control which is comprised of a True or False Radio Button List. This control enables users to select a true or false value to store in a boolean or bit field.

For a list of all members of this type, see EditTrueFalse Members.

System.Object
Control
WebControl
ListControl
RadioButtonList
EditTrueFalse

[Visual Basic]
Public Class EditTrueFalse
   Inherits RadioButtonList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IBindable, ILocal, IResetable
[C#]
public class EditTrueFalse : RadioButtonList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IBindable, ILocal, IResetable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse Members

Public Instance Constructors

EditTrueFalse Constructor Initiate Items List with True and False values

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Radio Button List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Box with the value of 'bound'
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditTrueFalse Class | Cambro.Web.QuickAdmin Namespace


EditTrueFalse Constructor

Initiate Items List with True and False values

[Visual Basic]
Public Sub New()
[C#]
public EditTrueFalse();

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse Properties

The properties of the EditTrueFalse class are listed below. For a complete list of EditTrueFalse class members, see the EditTrueFalse Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Addable | Should this control appear in Add Mode? Default True
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Editable | Is this Radio Button List editable in Edit mode? Default True
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the value be placed inside quotes in the SQL query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
textValue | Gets and Sets the value of the control
Title | String to display to the left of the Textbox
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
Trim | Should the field be trimmed of leading and following white space? Default False
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

EditTrueFalse Class | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Addable Property

Should this control appear in Add Mode? Default True

[Visual Basic]
NotOverridable Public Property Addable As Boolean
[C#]
public bool Addable {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Editable Property

Is this Radio Button List editable in Edit mode? Default True

[Visual Basic]
NotOverridable Public Property Editable As Boolean
[C#]
public bool Editable {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Quotes Property

Should the value be placed inside quotes in the SQL query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.textValue Property

Gets and Sets the value of the control

[Visual Basic]
NotOverridable Public Property textValue As String
[C#]
public string textValue {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Title Property

String to display to the left of the Textbox

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Trim Property

Should the field be trimmed of leading and following white space? Default False

[Visual Basic]
NotOverridable Public Property Trim As Boolean
[C#]
public bool Trim {final get; final set;}

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse Methods

The methods of the EditTrueFalse class are listed below. For a complete list of EditTrueFalse class members, see the EditTrueFalse Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
Bind | Checks the Check Box with the value of 'bound'
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset Inherited from IResetable
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from ListControl) |
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

EditTrueFalse Class | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Bind Method

Checks the Check Box with the value of 'bound'

[Visual Basic]
NotOverridable Public Sub Bind( _
   ByVal Texts As String _
)
[C#]
public final void Bind(
   string Texts
);

Parameters

Texts

String either 'true' or 'false'

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Render Method

Overridden Render renders controls based on Mode (Edit/View/Add) and whether Addable or Editable

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


EditTrueFalse.Reset Method

Reset Inherited from IResetable

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

EditTrueFalse Class | EditTrueFalse Members | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn Class

Just exactly as Microsoft want it

For a list of all members of this type, see HyperLinkColumn Members.

System.Object
DataGridColumn
HyperLinkColumn
HyperLinkColumn

[Visual Basic]
Public Class HyperLinkColumn
   Inherits HyperLinkColumn
   Implements IStateManager
[C#]
public class HyperLinkColumn : HyperLinkColumn, IStateManager

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

HyperLinkColumn Members | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn Members

Public Instance Constructors

HyperLinkColumn Constructor

Public Instance Properties

DataNavigateUrlField (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataNavigateUrlFormatString (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataTextField (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataTextFieldTable | This should be set to the Table from which the DataTextField is extracted.
DataTextFormatString (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataURLFieldTable | This should be set to the Table from which the DataNavigateUrlField is extracted.
FooterStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
FooterText (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderImageUrl (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderText (inherited from System.Web.UI.WebControls.DataGridColumn) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
NavigateUrl (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
SortExpression (inherited from System.Web.UI.WebControls.DataGridColumn) |
Target (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
Text (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
Visible (inherited from System.Web.UI.WebControls.DataGridColumn) |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
Initialize (inherited from HyperLinkColumn)
InitializeCell (inherited from HyperLinkColumn)
ToString (inherited from DataGridColumn)

Protected Instance Properties

DesignMode (inherited from System.Web.UI.WebControls.DataGridColumn)
IsTrackingViewState (inherited from System.Web.UI.WebControls.DataGridColumn)
Owner (inherited from System.Web.UI.WebControls.DataGridColumn)
ViewState (inherited from System.Web.UI.WebControls.DataGridColumn)

Protected Instance Methods

Finalize (inherited from Object)
FormatDataNavigateUrlValue (inherited from HyperLinkColumn)
FormatDataTextValue (inherited from HyperLinkColumn)
LoadViewState (inherited from DataGridColumn)
MemberwiseClone (inherited from Object)
OnColumnChanged (inherited from DataGridColumn)
SaveViewState (inherited from DataGridColumn)
TrackViewState (inherited from DataGridColumn)

Explicit Interface Implementations

IStateManager.LoadViewState (inherited from DataGridColumn)
IStateManager.SaveViewState (inherited from DataGridColumn)
IStateManager.TrackViewState (inherited from DataGridColumn)

See Also

HyperLinkColumn Class | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn Constructor

[Visual Basic]
Public Sub New()
[C#]
public HyperLinkColumn();

See Also

HyperLinkColumn Class | HyperLinkColumn Members | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn Properties

The properties of the HyperLinkColumn class are listed below. For a complete list of HyperLinkColumn class members, see the HyperLinkColumn Members topic.

Public Instance Properties

DataNavigateUrlField (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataNavigateUrlFormatString (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataTextField (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataTextFieldTable | This should be set to the Table from which the DataTextField is extracted.
DataTextFormatString (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
DataURLFieldTable | This should be set to the Table from which the DataNavigateUrlField is extracted.
FooterStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
FooterText (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderImageUrl (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderText (inherited from System.Web.UI.WebControls.DataGridColumn) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
NavigateUrl (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
SortExpression (inherited from System.Web.UI.WebControls.DataGridColumn) |
Target (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
Text (inherited from System.Web.UI.WebControls.HyperLinkColumn) |
Visible (inherited from System.Web.UI.WebControls.DataGridColumn) |

Protected Instance Properties

DesignMode (inherited from System.Web.UI.WebControls.DataGridColumn)
IsTrackingViewState (inherited from System.Web.UI.WebControls.DataGridColumn)
Owner (inherited from System.Web.UI.WebControls.DataGridColumn)
ViewState (inherited from System.Web.UI.WebControls.DataGridColumn)

See Also

HyperLinkColumn Class | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn.DataTextFieldTable Property

This should be set to the Table from which the DataTextField is extracted.

[Visual Basic]
Public Property DataTextFieldTable As String
[C#]
public string DataTextFieldTable {get; set;}

See Also

HyperLinkColumn Class | HyperLinkColumn Members | Cambro.Web.QuickAdmin Namespace


HyperLinkColumn.DataURLFieldTable Property

This should be set to the Table from which the DataNavigateUrlField is extracted.

[Visual Basic]
Public Property DataURLFieldTable As String
[C#]
public string DataURLFieldTable {get; set;}

See Also

HyperLinkColumn Class | HyperLinkColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn Class

Control which inherits from BoundColumn

For a list of all members of this type, see ResultsColumn Members.

System.Object
DataGridColumn
BoundColumn
ResultsColumn

[Visual Basic]
Public Class ResultsColumn
   Inherits BoundColumn
   Implements IStateManager
[C#]
public class ResultsColumn : BoundColumn, IStateManager

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn Members

Public Instance Constructors

ResultsColumn Constructor

Public Instance Properties

DataField (inherited from System.Web.UI.WebControls.BoundColumn) |
DataFormatString (inherited from System.Web.UI.WebControls.BoundColumn) |
DataSet | String containing the ID of the Control which contains the DataList and ValueList for this control
FooterStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
FooterText (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderImageUrl (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderText (inherited from System.Web.UI.WebControls.DataGridColumn) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
Link | Boolean to specify whether or not a link will appear on this Column Value, enabling the user to click through to View Mode. Default False
ReadOnly (inherited from System.Web.UI.WebControls.BoundColumn) |
SortExpression (inherited from System.Web.UI.WebControls.DataGridColumn) |
Table | Just in case the DataField Occurs in two tables, this enables you to specify the table to choose.
TextOrMemo | Boolean to determine whether the field referenced by this ResultsColumn is a Text or Memo Field. Default False
ToolTip | Tool Tip to display when the mouse is over the link
Visible (inherited from System.Web.UI.WebControls.DataGridColumn) |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
Initialize (inherited from BoundColumn)
InitializeCell (inherited from BoundColumn)
ToString (inherited from DataGridColumn)

Protected Instance Properties

DesignMode (inherited from System.Web.UI.WebControls.DataGridColumn)
IsTrackingViewState (inherited from System.Web.UI.WebControls.DataGridColumn)
Owner (inherited from System.Web.UI.WebControls.DataGridColumn)
ViewState (inherited from System.Web.UI.WebControls.DataGridColumn)

Protected Instance Methods

Finalize (inherited from Object)
FormatDataValue (inherited from BoundColumn)
LoadViewState (inherited from DataGridColumn)
MemberwiseClone (inherited from Object)
OnColumnChanged (inherited from DataGridColumn)
SaveViewState (inherited from DataGridColumn)
TrackViewState (inherited from DataGridColumn)

Explicit Interface Implementations

IStateManager.LoadViewState (inherited from DataGridColumn)
IStateManager.SaveViewState (inherited from DataGridColumn)
IStateManager.TrackViewState (inherited from DataGridColumn)

See Also

ResultsColumn Class | Cambro.Web.QuickAdmin Namespace


ResultsColumn Constructor

[Visual Basic]
Public Sub New()
[C#]
public ResultsColumn();

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn Properties

The properties of the ResultsColumn class are listed below. For a complete list of ResultsColumn class members, see the ResultsColumn Members topic.

Public Instance Properties

DataField (inherited from System.Web.UI.WebControls.BoundColumn) |
DataFormatString (inherited from System.Web.UI.WebControls.BoundColumn) |
DataSet | String containing the ID of the Control which contains the DataList and ValueList for this control
FooterStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
FooterText (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderImageUrl (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
HeaderText (inherited from System.Web.UI.WebControls.DataGridColumn) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGridColumn) |
Link | Boolean to specify whether or not a link will appear on this Column Value, enabling the user to click through to View Mode. Default False
ReadOnly (inherited from System.Web.UI.WebControls.BoundColumn) |
SortExpression (inherited from System.Web.UI.WebControls.DataGridColumn) |
Table | Just in case the DataField Occurs in two tables, this enables you to specify the table to choose.
TextOrMemo | Boolean to determine whether the field referenced by this ResultsColumn is a Text or Memo Field. Default False
ToolTip | Tool Tip to display when the mouse is over the link
Visible (inherited from System.Web.UI.WebControls.DataGridColumn) |

Protected Instance Properties

DesignMode (inherited from System.Web.UI.WebControls.DataGridColumn)
IsTrackingViewState (inherited from System.Web.UI.WebControls.DataGridColumn)
Owner (inherited from System.Web.UI.WebControls.DataGridColumn)
ViewState (inherited from System.Web.UI.WebControls.DataGridColumn)

See Also

ResultsColumn Class | Cambro.Web.QuickAdmin Namespace


ResultsColumn.DataSet Property

String containing the ID of the Control which contains the DataList and ValueList for this control

[Visual Basic]
Public Property DataSet As String
[C#]
public string DataSet {get; set;}

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn.Link Property

Boolean to specify whether or not a link will appear on this Column Value, enabling the user to click through to View Mode. Default False

[Visual Basic]
Public Property Link As Boolean
[C#]
public bool Link {get; set;}

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn.Table Property

Just in case the DataField Occurs in two tables, this enables you to specify the table to choose.

[Visual Basic]
Public Property Table As String
[C#]
public string Table {get; set;}

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn.TextOrMemo Property

Boolean to determine whether the field referenced by this ResultsColumn is a Text or Memo Field. Default False

[Visual Basic]
Public Property TextOrMemo As Boolean
[C#]
public bool TextOrMemo {get; set;}

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsColumn.ToolTip Property

Tool Tip to display when the mouse is over the link

[Visual Basic]
Public Property ToolTip As String
[C#]
public string ToolTip {get; set;}

See Also

ResultsColumn Class | ResultsColumn Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Class

Customised DataGrid which enables Paging and Sorting based on the search type, and adds a Rank Field if necessary

For a list of all members of this type, see ResultsDataGrid Members.

System.Object
Control
WebControl
BaseDataList
DataGrid
ResultsDataGrid

[Visual Basic]
Public Class ResultsDataGrid
   Inherits DataGrid
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, INamingContainer
[C#]
public class ResultsDataGrid : DataGrid, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, INamingContainer

Remarks

This specialised DataGrid is designed specifically for QuickAdmin. This ResultsDataGrid can be configured using the HTML view, the code behind or in the OnSearching and OnSearched Events. Using ResultsColumns, it is possible to creating columns which enable the user to click through to the View Page, and using TemplateColumns with links which have URLs including the ID of the record required to display. The ResultsDataGrid lets the user Page and Sort (if they have been set to true) in Exact Matching mode and Page in Fuzzy Matching Mode.

Example

Here is some code of the ResultsDataGrid in the OrderDetails.aspx page. You can see that a couple of links have been inserted to enable a specific order or product to be edited.

            <QuickAdmin:ResultsDataGrid runat=server Width=100% DataKeyField="OrderID" DataField2="ProductID" ID="ResultsDataGrid1" AllowPaging=True AllowSorting=True >
                <Columns>
                    <QuickAdmin:ResultsColumn DataField=OrderID HeaderText="Order ID" SortExpression="OrderID" Table="Order Details" />
                    <QuickAdmin:ResultsColumn DataField=ProductName HeaderText=Product SortExpression=ProductName Link=True ToolTip="Click here to edit the price, quantity or discount of this product in the order" />
                    <QuickAdmin:ResultsColumn DataField=Quantity HeaderText=Quantity SortExpression=Quantity />
                    <QuickAdmin:TemplateColumn>
                        <ItemTemplate>
                            <a href="Orders.aspx?ID=<%#DataBinder.Eval(Container.DataItem,"OrderID")%>"" title=""Click here to edit this order" >Edit Order</a>
                        </ItemTemplate>
                    </QuickAdmin:TemplateColumn>
                    <QuickAdmin:TemplateColumn>
                        <ItemTemplate>
                            <a href="Products.aspx?ID=<%#DataBinder.Eval(Container.DataItem,"ProductID")%>" title="Click here to edit this product" >Edit Product</a>
                        </ItemTemplate>
                    </QuickAdmin:TemplateColumn>
                </Columns>
            </QuickAdmin:ResultsDataGrid>

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Members

Public Instance Constructors

ResultsDataGrid Constructor Function which Initiates the DataGrid and Adds EventHandlers

Public Instance Fields

ParentResults The Control Container of the Results Data Grid

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
AllowCustomPaging (inherited from System.Web.UI.WebControls.DataGrid) |
AllowPaging (inherited from System.Web.UI.WebControls.DataGrid) |
AllowSorting (inherited from System.Web.UI.WebControls.DataGrid) |
AlternatingItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoGenerateColumns (inherited from System.Web.UI.WebControls.DataGrid) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BackImageUrl (inherited from System.Web.UI.WebControls.DataGrid) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.BaseDataList) |
CellSpacing (inherited from System.Web.UI.WebControls.BaseDataList) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.DataGrid) |
Controls (inherited from System.Web.UI.WebControls.BaseDataList) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
CurrentPageIndex (inherited from System.Web.UI.WebControls.DataGrid) |
DataKeyField (inherited from System.Web.UI.WebControls.BaseDataList) |
DataKeyField2 | Should be set to the Field which makes up Second Half of the Joint Primary Key when there is a Joint Key, otherwise left as an empty string.
DataKeys (inherited from System.Web.UI.WebControls.BaseDataList) |
DataMember (inherited from System.Web.UI.WebControls.BaseDataList) |
DataSource (inherited from System.Web.UI.WebControls.BaseDataList) |
EditItemIndex (inherited from System.Web.UI.WebControls.DataGrid) |
EditItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
FooterStyle (inherited from System.Web.UI.WebControls.DataGrid) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
GridLines (inherited from System.Web.UI.WebControls.BaseDataList) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
HorizontalAlign (inherited from System.Web.UI.WebControls.BaseDataList) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.DataGrid) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
PageCount (inherited from System.Web.UI.WebControls.DataGrid) |
PagerStyle (inherited from System.Web.UI.WebControls.DataGrid) |
PageSize (inherited from System.Web.UI.WebControls.DataGrid) |
Parent (inherited from System.Web.UI.Control) |
SelectedIndex (inherited from System.Web.UI.WebControls.DataGrid) |
SelectedItem (inherited from System.Web.UI.WebControls.DataGrid) |
SelectedItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
ShowFooter (inherited from System.Web.UI.WebControls.DataGrid) |
ShowHeader (inherited from System.Web.UI.WebControls.DataGrid) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
VirtualItemCount (inherited from System.Web.UI.WebControls.DataGrid) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from BaseDataList) |
Dispose (inherited from Control) |
DoPage | Function to Page the ResultsControl
DoSort | Function to Sort the DataGrid
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
Refresh | Useful function to call if the contents of the ResultsDataGrid have changed for some reason. This re-searches using the same search criteria and rebinds to the ResultsDataGrid.
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
DataKeysArray (inherited from System.Web.UI.WebControls.BaseDataList)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from BaseDataList) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from BaseDataList) |
CreateColumnSet (inherited from DataGrid) |
CreateControlCollection (inherited from Control) |
CreateControlHierarchy (inherited from DataGrid) |
CreateControlStyle (inherited from DataGrid) |
CreateItem (inherited from DataGrid) |
DoSearch | Function which Calls the search function on the SearchControl Control
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
InitializeItem (inherited from DataGrid) |
InitializePager (inherited from DataGrid) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from DataGrid) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from DataGrid) |
OnCancelCommand (inherited from DataGrid) |
OnDataBinding | Overridden OnDataBinding, enabling the ResultsDataGrid to handle multiple fields with identical names
OnDeleteCommand (inherited from DataGrid) |
OnEditCommand (inherited from DataGrid) |
OnInit | Create the Rank and Secondary ID Rows
OnItemCommand (inherited from DataGrid) |
OnItemCreated (inherited from DataGrid) |
OnItemDataBound (inherited from DataGrid) |
OnLoad | Decide whether to hide, reassign or make visible the added rows
OnPageIndexChanged (inherited from DataGrid) |
OnPreRender | Overridden OnInit Inserts a Rank Field if necessary
OnSelectedIndexChanged (inherited from BaseDataList) |
OnSortCommand (inherited from DataGrid) |
OnUnload (inherited from Control) |
OnUpdateCommand (inherited from DataGrid) |
PrepareControlHierarchy (inherited from DataGrid) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render, renders the ResultsDataGrid in a table row so it is combined with the QuickAdmin Table correctly.
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from DataGrid) |
TrackViewState (inherited from DataGrid) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

ResultsDataGrid Class | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Constructor

Function which Initiates the DataGrid and Adds EventHandlers

[Visual Basic]
Public Sub New()
[C#]
public ResultsDataGrid();

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Fields

The fields of the ResultsDataGrid class are listed below. For a complete list of ResultsDataGrid class members, see the ResultsDataGrid Members topic.

Public Instance Fields

ParentResults The Control Container of the Results Data Grid

See Also

ResultsDataGrid Class | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.ParentResults Field

The Control Container of the Results Data Grid

[Visual Basic]
Public ParentResults As Cambro.Web.QuickAdmin.ResultsControl
[C#]
public ResultsControl ParentResults;

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Properties

The properties of the ResultsDataGrid class are listed below. For a complete list of ResultsDataGrid class members, see the ResultsDataGrid Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
AllowCustomPaging (inherited from System.Web.UI.WebControls.DataGrid) |
AllowPaging (inherited from System.Web.UI.WebControls.DataGrid) |
AllowSorting (inherited from System.Web.UI.WebControls.DataGrid) |
AlternatingItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoGenerateColumns (inherited from System.Web.UI.WebControls.DataGrid) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BackImageUrl (inherited from System.Web.UI.WebControls.DataGrid) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.BaseDataList) |
CellSpacing (inherited from System.Web.UI.WebControls.BaseDataList) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.DataGrid) |
Controls (inherited from System.Web.UI.WebControls.BaseDataList) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
CurrentPageIndex (inherited from System.Web.UI.WebControls.DataGrid) |
DataKeyField (inherited from System.Web.UI.WebControls.BaseDataList) |
DataKeyField2 | Should be set to the Field which makes up Second Half of the Joint Primary Key when there is a Joint Key, otherwise left as an empty string.
DataKeys (inherited from System.Web.UI.WebControls.BaseDataList) |
DataMember (inherited from System.Web.UI.WebControls.BaseDataList) |
DataSource (inherited from System.Web.UI.WebControls.BaseDataList) |
EditItemIndex (inherited from System.Web.UI.WebControls.DataGrid) |
EditItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
FooterStyle (inherited from System.Web.UI.WebControls.DataGrid) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
GridLines (inherited from System.Web.UI.WebControls.BaseDataList) |
HeaderStyle (inherited from System.Web.UI.WebControls.DataGrid) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
HorizontalAlign (inherited from System.Web.UI.WebControls.BaseDataList) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.DataGrid) |
ItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
PageCount (inherited from System.Web.UI.WebControls.DataGrid) |
PagerStyle (inherited from System.Web.UI.WebControls.DataGrid) |
PageSize (inherited from System.Web.UI.WebControls.DataGrid) |
Parent (inherited from System.Web.UI.Control) |
SelectedIndex (inherited from System.Web.UI.WebControls.DataGrid) |
SelectedItem (inherited from System.Web.UI.WebControls.DataGrid) |
SelectedItemStyle (inherited from System.Web.UI.WebControls.DataGrid) |
ShowFooter (inherited from System.Web.UI.WebControls.DataGrid) |
ShowHeader (inherited from System.Web.UI.WebControls.DataGrid) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
VirtualItemCount (inherited from System.Web.UI.WebControls.DataGrid) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
DataKeysArray (inherited from System.Web.UI.WebControls.BaseDataList)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

ResultsDataGrid Class | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.DataKeyField2 Property

Should be set to the Field which makes up Second Half of the Joint Primary Key when there is a Joint Key, otherwise left as an empty string.

[Visual Basic]
Public Property DataKeyField2 As String
[C#]
public string DataKeyField2 {get; set;}

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid Methods

The methods of the ResultsDataGrid class are listed below. For a complete list of ResultsDataGrid class members, see the ResultsDataGrid Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from BaseDataList) |
Dispose (inherited from Control) |
DoPage | Function to Page the ResultsControl
DoSort | Function to Sort the DataGrid
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MergeStyle (inherited from WebControl) |
Refresh | Useful function to call if the contents of the ResultsDataGrid have changed for some reason. This re-searches using the same search criteria and rebinds to the ResultsDataGrid.
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from BaseDataList) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from BaseDataList) |
CreateColumnSet (inherited from DataGrid) |
CreateControlCollection (inherited from Control) |
CreateControlHierarchy (inherited from DataGrid) |
CreateControlStyle (inherited from DataGrid) |
CreateItem (inherited from DataGrid) |
DoSearch | Function which Calls the search function on the SearchControl Control
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
InitializeItem (inherited from DataGrid) |
InitializePager (inherited from DataGrid) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from DataGrid) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from DataGrid) |
OnCancelCommand (inherited from DataGrid) |
OnDataBinding | Overridden OnDataBinding, enabling the ResultsDataGrid to handle multiple fields with identical names
OnDeleteCommand (inherited from DataGrid) |
OnEditCommand (inherited from DataGrid) |
OnInit | Create the Rank and Secondary ID Rows
OnItemCommand (inherited from DataGrid) |
OnItemCreated (inherited from DataGrid) |
OnItemDataBound (inherited from DataGrid) |
OnLoad | Decide whether to hide, reassign or make visible the added rows
OnPageIndexChanged (inherited from DataGrid) |
OnPreRender | Overridden OnInit Inserts a Rank Field if necessary
OnSelectedIndexChanged (inherited from BaseDataList) |
OnSortCommand (inherited from DataGrid) |
OnUnload (inherited from Control) |
OnUpdateCommand (inherited from DataGrid) |
PrepareControlHierarchy (inherited from DataGrid) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render, renders the ResultsDataGrid in a table row so it is combined with the QuickAdmin Table correctly.
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from DataGrid) |
TrackViewState (inherited from DataGrid) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

ResultsDataGrid Class | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.DoPage Method

Function to Page the ResultsControl

[Visual Basic]
Public Sub DoPage( _
   ByVal o As Object, _
   ByVal f As System.Web.UI.WebControls.DataGridPageChangedEventArgs _
)
[C#]
public void DoPage(
   object o,
   DataGridPageChangedEventArgs f
);

Parameters

o

Object o (Irrelevant)

f

DataGridPageChangedEventArgs f from which the NewPageIndex is extracted

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.DoSearch Method

Function which Calls the search function on the SearchControl Control

[Visual Basic]
Protected Sub DoSearch()
[C#]
protected void DoSearch();

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.DoSort Method

Function to Sort the DataGrid

[Visual Basic]
Public Sub DoSort( _
   ByVal b As Object, _
   ByVal e As System.Web.UI.WebControls.DataGridSortCommandEventArgs _
)
[C#]
public void DoSort(
   object b,
   DataGridSortCommandEventArgs e
);

Parameters

b

Object (Irrelevant)

e

DataGridSortCommandEventArgs e from which the SortExpression is extracted

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.OnDataBinding Method

Overridden OnDataBinding, enabling the ResultsDataGrid to handle multiple fields with identical names

[Visual Basic]
Overrides Protected Sub OnDataBinding( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnDataBinding(
   EventArgs e
);

Parameters

e

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.OnInit Method

Create the Rank and Secondary ID Rows

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.OnLoad Method

Decide whether to hide, reassign or make visible the added rows

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.OnPreRender Method

Overridden OnInit Inserts a Rank Field if necessary

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.Refresh Method

Useful function to call if the contents of the ResultsDataGrid have changed for some reason. This re-searches using the same search criteria and rebinds to the ResultsDataGrid.

[Visual Basic]
Public Sub Refresh()
[C#]
public void Refresh();

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


ResultsDataGrid.Render Method

Overridden Render, renders the ResultsDataGrid in a table row so it is combined with the QuickAdmin Table correctly.

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

ResultsDataGrid Class | ResultsDataGrid Members | Cambro.Web.QuickAdmin Namespace


TemplateColumn Class

Just exactly as Microsoft want it

For a list of all members of this type, see TemplateColumn Members.

System.Object
DataGridColumn
TemplateColumn
TemplateColumn

[Visual Basic]
Public Class TemplateColumn
   Inherits TemplateColumn
   Implements IStateManager
[C#]
public class TemplateColumn : TemplateColumn, IStateManager

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

TemplateColumn Members | Cambro.Web.QuickAdmin Namespace


TemplateColumn Members

Public Instance Constructors

TemplateColumn Constructor

Public Instance Properties

EditItemTemplate (inherited from System.Web.UI.WebControls.TemplateColumn)
FooterStyle (inherited from System.Web.UI.WebControls.DataGridColumn)
FooterTemplate (inherited from System.Web.UI.WebControls.TemplateColumn)
FooterText (inherited from System.Web.UI.WebControls.DataGridColumn)
HeaderImageUrl (inherited from System.Web.UI.WebControls.DataGridColumn)
HeaderStyle (inherited from System.Web.UI.WebControls.DataGridColumn)
HeaderTemplate (inherited from System.Web.UI.WebControls.TemplateColumn)
HeaderText (inherited from System.Web.UI.WebControls.DataGridColumn)
ItemStyle (inherited from System.Web.UI.WebControls.DataGridColumn)
ItemTemplate (inherited from System.Web.UI.WebControls.TemplateColumn)
SortExpression (inherited from System.Web.UI.WebControls.DataGridColumn)
Visible (inherited from System.Web.UI.WebControls.DataGridColumn)

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
Initialize (inherited from DataGridColumn)
InitializeCell (inherited from TemplateColumn)
ToString (inherited from DataGridColumn)

Protected Instance Properties

DesignMode (inherited from System.Web.UI.WebControls.DataGridColumn)
IsTrackingViewState (inherited from System.Web.UI.WebControls.DataGridColumn)
Owner (inherited from System.Web.UI.WebControls.DataGridColumn)
ViewState (inherited from System.Web.UI.WebControls.DataGridColumn)

Protected Instance Methods

Finalize (inherited from Object)
LoadViewState (inherited from DataGridColumn)
MemberwiseClone (inherited from Object)
OnColumnChanged (inherited from DataGridColumn)
SaveViewState (inherited from DataGridColumn)
TrackViewState (inherited from DataGridColumn)

Explicit Interface Implementations

IStateManager.LoadViewState (inherited from DataGridColumn)
IStateManager.SaveViewState (inherited from DataGridColumn)
IStateManager.TrackViewState (inherited from DataGridColumn)

See Also

TemplateColumn Class | Cambro.Web.QuickAdmin Namespace


TemplateColumn Constructor

[Visual Basic]
Public Sub New()
[C#]
public TemplateColumn();

See Also

TemplateColumn Class | TemplateColumn Members | Cambro.Web.QuickAdmin Namespace


Local Class

Class which creates a Control which searches textual data from the LocalField of the Local Table. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.

For a list of all members of this type, see Local Members.

System.Object
Control
Local

[Visual Basic]
Public Class Local
   Inherits Control
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, ILocal, ISearchable
[C#]
public class Local : Control, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Local Members | Cambro.Web.QuickAdmin Namespace


Local Members

Public Instance Constructors

Local Constructor

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Local Class | Cambro.Web.QuickAdmin Namespace


Local Constructor

[Visual Basic]
Public Sub New()
[C#]
public Local();

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local Properties

The properties of the Local class are listed below. For a complete list of Local class members, see the Local Members topic.

Public Instance Properties

BindingContainer (inherited from System.Web.UI.Control) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
EnableViewState (inherited from System.Web.UI.Control) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Local Class | Cambro.Web.QuickAdmin Namespace


Local.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local Methods

The methods of the Local class are listed below. For a complete list of Local class members, see the Local Members topic.

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Control) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState (inherited from Control) |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

Local Class | Cambro.Web.QuickAdmin Namespace


Local.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Local.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Local Class | Local Members | Cambro.Web.QuickAdmin Namespace


Many2Many Class

Control which searches textual data from a Table linked by a Many to Many relationship to the Local Table. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.

For a list of all members of this type, see Many2Many Members.

System.Object
Control
WebControl
Many2Many

[Visual Basic]
Public Class Many2Many
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IMany2Many, IOne2Many, ILocal, ISearchable
[C#]
public class Many2Many : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IMany2Many, IOne2Many, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many Members

Public Instance Constructors

Many2Many Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from WebControl) |
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2Many Class | Cambro.Web.QuickAdmin Namespace


Many2Many Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2Many();

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many Properties

The properties of the Many2Many class are listed below. For a complete list of Many2Many class members, see the Many2Many Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2Many Class | Cambro.Web.QuickAdmin Namespace


Many2Many.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many Methods

The methods of the Many2Many class are listed below. For a complete list of Many2Many class members, see the Many2Many Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from WebControl) |
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2Many Class | Cambro.Web.QuickAdmin Namespace


Many2Many.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


Many2Many.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2Many Class | Many2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many Class

Control which searches a linked table field for textual data when the link is defined by a One to Many relationship. Matches on combinations of the text, returning any matches in Exact search mode and a score for each match in Fuzzy search mode.

For a list of all members of this type, see One2Many Members.

System.Object
Control
WebControl
One2Many

[Visual Basic]
Public Class One2Many
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IOne2Many, ILocal, ISearchable
[C#]
public class One2Many : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IOne2Many, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many Members

Public Instance Constructors

One2Many Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from WebControl) |
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2Many Class | Cambro.Web.QuickAdmin Namespace


One2Many Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2Many();

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many Properties

The properties of the One2Many class are listed below. For a complete list of One2Many class members, see the One2Many Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2Many Class | Cambro.Web.QuickAdmin Namespace


One2Many.ForeignDataField Property

One2Many Data Field is the Field to display to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many Methods

The methods of the One2Many class are listed below. For a complete list of One2Many class members, see the One2Many Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from WebControl) |
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2Many Class | Cambro.Web.QuickAdmin Namespace


One2Many.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


One2Many.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2Many Class | One2Many Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate Class

Creates a Search control with the ability to select a day, week or month. To select a day, just click the correct day, to select a week click the button to the left of the first day of the week and to select the month, click on the button in the top right. This enables the user to select a range of days and search on the LocalField for a date between those two days. If no selection is made the no filtering by this date is done, if any selection is made then all the records which have a Date in the LocalField which is between the date(s) specified will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalBetweenDate Members.

System.Object
Control
WebControl
Calendar
LocalBetweenDate

[Visual Basic]
Public Class LocalBetweenDate
   Inherits Calendar
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, ILocal, IResetable, ISearchable
[C#]
public class LocalBetweenDate : Calendar, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, ILocal, IResetable, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate Members

Public Instance Constructors

LocalBetweenDate Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenDate Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalBetweenDate();

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate Properties

The properties of the LocalBetweenDate class are listed below. For a complete list of LocalBetweenDate class members, see the LocalBetweenDate Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalBetweenDate Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.StartDate Property

The date to be appear on the Calendar Control if no date is selected

[Visual Basic]
Public Property StartDate As String
[C#]
public string StartDate {get; set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate Methods

The methods of the LocalBetweenDate class are listed below. For a complete list of LocalBetweenDate class members, see the LocalBetweenDate Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenDate Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDate.Reset Method

Reset implemented by IResetable resets the Control

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalBetweenDate Class | LocalBetweenDate Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice Class

Creates a Search control with the ability to select a range of dates using two Calendar controls. In the event that no selection is made, the records are not filtered by the Date. In the event that the 'Start Date' Calendar control only is clicked, then all records in which the date is on or after the selected date will be returned. Likewise, only selecting the 'End Date' Calendar control will search the LocalField for dates which dates which occur previous to the selected date. In the event that both calendar controls have dates specified, then records will only be returned if the LocalField value occurs between both. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalBetweenDateTwice Members.

System.Object
Control
WebControl
LocalBetweenDateTwice

[Visual Basic]
Public Class LocalBetweenDateTwice
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, ILocal, IResetable, ISearchable
[C#]
public class LocalBetweenDateTwice : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, ILocal, IResetable, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice Members

Public Instance Constructors

LocalBetweenDateTwice Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CalOneDayHeaderStyle | The First Calendar CalOneDayHeaderStyle Style
CalOneDayNameFormat | The First Calendar CalOneDayNameFormat Property
CalOneDayStyle | The First Calendar CalOneDayHeaderStyle Style
CalOneFirstDayOfWeek | The First Calendar CalOneFirstDayOfWeek Property
CalOneNextMonthText | The First Calendar CalOneNextMonthText Property
CalOneNextPrevFormat | The First Calendar CalOneNextPrevFormat Property
CalOneNextPrevStyle | The First Calendar CalOneNextPrevStyle Style
CalOneOtherMonthDayStyle | The First Calendar CalOneOtherMonthDayStyle Style
CalOnePrevMonthText | The First Calendar CalOnePrevMonthText Property
CalOneSelectedDayStyle | The First Calendar CalOneSelectedDayStyle Style
CalOneSelectMonthText | The First Calendar CalOneSelectMonthText Property
CalOneSelectorStyle | The First Calendar CalOneSelectorStyle Style
CalOneSelectWeekText | The First Calendar CalOneSelectWeekText Property
CalOneShowDayHeader | The First Calendar CalOneShowDayHeader Property
CalOneShowGridLines | The First Calendar CalOneShowGridLines Property
CalOneShowNextPrevMonth | The First Calendar CalOneShowNextPrevMonth Property
CalOneShowTitle | The First Calendar CalOneShowTitle Property
CalOneTitleFormat | The First Calendar CalOneTitleFormat Property
CalOneTitleStyle | The First Calendar CalOneTitleStyle Style
CalOneTodayDayStyle | The First Calendar CalOneTodayDayStyle Style
CalOneWeekendDayStyle | The First Calendar CalOneWeekendDayStyle Style
CalTwoDayHeaderStyle | The Second Calendar CalTwoDayHeaderStyle Style
CalTwoDayNameFormat | The Second Calendar CalTwoDayNameFormat Property
CalTwoDayStyle | The Second Calendar CalTwoDayStyle Style
CalTwoFirstDayOfWeek | The Second Calendar CalTwoFirstDayOfWeek Property
CalTwoNextMonthText | The Second Calendar CalTwoNextMonthText Property
CalTwoNextPrevFormat | The Second Calendar CalTwoNextPrevFormat Property
CalTwoNextPrevStyle | The Second Calendar CalTwoNextPrevStyle Style
CalTwoOtherMonthDayStyle | The Second Calendar CalTwoOtherMonthDayStyle Style
CalTwoPrevMonthText | The Second Calendar CalTwoPrevMonthText Property
CalTwoSelectedDayStyle | The Second Calendar CalTwoSelectedDayStyle Style
CalTwoSelectMonthText | The Second Calendar CalTwoSelectMonthText Property
CalTwoSelectorStyle | The Second Calendar CalTwoSelectorStyle Style
CalTwoSelectWeekText | The Second Calendar CalTwoSelectWeekText Property
CalTwoShowDayHeader | The Second Calendar CalTwoShowDayHeader Property
CalTwoShowGridLines | The Second Calendar CalTwoShowGridLines Property
CalTwoShowNextPrevMonth | The Second Calendar CalTwoShowNextPrevMonth Property
CalTwoShowTitle | The Second Calendar CalTwoShowTitle Property
CalTwoTitleFormat | The Second Calendar CalTwoTitleFormat Property
CalTwoTitleStyle | The Second Calendar CalTwoTitleStyle Style
CalTwoTodayDayStyle | The Second Calendar CalTwoTodayDayStyle Style
CalTwoWeekendDayStyle | The Second Calendar CalTwoWeekendDayStyle Style
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
EndDate | The date to be appear on the End Calendar Control if no date is selected
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Start Calendar if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenDateTwice Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalBetweenDateTwice();

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice Properties

The properties of the LocalBetweenDateTwice class are listed below. For a complete list of LocalBetweenDateTwice class members, see the LocalBetweenDateTwice Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CalOneDayHeaderStyle | The First Calendar CalOneDayHeaderStyle Style
CalOneDayNameFormat | The First Calendar CalOneDayNameFormat Property
CalOneDayStyle | The First Calendar CalOneDayHeaderStyle Style
CalOneFirstDayOfWeek | The First Calendar CalOneFirstDayOfWeek Property
CalOneNextMonthText | The First Calendar CalOneNextMonthText Property
CalOneNextPrevFormat | The First Calendar CalOneNextPrevFormat Property
CalOneNextPrevStyle | The First Calendar CalOneNextPrevStyle Style
CalOneOtherMonthDayStyle | The First Calendar CalOneOtherMonthDayStyle Style
CalOnePrevMonthText | The First Calendar CalOnePrevMonthText Property
CalOneSelectedDayStyle | The First Calendar CalOneSelectedDayStyle Style
CalOneSelectMonthText | The First Calendar CalOneSelectMonthText Property
CalOneSelectorStyle | The First Calendar CalOneSelectorStyle Style
CalOneSelectWeekText | The First Calendar CalOneSelectWeekText Property
CalOneShowDayHeader | The First Calendar CalOneShowDayHeader Property
CalOneShowGridLines | The First Calendar CalOneShowGridLines Property
CalOneShowNextPrevMonth | The First Calendar CalOneShowNextPrevMonth Property
CalOneShowTitle | The First Calendar CalOneShowTitle Property
CalOneTitleFormat | The First Calendar CalOneTitleFormat Property
CalOneTitleStyle | The First Calendar CalOneTitleStyle Style
CalOneTodayDayStyle | The First Calendar CalOneTodayDayStyle Style
CalOneWeekendDayStyle | The First Calendar CalOneWeekendDayStyle Style
CalTwoDayHeaderStyle | The Second Calendar CalTwoDayHeaderStyle Style
CalTwoDayNameFormat | The Second Calendar CalTwoDayNameFormat Property
CalTwoDayStyle | The Second Calendar CalTwoDayStyle Style
CalTwoFirstDayOfWeek | The Second Calendar CalTwoFirstDayOfWeek Property
CalTwoNextMonthText | The Second Calendar CalTwoNextMonthText Property
CalTwoNextPrevFormat | The Second Calendar CalTwoNextPrevFormat Property
CalTwoNextPrevStyle | The Second Calendar CalTwoNextPrevStyle Style
CalTwoOtherMonthDayStyle | The Second Calendar CalTwoOtherMonthDayStyle Style
CalTwoPrevMonthText | The Second Calendar CalTwoPrevMonthText Property
CalTwoSelectedDayStyle | The Second Calendar CalTwoSelectedDayStyle Style
CalTwoSelectMonthText | The Second Calendar CalTwoSelectMonthText Property
CalTwoSelectorStyle | The Second Calendar CalTwoSelectorStyle Style
CalTwoSelectWeekText | The Second Calendar CalTwoSelectWeekText Property
CalTwoShowDayHeader | The Second Calendar CalTwoShowDayHeader Property
CalTwoShowGridLines | The Second Calendar CalTwoShowGridLines Property
CalTwoShowNextPrevMonth | The Second Calendar CalTwoShowNextPrevMonth Property
CalTwoShowTitle | The Second Calendar CalTwoShowTitle Property
CalTwoTitleFormat | The Second Calendar CalTwoTitleFormat Property
CalTwoTitleStyle | The Second Calendar CalTwoTitleStyle Style
CalTwoTodayDayStyle | The Second Calendar CalTwoTodayDayStyle Style
CalTwoWeekendDayStyle | The Second Calendar CalTwoWeekendDayStyle Style
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
EndDate | The date to be appear on the End Calendar Control if no date is selected
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Start Calendar if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalBetweenDateTwice Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneDayHeaderStyle Property

The First Calendar CalOneDayHeaderStyle Style

[Visual Basic]
Public Property CalOneDayHeaderStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneDayHeaderStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneDayNameFormat Property

The First Calendar CalOneDayNameFormat Property

[Visual Basic]
Public Property CalOneDayNameFormat As System.Web.UI.WebControls.DayNameFormat
[C#]
public System.Web.UI.WebControls.DayNameFormat CalOneDayNameFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneDayStyle Property

The First Calendar CalOneDayHeaderStyle Style

[Visual Basic]
Public Property CalOneDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneFirstDayOfWeek Property

The First Calendar CalOneFirstDayOfWeek Property

[Visual Basic]
Public Property CalOneFirstDayOfWeek As System.Web.UI.WebControls.FirstDayOfWeek
[C#]
public System.Web.UI.WebControls.FirstDayOfWeek CalOneFirstDayOfWeek {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneNextMonthText Property

The First Calendar CalOneNextMonthText Property

[Visual Basic]
Public Property CalOneNextMonthText As String
[C#]
public string CalOneNextMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneNextPrevFormat Property

The First Calendar CalOneNextPrevFormat Property

[Visual Basic]
Public Property CalOneNextPrevFormat As System.Web.UI.WebControls.NextPrevFormat
[C#]
public System.Web.UI.WebControls.NextPrevFormat CalOneNextPrevFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneNextPrevStyle Property

The First Calendar CalOneNextPrevStyle Style

[Visual Basic]
Public Property CalOneNextPrevStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneNextPrevStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneOtherMonthDayStyle Property

The First Calendar CalOneOtherMonthDayStyle Style

[Visual Basic]
Public Property CalOneOtherMonthDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneOtherMonthDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOnePrevMonthText Property

The First Calendar CalOnePrevMonthText Property

[Visual Basic]
Public Property CalOnePrevMonthText As String
[C#]
public string CalOnePrevMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneSelectedDayStyle Property

The First Calendar CalOneSelectedDayStyle Style

[Visual Basic]
Public Property CalOneSelectedDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneSelectedDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneSelectMonthText Property

The First Calendar CalOneSelectMonthText Property

[Visual Basic]
Public Property CalOneSelectMonthText As String
[C#]
public string CalOneSelectMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneSelectorStyle Property

The First Calendar CalOneSelectorStyle Style

[Visual Basic]
Public Property CalOneSelectorStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneSelectorStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneSelectWeekText Property

The First Calendar CalOneSelectWeekText Property

[Visual Basic]
Public Property CalOneSelectWeekText As String
[C#]
public string CalOneSelectWeekText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneShowDayHeader Property

The First Calendar CalOneShowDayHeader Property

[Visual Basic]
Public Property CalOneShowDayHeader As Boolean
[C#]
public bool CalOneShowDayHeader {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneShowGridLines Property

The First Calendar CalOneShowGridLines Property

[Visual Basic]
Public Property CalOneShowGridLines As Boolean
[C#]
public bool CalOneShowGridLines {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneShowNextPrevMonth Property

The First Calendar CalOneShowNextPrevMonth Property

[Visual Basic]
Public Property CalOneShowNextPrevMonth As Boolean
[C#]
public bool CalOneShowNextPrevMonth {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneShowTitle Property

The First Calendar CalOneShowTitle Property

[Visual Basic]
Public Property CalOneShowTitle As Boolean
[C#]
public bool CalOneShowTitle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneTitleFormat Property

The First Calendar CalOneTitleFormat Property

[Visual Basic]
Public Property CalOneTitleFormat As System.Web.UI.WebControls.TitleFormat
[C#]
public System.Web.UI.WebControls.TitleFormat CalOneTitleFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneTitleStyle Property

The First Calendar CalOneTitleStyle Style

[Visual Basic]
Public Property CalOneTitleStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneTitleStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneTodayDayStyle Property

The First Calendar CalOneTodayDayStyle Style

[Visual Basic]
Public Property CalOneTodayDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneTodayDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalOneWeekendDayStyle Property

The First Calendar CalOneWeekendDayStyle Style

[Visual Basic]
Public Property CalOneWeekendDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalOneWeekendDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoDayHeaderStyle Property

The Second Calendar CalTwoDayHeaderStyle Style

[Visual Basic]
Public Property CalTwoDayHeaderStyle As System.Web.UI.WebControls.Style
[C#]
public System.Web.UI.WebControls.Style CalTwoDayHeaderStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoDayNameFormat Property

The Second Calendar CalTwoDayNameFormat Property

[Visual Basic]
Public Property CalTwoDayNameFormat As System.Web.UI.WebControls.DayNameFormat
[C#]
public System.Web.UI.WebControls.DayNameFormat CalTwoDayNameFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoDayStyle Property

The Second Calendar CalTwoDayStyle Style

[Visual Basic]
Public Property CalTwoDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoFirstDayOfWeek Property

The Second Calendar CalTwoFirstDayOfWeek Property

[Visual Basic]
Public Property CalTwoFirstDayOfWeek As System.Web.UI.WebControls.FirstDayOfWeek
[C#]
public System.Web.UI.WebControls.FirstDayOfWeek CalTwoFirstDayOfWeek {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoNextMonthText Property

The Second Calendar CalTwoNextMonthText Property

[Visual Basic]
Public Property CalTwoNextMonthText As String
[C#]
public string CalTwoNextMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoNextPrevFormat Property

The Second Calendar CalTwoNextPrevFormat Property

[Visual Basic]
Public Property CalTwoNextPrevFormat As System.Web.UI.WebControls.NextPrevFormat
[C#]
public System.Web.UI.WebControls.NextPrevFormat CalTwoNextPrevFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoNextPrevStyle Property

The Second Calendar CalTwoNextPrevStyle Style

[Visual Basic]
Public Property CalTwoNextPrevStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoNextPrevStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoOtherMonthDayStyle Property

The Second Calendar CalTwoOtherMonthDayStyle Style

[Visual Basic]
Public Property CalTwoOtherMonthDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoOtherMonthDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoPrevMonthText Property

The Second Calendar CalTwoPrevMonthText Property

[Visual Basic]
Public Property CalTwoPrevMonthText As String
[C#]
public string CalTwoPrevMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoSelectedDayStyle Property

The Second Calendar CalTwoSelectedDayStyle Style

[Visual Basic]
Public Property CalTwoSelectedDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoSelectedDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoSelectMonthText Property

The Second Calendar CalTwoSelectMonthText Property

[Visual Basic]
Public Property CalTwoSelectMonthText As String
[C#]
public string CalTwoSelectMonthText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoSelectorStyle Property

The Second Calendar CalTwoSelectorStyle Style

[Visual Basic]
Public Property CalTwoSelectorStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoSelectorStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoSelectWeekText Property

The Second Calendar CalTwoSelectWeekText Property

[Visual Basic]
Public Property CalTwoSelectWeekText As String
[C#]
public string CalTwoSelectWeekText {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoShowDayHeader Property

The Second Calendar CalTwoShowDayHeader Property

[Visual Basic]
Public Property CalTwoShowDayHeader As Boolean
[C#]
public bool CalTwoShowDayHeader {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoShowGridLines Property

The Second Calendar CalTwoShowGridLines Property

[Visual Basic]
Public Property CalTwoShowGridLines As Boolean
[C#]
public bool CalTwoShowGridLines {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoShowNextPrevMonth Property

The Second Calendar CalTwoShowNextPrevMonth Property

[Visual Basic]
Public Property CalTwoShowNextPrevMonth As Boolean
[C#]
public bool CalTwoShowNextPrevMonth {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoShowTitle Property

The Second Calendar CalTwoShowTitle Property

[Visual Basic]
Public Property CalTwoShowTitle As Boolean
[C#]
public bool CalTwoShowTitle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoTitleFormat Property

The Second Calendar CalTwoTitleFormat Property

[Visual Basic]
Public Property CalTwoTitleFormat As System.Web.UI.WebControls.TitleFormat
[C#]
public System.Web.UI.WebControls.TitleFormat CalTwoTitleFormat {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoTitleStyle Property

The Second Calendar CalTwoTitleStyle Style

[Visual Basic]
Public Property CalTwoTitleStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoTitleStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoTodayDayStyle Property

The Second Calendar CalTwoTodayDayStyle Style

[Visual Basic]
Public Property CalTwoTodayDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoTodayDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.CalTwoWeekendDayStyle Property

The Second Calendar CalTwoWeekendDayStyle Style

[Visual Basic]
Public Property CalTwoWeekendDayStyle As System.Web.UI.WebControls.TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle CalTwoWeekendDayStyle {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.EndDate Property

The date to be appear on the End Calendar Control if no date is selected

[Visual Basic]
Public Property EndDate As String
[C#]
public string EndDate {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.StartDate Property

The date to be appear on the Start Calendar if no date is selected

[Visual Basic]
Public Property StartDate As String
[C#]
public string StartDate {get; set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice Methods

The methods of the LocalBetweenDateTwice class are listed below. For a complete list of LocalBetweenDateTwice class members, see the LocalBetweenDateTwice Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenDateTwice Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenDateTwice.Reset Method

Reset implemented by IResetable resets the Control

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalBetweenDateTwice Class | LocalBetweenDateTwice Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue Class

Creates a search control which prompts for the user to supply two numeric values to search between. In the case that nothing is entered, this control is ignored. If the first box is filled, and the second is not, only records with values greater than or equal to the value entered will be returned. Likewise, it only the second box is filled, only values which are less than or equal to the entered value will be returned. If both boxes are entered, then values in the range are returned, including values which match the entered values. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalBetweenValue Members.

System.Object
Control
WebControl
LocalBetweenValue

[Visual Basic]
Public Class LocalBetweenValue
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IResetable, ILocal, ISearchable
[C#]
public class LocalBetweenValue : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IResetable, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue Members

Public Instance Constructors

LocalBetweenValue Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
EndText | The Text to displayed to the right of the second text box.
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MiddleText | The String to display between the two CheckBoxes
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
StartText | The Text to be displayed right of the title but left of the two text boxes
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenValue Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalBetweenValue();

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue Properties

The properties of the LocalBetweenValue class are listed below. For a complete list of LocalBetweenValue class members, see the LocalBetweenValue Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
EndText | The Text to displayed to the right of the second text box.
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MiddleText | The String to display between the two CheckBoxes
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
StartText | The Text to be displayed right of the title but left of the two text boxes
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalBetweenValue Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.EndText Property

The Text to displayed to the right of the second text box.

[Visual Basic]
Public Property EndText As String
[C#]
public string EndText {get; set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.MiddleText Property

The String to display between the two CheckBoxes

[Visual Basic]
Public Property MiddleText As String
[C#]
public string MiddleText {get; set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.StartText Property

The Text to be displayed right of the title but left of the two text boxes

[Visual Basic]
Public Property StartText As String
[C#]
public string StartText {get; set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue Methods

The methods of the LocalBetweenValue class are listed below. For a complete list of LocalBetweenValue class members, see the LocalBetweenValue Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalBetweenValue Class | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalBetweenValue.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalBetweenValue Class | LocalBetweenValue Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList Class

This creates a Search Control of Check boxes which is bound from a DataLists Control enabling the user to search the LocalField. i.e. Rather than creating a linked table with a Integer Primary Key and a Text Field with the values 0 - Disabled, 1 - Enabled, 2 - Deleted with the Primary Key stored in the LocalField, a datalist with these values can be created so the user selects from Disabled, Enabled and Deleted and the value is stored locally with the above referenced table never existing. In a Exact search, no selections will return any records that match the rest of the search, one selection will return only the records which match that selection, and multiple selections will return those records that match one of the selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalCheckBoxList Members.

System.Object
Control
WebControl
ListControl
CheckBoxList
LocalCheckBoxList

[Visual Basic]
Public Class LocalCheckBoxList
   Inherits CheckBoxList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList
[C#]
public class LocalCheckBoxList : CheckBoxList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList Members

Public Instance Constructors

LocalCheckBoxList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalCheckBoxList();

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList Properties

The properties of the LocalCheckBoxList class are listed below. For a complete list of LocalCheckBoxList class members, see the LocalCheckBoxList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.DataSet Property

String which contains the ID of the Control which specifies the DataList and ValueList for this control

[Visual Basic]
NotOverridable Public Property DataSet As String
[C#]
public string DataSet {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList Methods

The methods of the LocalCheckBoxList class are listed below. For a complete list of LocalCheckBoxList class members, see the LocalCheckBoxList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.BindDataSet Method

This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control

            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);

[Visual Basic]
NotOverridable Public Sub BindDataSet()
[C#]
public final void BindDataSet();

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.OnLoad Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.OnPreRender Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalCheckBoxList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalCheckBoxList Class | LocalCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList Class

Control which creates a Drop Down List from a DataList, allowing the user to search on none or one items from the DataList. In an Exact search, no selections will return anything that matches the rest of the search, one selection will restrict the results to the records which match the selection. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier. See LocalCheckBoxList for more information.

For a list of all members of this type, see LocalDropDownList Members.

System.Object
Control
WebControl
ListControl
DropDownList
LocalDropDownList

[Visual Basic]
Public Class LocalDropDownList
   Inherits DropDownList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList
[C#]
public class LocalDropDownList : DropDownList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList Members

Public Instance Constructors

LocalDropDownList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalDropDownList Class | Cambro.Web.QuickAdmin Namespace


LocalDropDownList Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalDropDownList();

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList Properties

The properties of the LocalDropDownList class are listed below. For a complete list of LocalDropDownList class members, see the LocalDropDownList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalDropDownList Class | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.DataSet Property

String which contains the ID of the Control which specifies the DataList and ValueList for this control

[Visual Basic]
NotOverridable Public Property DataSet As String
[C#]
public string DataSet {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList Methods

The methods of the LocalDropDownList class are listed below. For a complete list of LocalDropDownList class members, see the LocalDropDownList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalDropDownList Class | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.BindDataSet Method

This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control

            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);

[Visual Basic]
NotOverridable Public Sub BindDataSet()
[C#]
public final void BindDataSet();

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.OnLoad Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.OnPreRender Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalDropDownList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalDropDownList Class | LocalDropDownList Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox Class

This control creates a Search Control which searches the LocalField for integer values. If the box is empty, no search is done, otherwise an exact match is required to return any selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalIntBox Members.

System.Object
Control
WebControl
TextBox
LocalIntBox

[Visual Basic]
Public Class LocalIntBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable
[C#]
public class LocalIntBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox Members

Public Instance Constructors

LocalIntBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalIntBox Class | Cambro.Web.QuickAdmin Namespace


LocalIntBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalIntBox();

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox Properties

The properties of the LocalIntBox class are listed below. For a complete list of LocalIntBox class members, see the LocalIntBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalIntBox Class | Cambro.Web.QuickAdmin Namespace


LocalIntBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox Methods

The methods of the LocalIntBox class are listed below. For a complete list of LocalIntBox class members, see the LocalIntBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalIntBox Class | Cambro.Web.QuickAdmin Namespace


LocalIntBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalIntBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalIntBox Class | LocalIntBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox Class

Control which creates a ListBox from a DataList, allowing the user to select none, one or more records from the listbox. In an Exact search, selecting none returns everything that matches the rest of the search, one returns any record that matches that choice and multiple selections return all the records that match any of the selections. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier. See LocalCheckBoxList for more information.

For a list of all members of this type, see LocalListBox Members.

System.Object
Control
WebControl
ListControl
ListBox
LocalListBox

[Visual Basic]
Public Class LocalListBox
   Inherits ListBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList
[C#]
public class LocalListBox : ListBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable, IDataList

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox Members

Public Instance Constructors

LocalListBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalListBox Class | Cambro.Web.QuickAdmin Namespace


LocalListBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalListBox();

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox Properties

The properties of the LocalListBox class are listed below. For a complete list of LocalListBox class members, see the LocalListBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSet | String which contains the ID of the Control which specifies the DataList and ValueList for this control
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalListBox Class | Cambro.Web.QuickAdmin Namespace


LocalListBox.DataSet Property

String which contains the ID of the Control which specifies the DataList and ValueList for this control

[Visual Basic]
NotOverridable Public Property DataSet As String
[C#]
public string DataSet {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox Methods

The methods of the LocalListBox class are listed below. For a complete list of LocalListBox class members, see the LocalListBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl)
BindDataSet This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control
            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);
ClearSelection (inherited from ListControl)
CopyBaseAttributes (inherited from WebControl)
DataBind (inherited from Control)
Dispose (inherited from Control)
Equals (inherited from Object)
FindControl (inherited from Control)
GetHashCode (inherited from Object)
GetType (inherited from Object)
HasControls (inherited from Control)
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl)
RenderBeginTag (inherited from WebControl)
RenderControl (inherited from Control)
RenderEndTag (inherited from WebControl)
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control)
SetRenderMethodDelegate (inherited from Control)
ToString (inherited from Object)

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender | Overridden OnPreRender to Bind Items to the Control
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalListBox Class | Cambro.Web.QuickAdmin Namespace


LocalListBox.BindDataSet Method

This is the function required by IDataList to bind the DataLists referenced by the DataSet property. Use this code to find the DataLists referenced by this Control

            Control D = this.ParentAdmin.DataContainer;
            DataLists Dat = (DataLists) D.FindControl(DataSet);

[Visual Basic]
NotOverridable Public Sub BindDataSet()
[C#]
public final void BindDataSet();

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.OnLoad Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.OnPreRender Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalListBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalListBox Class | LocalListBox Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate Class

Creates a Calendar control with the ability to select one date. If no selection is made then the search does not search on the date. If a selection is made, then only the records with that exact date in the LocalField will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalOnDate Members.

System.Object
Control
WebControl
Calendar
LocalOnDate

[Visual Basic]
Public Class LocalOnDate
   Inherits Calendar
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, ILocal, IResetable, ISearchable
[C#]
public class LocalOnDate : Calendar, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackEventHandler, ILocal, IResetable, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate Members

Public Instance Constructors

LocalOnDate Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalOnDate Class | Cambro.Web.QuickAdmin Namespace


LocalOnDate Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalOnDate();

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate Properties

The properties of the LocalOnDate class are listed below. For a complete list of LocalOnDate class members, see the LocalOnDate Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.Calendar) |
CellSpacing (inherited from System.Web.UI.WebControls.Calendar) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DayHeaderStyle (inherited from System.Web.UI.WebControls.Calendar) |
DayNameFormat (inherited from System.Web.UI.WebControls.Calendar) |
DayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
FirstDayOfWeek (inherited from System.Web.UI.WebControls.Calendar) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
NextMonthText (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevFormat (inherited from System.Web.UI.WebControls.Calendar) |
NextPrevStyle (inherited from System.Web.UI.WebControls.Calendar) |
OtherMonthDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
PrevMonthText (inherited from System.Web.UI.WebControls.Calendar) |
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedDate (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDates (inherited from System.Web.UI.WebControls.Calendar) |
SelectedDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectionMode (inherited from System.Web.UI.WebControls.Calendar) |
SelectMonthText (inherited from System.Web.UI.WebControls.Calendar) |
SelectorStyle (inherited from System.Web.UI.WebControls.Calendar) |
SelectWeekText (inherited from System.Web.UI.WebControls.Calendar) |
ShowDayHeader (inherited from System.Web.UI.WebControls.Calendar) |
ShowGridLines (inherited from System.Web.UI.WebControls.Calendar) |
ShowNextPrevMonth (inherited from System.Web.UI.WebControls.Calendar) |
ShowTitle (inherited from System.Web.UI.WebControls.Calendar) |
Site (inherited from System.Web.UI.Control) |
StartDate | The date to be appear on the Calendar Control if no date is selected
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
TitleFormat (inherited from System.Web.UI.WebControls.Calendar) |
TitleStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodayDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
TodaysDate (inherited from System.Web.UI.WebControls.Calendar) |
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
VisibleDate (inherited from System.Web.UI.WebControls.Calendar) |
WeekendDayStyle (inherited from System.Web.UI.WebControls.Calendar) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalOnDate Class | Cambro.Web.QuickAdmin Namespace


LocalOnDate.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.StartDate Property

The date to be appear on the Calendar Control if no date is selected

[Visual Basic]
Public Property StartDate As String
[C#]
public string StartDate {get; set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate Methods

The methods of the LocalOnDate class are listed below. For a complete list of LocalOnDate class members, see the LocalOnDate Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Reset implemented by IResetable resets the Control
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Calendar) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
HasWeekSelectors (inherited from Calendar) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from Calendar) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnDayRender (inherited from Calendar) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Calendar) |
OnSelectionChanged (inherited from Calendar) |
OnUnload (inherited from Control) |
OnVisibleMonthChanged (inherited from Calendar) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from Calendar) |
TrackViewState (inherited from Calendar) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackEventHandler.RaisePostBackEvent (inherited from Calendar)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalOnDate Class | Cambro.Web.QuickAdmin Namespace


LocalOnDate.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalOnDate.Reset Method

Reset implemented by IResetable resets the Control

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalOnDate Class | LocalOnDate Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox Class

Creates a TextBox which allows the user to search on the LocalField for this text. It will only return exact matches and no search is done when the box is empty. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalTextBox Members.

System.Object
Control
WebControl
TextBox
LocalTextBox

[Visual Basic]
Public Class LocalTextBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable
[C#]
public class LocalTextBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox Members

Public Instance Constructors

LocalTextBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalTextBox Class | Cambro.Web.QuickAdmin Namespace


LocalTextBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public LocalTextBox();

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox Properties

The properties of the LocalTextBox class are listed below. For a complete list of LocalTextBox class members, see the LocalTextBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalTextBox Class | Cambro.Web.QuickAdmin Namespace


LocalTextBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default True

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox Methods

The methods of the LocalTextBox class are listed below. For a complete list of LocalTextBox class members, see the LocalTextBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit (inherited from Control) |
OnLoad | Just making sure all Fields exist....
OnPreRender (inherited from TextBox) |
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalTextBox Class | Cambro.Web.QuickAdmin Namespace


LocalTextBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.OnLoad Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTextBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalTextBox Class | LocalTextBox Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse Class

Creates a Control with a True and a False Check Box, which allows the user to search on bit fields or booleans in the database. In an Exact search, leaving both ticked or unticked returns all records which match the rest of the search. Ticking one and not the other will only return the relevant records. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see LocalTrueOrFalse Members.

System.Object
Control
WebControl
LocalTrueOrFalse

[Visual Basic]
Public Class LocalTrueOrFalse
   Inherits WebControl
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IResetable, ILocal, ISearchable
[C#]
public class LocalTrueOrFalse : WebControl, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IResetable, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse Members

Public Instance Constructors

LocalTrueOrFalse Constructor Add a CheckBoxList to the Control

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CheckBackColor | The Check Box List CheckBackColor Property
CheckBorderColor | The Check Box List CheckBorderColor Property
CheckBorderStyle | The Check Box List CheckBorderStyle Property
CheckBorderWidth | The Check Box List CheckBorderWidth Property
CheckCellPadding | The Check Box List CheckCellPadding Property
CheckCellSpacing | The Check Box List CheckCellSpacing Property
CheckCssClass | The Check Box List CheckCssClass Property
CheckFont | The Check Box List CheckFont Property
CheckForeColor | The Check Box List CheckForeColor Property
CheckHeight | The Check Box List CheckHeight Property
CheckRepeatColumns | The Check Box List CheckRepeatColumns Property
CheckRepeatDirection | The Check Box List CheckRepeatDirection Property
CheckRepeatLayout | The Check Box List CheckRepeatLayout Property
CheckStyle | The Check Box List CheckStyle Property
CheckTextAlign | The Check Box List CheckTextAlign Property
CheckToolTip | The Check Box List CheckToolTip Property
CheckWidth | The Check Box List CheckWidth Property
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalTrueOrFalse Class | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse Constructor

Add a CheckBoxList to the Control

[Visual Basic]
Public Sub New()
[C#]
public LocalTrueOrFalse();

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse Properties

The properties of the LocalTrueOrFalse class are listed below. For a complete list of LocalTrueOrFalse class members, see the LocalTrueOrFalse Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CheckBackColor | The Check Box List CheckBackColor Property
CheckBorderColor | The Check Box List CheckBorderColor Property
CheckBorderStyle | The Check Box List CheckBorderStyle Property
CheckBorderWidth | The Check Box List CheckBorderWidth Property
CheckCellPadding | The Check Box List CheckCellPadding Property
CheckCellSpacing | The Check Box List CheckCellSpacing Property
CheckCssClass | The Check Box List CheckCssClass Property
CheckFont | The Check Box List CheckFont Property
CheckForeColor | The Check Box List CheckForeColor Property
CheckHeight | The Check Box List CheckHeight Property
CheckRepeatColumns | The Check Box List CheckRepeatColumns Property
CheckRepeatDirection | The Check Box List CheckRepeatDirection Property
CheckRepeatLayout | The Check Box List CheckRepeatLayout Property
CheckStyle | The Check Box List CheckStyle Property
CheckTextAlign | The Check Box List CheckTextAlign Property
CheckToolTip | The Check Box List CheckToolTip Property
CheckWidth | The Check Box List CheckWidth Property
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for this Field
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

LocalTrueOrFalse Class | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckBackColor Property

The Check Box List CheckBackColor Property

[Visual Basic]
Public Property CheckBackColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckBackColor {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckBorderColor Property

The Check Box List CheckBorderColor Property

[Visual Basic]
Public Property CheckBorderColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckBorderColor {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckBorderStyle Property

The Check Box List CheckBorderStyle Property

[Visual Basic]
Public Property CheckBorderStyle As System.Web.UI.WebControls.BorderStyle
[C#]
public System.Web.UI.WebControls.BorderStyle CheckBorderStyle {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckBorderWidth Property

The Check Box List CheckBorderWidth Property

[Visual Basic]
Public Property CheckBorderWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckBorderWidth {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckCellPadding Property

The Check Box List CheckCellPadding Property

[Visual Basic]
Public Property CheckCellPadding As Integer
[C#]
public int CheckCellPadding {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckCellSpacing Property

The Check Box List CheckCellSpacing Property

[Visual Basic]
Public Property CheckCellSpacing As Integer
[C#]
public int CheckCellSpacing {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckCssClass Property

The Check Box List CheckCssClass Property

[Visual Basic]
Public Property CheckCssClass As String
[C#]
public string CheckCssClass {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckFont Property

The Check Box List CheckFont Property

[Visual Basic]
Public ReadOnly Property CheckFont As System.Web.UI.WebControls.FontInfo
[C#]
public System.Web.UI.WebControls.FontInfo CheckFont {get;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckForeColor Property

The Check Box List CheckForeColor Property

[Visual Basic]
Public Property CheckForeColor As System.Drawing.Color
[C#]
public System.Drawing.Color CheckForeColor {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckHeight Property

The Check Box List CheckHeight Property

[Visual Basic]
Public Property CheckHeight As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckHeight {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckRepeatColumns Property

The Check Box List CheckRepeatColumns Property

[Visual Basic]
Public Property CheckRepeatColumns As Integer
[C#]
public int CheckRepeatColumns {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckRepeatDirection Property

The Check Box List CheckRepeatDirection Property

[Visual Basic]
Public Property CheckRepeatDirection As System.Web.UI.WebControls.RepeatDirection
[C#]
public System.Web.UI.WebControls.RepeatDirection CheckRepeatDirection {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckRepeatLayout Property

The Check Box List CheckRepeatLayout Property

[Visual Basic]
Public Property CheckRepeatLayout As System.Web.UI.WebControls.RepeatLayout
[C#]
public System.Web.UI.WebControls.RepeatLayout CheckRepeatLayout {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckStyle Property

The Check Box List CheckStyle Property

[Visual Basic]
Public ReadOnly Property CheckStyle As System.Web.UI.CssStyleCollection
[C#]
public System.Web.UI.CssStyleCollection CheckStyle {get;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckTextAlign Property

The Check Box List CheckTextAlign Property

[Visual Basic]
Public Property CheckTextAlign As System.Web.UI.WebControls.TextAlign
[C#]
public System.Web.UI.WebControls.TextAlign CheckTextAlign {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckToolTip Property

The Check Box List CheckToolTip Property

[Visual Basic]
Public Property CheckToolTip As String
[C#]
public string CheckToolTip {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.CheckWidth Property

The Check Box List CheckWidth Property

[Visual Basic]
Public Property CheckWidth As System.Web.UI.WebControls.Unit
[C#]
public System.Web.UI.WebControls.Unit CheckWidth {get; set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.Title Property

The Title to display for this Field

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse Methods

The methods of the LocalTrueOrFalse class are listed below. For a complete list of LocalTrueOrFalse class members, see the LocalTrueOrFalse Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

LocalTrueOrFalse Class | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


LocalTrueOrFalse.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

LocalTrueOrFalse Class | LocalTrueOrFalse Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList Class

Control which creates a Search control containing a Check Box List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If more than one selection is made, any records that match at least one of the records will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see Many2ManyCheckBoxList Members.

System.Object
Control
WebControl
ListControl
CheckBoxList
Many2ManyCheckBoxList

[Visual Basic]
Public Class Many2ManyCheckBoxList
   Inherits CheckBoxList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class Many2ManyCheckBoxList : CheckBoxList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList Members

Public Instance Constructors

Many2ManyCheckBoxList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2ManyCheckBoxList();

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList Properties

The properties of the Many2ManyCheckBoxList class are listed below. For a complete list of Many2ManyCheckBoxList class members, see the Many2ManyCheckBoxList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList Methods

The methods of the Many2ManyCheckBoxList class are listed below. For a complete list of Many2ManyCheckBoxList class members, see the Many2ManyCheckBoxList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyCheckBoxList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Many2ManyCheckBoxList Class | Many2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList Class

Control which creates a Search control containing a Drop Down List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see Many2ManyDropDownList Members.

System.Object
Control
WebControl
ListControl
DropDownList
Many2ManyDropDownList

[Visual Basic]
Public Class Many2ManyDropDownList
   Inherits DropDownList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class Many2ManyDropDownList : DropDownList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList Members

Public Instance Constructors

Many2ManyDropDownList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2ManyDropDownList();

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList Properties

The properties of the Many2ManyDropDownList class are listed below. For a complete list of Many2ManyDropDownList class members, see the Many2ManyDropDownList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList Methods

The methods of the Many2ManyDropDownList class are listed below. For a complete list of Many2ManyDropDownList class members, see the Many2ManyDropDownList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyDropDownList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Many2ManyDropDownList Class | Many2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox Class

Control which creates a Search control containing a List Box of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If more than one selection is made, any records that match at least one of the records will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see Many2ManyListBox Members.

System.Object
Control
WebControl
ListControl
ListBox
Many2ManyListBox

[Visual Basic]
Public Class Many2ManyListBox
   Inherits ListBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class Many2ManyListBox : ListBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox Members

Public Instance Constructors

Many2ManyListBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2ManyListBox();

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox Properties

The properties of the Many2ManyListBox class are listed below. For a complete list of Many2ManyListBox class members, see the Many2ManyListBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox Methods

The methods of the Many2ManyListBox class are listed below. For a complete list of Many2ManyListBox class members, see the Many2ManyListBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyListBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Many2ManyListBox Class | Many2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList Class

Control which creates a Search control containing a Radio Button List of all the links possible in this Many2Many relationship. If no selection is made, the search will not be affected. If one selection is made only the records that match the selection will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see Many2ManyRadioButtonList Members.

System.Object
Control
WebControl
ListControl
RadioButtonList
Many2ManyRadioButtonList

[Visual Basic]
Public Class Many2ManyRadioButtonList
   Inherits RadioButtonList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class Many2ManyRadioButtonList : RadioButtonList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList Members

Public Instance Constructors

Many2ManyRadioButtonList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2ManyRadioButtonList();

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList Properties

The properties of the Many2ManyRadioButtonList class are listed below. For a complete list of Many2ManyRadioButtonList class members, see the Many2ManyRadioButtonList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList Methods

The methods of the Many2ManyRadioButtonList class are listed below. For a complete list of Many2ManyRadioButtonList class members, see the Many2ManyRadioButtonList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyRadioButtonList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Many2ManyRadioButtonList Class | Many2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox Class

Control which creates a Search Control containing a TextBox. If no text is entered, then the search is not affected by this control. If text is entered, then only records that match the text exactly will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see Many2ManyTextBox Members.

System.Object
Control
WebControl
TextBox
Many2ManyTextBox

[Visual Basic]
Public Class Many2ManyTextBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable
[C#]
public class Many2ManyTextBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IMany2Many, IOne2Many, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox Members

Public Instance Constructors

Many2ManyTextBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public Many2ManyTextBox();

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox Properties

The properties of the Many2ManyTextBox class are listed below. For a complete list of Many2ManyTextBox class members, see the Many2ManyTextBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | Field which stores the data to be displayed to the user
ForeignKeyField | The Key that references the One2Many Table Primary Key
ForeignTable | The One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
IntermediateForeignKey | The Key which references the One2Many Table Primary Key
IntermediateLocalKey | The Key which references the Primary Key of the Local Table
IntermediateTable | The Intermediate Table
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

Many2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.ForeignDataField Property

Field which stores the data to be displayed to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.ForeignKeyField Property

The Key that references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.ForeignTable Property

The One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.IntermediateForeignKey Property

The Key which references the One2Many Table Primary Key

[Visual Basic]
NotOverridable Public Property IntermediateForeignKey As String
[C#]
public string IntermediateForeignKey {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.IntermediateLocalKey Property

The Key which references the Primary Key of the Local Table

[Visual Basic]
NotOverridable Public Property IntermediateLocalKey As String
[C#]
public string IntermediateLocalKey {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.IntermediateTable Property

The Intermediate Table

[Visual Basic]
NotOverridable Public Property IntermediateTable As String
[C#]
public string IntermediateTable {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default True

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox Methods

The methods of the Many2ManyTextBox class are listed below. For a complete list of Many2ManyTextBox class members, see the Many2ManyTextBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
Insert | Not used in Search Mode, only in Add/Remove/Edit
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
Remove | Not used in Search Mode, only in Add/Remove/Edit
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

Many2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Insert Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Insert() As System.Collections.ArrayList
[C#]
public final ArrayList Insert();

Return Value

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Remove Method

Not used in Search Mode, only in Add/Remove/Edit

[Visual Basic]
NotOverridable Public Function Remove() As System.Collections.ArrayList
[C#]
public final ArrayList Remove();

Return Value

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Many2ManyTextBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Many2ManyTextBox Class | Many2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList Class

Check Box List Control which displays values from a linked table in a checkbox list to the user. If no Check Boxes are ticked, the search is not affected. If one box is ticked, only records which match that selection are returned, if multiple are ticked then any records that match any of the selections are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see One2ManyCheckBoxList Members.

System.Object
Control
WebControl
ListControl
CheckBoxList
One2ManyCheckBoxList

[Visual Basic]
Public Class One2ManyCheckBoxList
   Inherits CheckBoxList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class One2ManyCheckBoxList : CheckBoxList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList Members

Public Instance Constructors

One2ManyCheckBoxList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2ManyCheckBoxList();

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList Properties

The properties of the One2ManyCheckBoxList class are listed below. For a complete list of One2ManyCheckBoxList class members, see the One2ManyCheckBoxList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.CheckBoxList) |
CellSpacing (inherited from System.Web.UI.WebControls.CheckBoxList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatDirection (inherited from System.Web.UI.WebControls.CheckBoxList) |
RepeatLayout (inherited from System.Web.UI.WebControls.CheckBoxList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.CheckBoxList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.ForeignDataField Property

One2Many Data Field is the Field to display to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList Methods

The methods of the One2ManyCheckBoxList class are listed below. For a complete list of One2ManyCheckBoxList class members, see the One2ManyCheckBoxList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from CheckBoxList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from CheckBoxList) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from CheckBoxList)
IPostBackDataHandler.LoadPostData (inherited from CheckBoxList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from CheckBoxList)
IRepeatInfoUser.RenderItem (inherited from CheckBoxList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyCheckBoxList Class | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyCheckBoxList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

One2ManyCheckBoxList Class | One2ManyCheckBoxList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList Class

This control creates a Search control which searches a linked table. A list of the possible values are displayed in a Drop Down List for the user to select from. In the event that no selections are made, the search is not affected. If an item in the list is selected, then only records that match that selection are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see One2ManyDropDownList Members.

System.Object
Control
WebControl
ListControl
DropDownList
One2ManyDropDownList

[Visual Basic]
Public Class One2ManyDropDownList
   Inherits DropDownList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class One2ManyDropDownList : DropDownList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList Members

Public Instance Constructors

One2ManyDropDownList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2ManyDropDownList();

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList Properties

The properties of the One2ManyDropDownList class are listed below. For a complete list of One2ManyDropDownList class members, see the One2ManyDropDownList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.DropDownList) |
BorderStyle (inherited from System.Web.UI.WebControls.DropDownList) |
BorderWidth (inherited from System.Web.UI.WebControls.DropDownList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
SelectedIndex (inherited from System.Web.UI.WebControls.DropDownList) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.DropDownList) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.ForeignDataField Property

One2Many Data Field is the Field to display to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList Methods

The methods of the One2ManyDropDownList class are listed below. For a complete list of One2ManyDropDownList class members, see the One2ManyDropDownList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from DropDownList) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from DropDownList) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from DropDownList) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from DropDownList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from DropDownList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyDropDownList Class | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyDropDownList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

One2ManyDropDownList Class | One2ManyDropDownList Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox Class

This control creates a Search control which extracts values from a linked table and displays them in a list box. In the event that no selections are made, this control does not affect the search. If one selection is made, then only records that match that selection will be returned. If multiple selections are made, then any record that matches any of the selections will be returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see One2ManyListBox Members.

System.Object
Control
WebControl
ListControl
ListBox
One2ManyListBox

[Visual Basic]
Public Class One2ManyListBox
   Inherits ListBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class One2ManyListBox : ListBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox Members

Public Instance Constructors

One2ManyListBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyListBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2ManyListBox();

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox Properties

The properties of the One2ManyListBox class are listed below. For a complete list of One2ManyListBox class members, see the One2ManyListBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.ListBox) |
BorderStyle (inherited from System.Web.UI.WebControls.ListBox) |
BorderWidth (inherited from System.Web.UI.WebControls.ListBox) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
Rows (inherited from System.Web.UI.WebControls.ListBox) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
SelectionMode (inherited from System.Web.UI.WebControls.ListBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.ListBox) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.ForeignDataField Property

One2Many Data Field is the Field to display to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox Methods

The methods of the One2ManyListBox class are listed below. For a complete list of One2ManyListBox class members, see the One2ManyListBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from ListBox) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from ListBox) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from ListBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from ListBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyListBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyListBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

One2ManyListBox Class | One2ManyListBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList Class

This control creates a Search control which searches a linked table and displays the possible links in a Radio Button List. If No selections are made, the search is not affected. If one selection is made then only records that match that selection are returned. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see One2ManyRadioButtonList Members.

System.Object
Control
WebControl
ListControl
RadioButtonList
One2ManyRadioButtonList

[Visual Basic]
Public Class One2ManyRadioButtonList
   Inherits RadioButtonList
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields
[C#]
public class One2ManyRadioButtonList : RadioButtonList, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IRepeatInfoUser, INamingContainer, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable, IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList Members

Public Instance Constructors

One2ManyRadioButtonList Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2ManyRadioButtonList();

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList Properties

The properties of the One2ManyRadioButtonList class are listed below. For a complete list of One2ManyRadioButtonList class members, see the One2ManyRadioButtonList Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.ListControl) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
CellPadding (inherited from System.Web.UI.WebControls.RadioButtonList) |
CellSpacing (inherited from System.Web.UI.WebControls.RadioButtonList) |
ClientID (inherited from System.Web.UI.Control) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
DataMember (inherited from System.Web.UI.WebControls.ListControl) |
DataSource (inherited from System.Web.UI.WebControls.ListControl) |
DataTextField (inherited from System.Web.UI.WebControls.ListControl) |
DataTextFormatString (inherited from System.Web.UI.WebControls.ListControl) |
DataValueField (inherited from System.Web.UI.WebControls.ListControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user
ForeignGroupFields | The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
Items (inherited from System.Web.UI.WebControls.ListControl) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default False
RepeatColumns (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatDirection (inherited from System.Web.UI.WebControls.RadioButtonList) |
RepeatLayout (inherited from System.Web.UI.WebControls.RadioButtonList) |
SelectedIndex (inherited from System.Web.UI.WebControls.ListControl) |
SelectedItem (inherited from System.Web.UI.WebControls.ListControl) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
TextAlign (inherited from System.Web.UI.WebControls.RadioButtonList) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.WebControl)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.ForeignDataField Property

One2Many Data Field is the Field to display to the user

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.ForeignGroupFields Property

The String which is placed inside the SQL Select Query, to group 2 or more fields together. See IGroupFields for more details

[Visual Basic]
NotOverridable Public Property ForeignGroupFields As String
[C#]
public string ForeignGroupFields {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default False

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList Methods

The methods of the One2ManyRadioButtonList class are listed below. For a complete list of One2ManyRadioButtonList class members, see the One2ManyRadioButtonList Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
ClearSelection (inherited from ListControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from WebControl) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from RadioButtonList) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from ListControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from ListControl) |
OnInit | Just making sure all Fields exist....
OnLoad | Overridden OnPreRender to Bind Items to the Control
OnPreRender | Overridden OnPreRender
OnSelectedIndexChanged (inherited from ListControl) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from ListControl) |
TrackViewState (inherited from ListControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IRepeatInfoUser.GetItemStyle (inherited from RadioButtonList)
IPostBackDataHandler.LoadPostData (inherited from RadioButtonList)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from RadioButtonList)
IRepeatInfoUser.RenderItem (inherited from RadioButtonList)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyRadioButtonList Class | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.OnLoad Method

Overridden OnPreRender to Bind Items to the Control

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs e
);

Parameters

e

EventArgs e

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyRadioButtonList.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

One2ManyRadioButtonList Class | One2ManyRadioButtonList Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox Class

Control which allows the user to search on text values in a One2Many Table. This search control does not search when the text box is empty, and only returns results that match exactly if the text box is not empty. If the search is a Fuzzy search, then all records will be returned, but the matches get scores based on the Match Multiplier.

For a list of all members of this type, see One2ManyTextBox Members.

System.Object
Control
WebControl
TextBox
One2ManyTextBox

[Visual Basic]
Public Class One2ManyTextBox
   Inherits TextBox
   Implements IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable
[C#]
public class One2ManyTextBox : TextBox, IComponent, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor, IPostBackDataHandler, IResetable, IOne2Many, ILocal, ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox Members

Public Instance Constructors

One2ManyTextBox Constructor

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user Depreciated in version 1.1 - use ForeignKeyField
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public One2ManyTextBox();

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox Properties

The properties of the One2ManyTextBox class are listed below. For a complete list of One2ManyTextBox class members, see the One2ManyTextBox Members topic.

Public Instance Properties

AccessKey (inherited from System.Web.UI.WebControls.WebControl) |
Attributes (inherited from System.Web.UI.WebControls.WebControl) |
AutoPostBack (inherited from System.Web.UI.WebControls.TextBox) |
BackColor (inherited from System.Web.UI.WebControls.WebControl) |
BindingContainer (inherited from System.Web.UI.Control) |
BorderColor (inherited from System.Web.UI.WebControls.WebControl) |
BorderStyle (inherited from System.Web.UI.WebControls.WebControl) |
BorderWidth (inherited from System.Web.UI.WebControls.WebControl) |
ClientID (inherited from System.Web.UI.Control) |
Columns (inherited from System.Web.UI.WebControls.TextBox) |
Controls (inherited from System.Web.UI.Control) |
ControlStyle (inherited from System.Web.UI.WebControls.WebControl) |
ControlStyleCreated (inherited from System.Web.UI.WebControls.WebControl) |
CssClass (inherited from System.Web.UI.WebControls.WebControl) |
Enabled (inherited from System.Web.UI.WebControls.WebControl) |
EnableViewState (inherited from System.Web.UI.Control) |
Font (inherited from System.Web.UI.WebControls.WebControl) |
ForeColor (inherited from System.Web.UI.WebControls.WebControl) |
ForeignDataField | One2Many Data Field is the Field to display to the user Depreciated in version 1.1 - use ForeignKeyField
ForeignKeyField | This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table
ForeignTable | The is the One2Many Table
Height (inherited from System.Web.UI.WebControls.WebControl) |
ID (inherited from System.Web.UI.Control) |
LocalField | Get or Sets the LocalField Value
MatchMultiplier | The score the ranked search should get for an exact match
MaxLength (inherited from System.Web.UI.WebControls.TextBox) |
NamingContainer (inherited from System.Web.UI.Control) |
Page (inherited from System.Web.UI.Control) |
Parent (inherited from System.Web.UI.Control) |
ParentAdmin | This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....
Quotes | Should the field be enclosed in quotes in the SQL Query? Default True
ReadOnly (inherited from System.Web.UI.WebControls.TextBox) |
Rows (inherited from System.Web.UI.WebControls.TextBox) |
Site (inherited from System.Web.UI.Control) |
Style (inherited from System.Web.UI.WebControls.WebControl) |
TabIndex (inherited from System.Web.UI.WebControls.WebControl) |
TemplateSourceDirectory (inherited from System.Web.UI.Control) |
Text (inherited from System.Web.UI.WebControls.TextBox) |
TextMode (inherited from System.Web.UI.WebControls.TextBox) |
Title | The Title to display for these Fields
ToolTip (inherited from System.Web.UI.WebControls.WebControl) |
UniqueID (inherited from System.Web.UI.Control) |
Visible (inherited from System.Web.UI.Control) |
Width (inherited from System.Web.UI.WebControls.WebControl) |
Wrap (inherited from System.Web.UI.WebControls.TextBox) |

Protected Instance Properties

ChildControlsCreated (inherited from System.Web.UI.Control)
Context (inherited from System.Web.UI.Control)
Events (inherited from System.Web.UI.Control)
HasChildViewState (inherited from System.Web.UI.Control)
IsTrackingViewState (inherited from System.Web.UI.Control)
TagKey (inherited from System.Web.UI.WebControls.TextBox)
TagName (inherited from System.Web.UI.WebControls.WebControl)
ViewState (inherited from System.Web.UI.Control)
ViewStateIgnoresCase (inherited from System.Web.UI.Control)

See Also

One2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.ForeignDataField Property

One2Many Data Field is the Field to display to the user Depreciated in version 1.1 - use ForeignKeyField

[Visual Basic]
NotOverridable Public Property ForeignDataField As String
[C#]
public string ForeignDataField {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.ForeignKeyField Property

This is the Primary Key of the One2Many Table, which is stored in the LocalField of the Local Table

[Visual Basic]
NotOverridable Public Property ForeignKeyField As String
[C#]
public string ForeignKeyField {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.ForeignTable Property

The is the One2Many Table

[Visual Basic]
NotOverridable Public Property ForeignTable As String
[C#]
public string ForeignTable {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.LocalField Property

Get or Sets the LocalField Value

[Visual Basic]
NotOverridable Public Property LocalField As String
[C#]
public string LocalField {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.MatchMultiplier Property

The score the ranked search should get for an exact match

[Visual Basic]
NotOverridable Public Property MatchMultiplier As Integer
[C#]
public int MatchMultiplier {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.ParentAdmin Property

This is a reference to the Parent Admin Control, used to determine the mode QuickAdmin is in and more.....

[Visual Basic]
NotOverridable Public Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
public Admin ParentAdmin {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.Quotes Property

Should the field be enclosed in quotes in the SQL Query? Default True

[Visual Basic]
NotOverridable Public Property Quotes As Boolean
[C#]
public bool Quotes {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.Title Property

The Title to display for these Fields

[Visual Basic]
NotOverridable Public Property Title As String
[C#]
public string Title {final get; final set;}

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox Methods

The methods of the One2ManyTextBox class are listed below. For a complete list of One2ManyTextBox class members, see the One2ManyTextBox Members topic.

Public Instance Methods

ApplyStyle (inherited from WebControl) |
CopyBaseAttributes (inherited from WebControl) |
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
HasControls (inherited from Control) |
MakeExact | Function to create the statements for the Exact Matching SQL Query
MakeRank | Function to create the Case Statements for the Ranked SQL Query
MergeStyle (inherited from WebControl) |
RenderBeginTag (inherited from WebControl) |
RenderControl (inherited from Control) |
RenderEndTag (inherited from WebControl) |
Reset | Function which is called when the Reset Button is pressed
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |

Protected Instance Methods

AddAttributesToRender (inherited from TextBox) |
AddParsedSubObject (inherited from TextBox) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
CreateControlStyle (inherited from WebControl) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from WebControl) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit | Just making sure all Fields exist....
OnLoad (inherited from Control) |
OnPreRender | Overridden OnPreRender
OnTextChanged (inherited from TextBox) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render | Overridden Render to draw the control in the table with its title
RenderChildren (inherited from Control) |
RenderContents (inherited from WebControl) |
SaveViewState (inherited from WebControl) |
TrackViewState (inherited from WebControl) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)
IAttributeAccessor.GetAttribute (inherited from WebControl)
IPostBackDataHandler.LoadPostData (inherited from TextBox)
IPostBackDataHandler.RaisePostDataChangedEvent (inherited from TextBox)
IAttributeAccessor.SetAttribute (inherited from WebControl)

See Also

One2ManyTextBox Class | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.MakeExact Method

Function to create the statements for the Exact Matching SQL Query

[Visual Basic]
NotOverridable Public Function MakeExact() As String
[C#]
public final string MakeExact();

Return Value

String for the SQL Query Where

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.MakeRank Method

Function to create the Case Statements for the Ranked SQL Query

[Visual Basic]
NotOverridable Public Function MakeRank() As String
[C#]
public final string MakeRank();

Return Value

Case statement String

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.OnInit Method

Just making sure all Fields exist....

[Visual Basic]
Overrides Protected Sub OnInit( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnInit(
   EventArgs e
);

Parameters

e

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.OnPreRender Method

Overridden OnPreRender

[Visual Basic]
Overrides Protected Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
[C#]
protected override void OnPreRender(
   EventArgs e
);

Parameters

e

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.Render Method

Overridden Render to draw the control in the table with its title

[Visual Basic]
Overrides Protected Sub Render( _
   ByVal w As System.Web.UI.HtmlTextWriter _
)
[C#]
protected override void Render(
   HtmlTextWriter w
);

Parameters

w

HtmlTextWriter w

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


One2ManyTextBox.Reset Method

Function which is called when the Reset Button is pressed

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

One2ManyTextBox Class | One2ManyTextBox Members | Cambro.Web.QuickAdmin Namespace


Db Class

Class contains static methods to create Database Queries, Selects etc

For a list of all members of this type, see Db Members.

System.Object
Db

[Visual Basic]
Public Class Db
[C#]
public class Db

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Db Members | Cambro.Web.QuickAdmin Namespace


Db Members

Public Static (Shared) Methods

Dv | Method which returns a DataView.
PNum | Method which ensures that any numeric values which are inserted into the database are correct
PStr | Method which ensures that any strings in a SQL query can be handled correctly by the database, by replacing single quotes with two single quotes

Public Instance Constructors

Db Constructor

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Db Class | Cambro.Web.QuickAdmin Namespace


Db Constructor

[Visual Basic]
Public Sub New()
[C#]
public Db();

See Also

Db Class | Db Members | Cambro.Web.QuickAdmin Namespace


Db Methods

The methods of the Db class are listed below. For a complete list of Db class members, see the Db Members topic.

Public Static (Shared) Methods

Dv | Method which returns a DataView.
PNum | Method which ensures that any numeric values which are inserted into the database are correct
PStr | Method which ensures that any strings in a SQL query can be handled correctly by the database, by replacing single quotes with two single quotes

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Db Class | Cambro.Web.QuickAdmin Namespace


Db.Dv Method

Method which returns a DataView.

[Visual Basic]
Public Shared Function Dv( _
   ByVal SQL As String, _
   ByVal o As Object _
) As System.Data.DataView
[C#]
public static DataView Dv(
   string SQL,
   object o
);

Parameters

SQL

A sql string to run on the database

o

An object in the QuickAdmin Hierarchy

Return Value

See Also

Db Class | Db Members | Cambro.Web.QuickAdmin Namespace


Db.PNum Method

Method which ensures that any numeric values which are inserted into the database are correct

[Visual Basic]
Public Shared Function PNum( _
   ByVal inObj As Object _
) As String
[C#]
public static string PNum(
   object inObj
);

Parameters

inObj

The numeric object in the SQL string

Return Value

See Also

Db Class | Db Members | Cambro.Web.QuickAdmin Namespace


Db.PStr Method

Method which ensures that any strings in a SQL query can be handled correctly by the database, by replacing single quotes with two single quotes

[Visual Basic]
Public Shared Function PStr( _
   ByVal inObj As Object _
) As String
[C#]
public static string PStr(
   object inObj
);

Parameters

inObj

The object in the SQL string

Return Value

See Also

Db Class | Db Members | Cambro.Web.QuickAdmin Namespace


StrMan Class

Class Containing Static Functions

For a list of all members of this type, see StrMan Members.

System.Object
StrMan

[Visual Basic]
Public Class StrMan
[C#]
public class StrMan

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

StrMan Members | Cambro.Web.QuickAdmin Namespace


StrMan Members

Public Static (Shared) Methods

ID2Field | This method is identical to the IDField method, though it works on the Second half of the joint Primary Key if there is one.
IDField | This method is used in the Edit Controls and parsed the Primary ID of the relevant record in the database. It returns a string which is inserted in the SQL query with the ID either in quotes if it is string or parsed as a number if it is not.
Quotes | This method places the value of the LocalField of the ILocal Control in quotes or not depending on the settings of the Quotes property of control which called this method.

Public Instance Constructors

StrMan Constructor

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StrMan Class | Cambro.Web.QuickAdmin Namespace


StrMan Constructor

[Visual Basic]
Public Sub New()
[C#]
public StrMan();

See Also

StrMan Class | StrMan Members | Cambro.Web.QuickAdmin Namespace


StrMan Methods

The methods of the StrMan class are listed below. For a complete list of StrMan class members, see the StrMan Members topic.

Public Static (Shared) Methods

ID2Field | This method is identical to the IDField method, though it works on the Second half of the joint Primary Key if there is one.
IDField | This method is used in the Edit Controls and parsed the Primary ID of the relevant record in the database. It returns a string which is inserted in the SQL query with the ID either in quotes if it is string or parsed as a number if it is not.
Quotes | This method places the value of the LocalField of the ILocal Control in quotes or not depending on the settings of the Quotes property of control which called this method.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StrMan Class | Cambro.Web.QuickAdmin Namespace


StrMan.ID2Field Method

This method is identical to the IDField method, though it works on the Second half of the joint Primary Key if there is one.

[Visual Basic]
Public Shared Function ID2Field( _
   ByVal ID As String, _
   ByVal o As Object _
) As String
[C#]
public static string ID2Field(
   string ID,
   object o
);

Parameters

ID

The second half of the joint Primary Key of the relevant record

o

An object in the QuickAdmin Hierarchy

Return Value

string containing the second half of the joint primary key with or without quotes

See Also

StrMan Class | StrMan Members | Cambro.Web.QuickAdmin Namespace


StrMan.IDField Method

This method is used in the Edit Controls and parsed the Primary ID of the relevant record in the database. It returns a string which is inserted in the SQL query with the ID either in quotes if it is string or parsed as a number if it is not.

[Visual Basic]
Public Shared Function IDField( _
   ByVal ID As String, _
   ByVal o As Object _
) As String
[C#]
public static string IDField(
   string ID,
   object o
);

Parameters

ID

The Primary Key of the relevant record

o

An object in the QuickAdmin Hierarchy

Return Value

string containing the primary key with or without quotes

See Also

StrMan Class | StrMan Members | Cambro.Web.QuickAdmin Namespace


StrMan.Quotes Method

This method places the value of the LocalField of the ILocal Control in quotes or not depending on the settings of the Quotes property of control which called this method.

[Visual Basic]
Public Shared Function Quotes( _
   ByVal IOO As Cambro.Web.QuickAdmin.ILocal, _
   ByVal Inner As String _
) As String
[C#]
public static string Quotes(
   ILocal IOO,
   string Inner
);

Parameters

IOO

ILocal Control

Inner

string, the value of the LocalField

Return Value

The value of the LocalField with or without surrounding quotes

See Also

StrMan Class | StrMan Members | Cambro.Web.QuickAdmin Namespace


IBindable Interface

Interface to be implemented by all Controls to be used in the View/Edit/Delete part of QuickAdmin

For a list of all members of this type, see IBindable Members.

[Visual Basic]
Public Interface IBindable
   Implements ILocal
[C#]
public interface IBindable : ILocal

Remarks

IBindable is a very simple yet powerful interface to implement. With a few simple settings to make, it is easy to add your own custom Server Control to the collection of Controls available to you using Cambro's QuickAdmin. See below with a demonstration of how to create a Rich Text Box for your Form.

Example

The HTML attribute allows the Text of the Rich Text Box to be get{} and set{}

             public class EditRichEdit : Cambro.Web.QuickAdmin.EditControl, IBindable, IResetable
             {
                 private Cambro.Web.RichEdit.RichEdit MyRichEdit = new Cambro.Web.RichEdit.RichEdit();

                    new public string textValue
                    {
                        get { return MyRichEdit.Html; }
                        set { MyRichEdit.Html = value; }
                    }

                    public EditRichEdit()
                    {
                        Controls.Add(MyRichEdit);
                    }

                    new public void Reset()
                    {
                        MyRichEdit.Html = "";
                    }

                    new public void Bind(string bound)
                    {
                        MyRichEdit.Html = bound;
                    }

                    protected override void Render(HtmlTextWriter w)
                    {
                        if (ParentAdmin.AdminMode == Admin.Mode.Edit && Editable == true || ParentAdmin.AdminMode == Admin.Mode.Add && Addable == true)
                        {
                            w.Write("<tr><td class=lefttitle>" +Title+ "</td><td class=rightvalues>");
                            base.Render(w);
                            w.Write("</td></tr>");
                        }
                        else
                        {
                            w.Write("<tr><td class=lefttitle>" +Title+ "</td><td class=rightvalues>" + MyRichEdit.Html + "</td></tr>");
                        }
                    }
            }

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IBindable Members | Cambro.Web.QuickAdmin Namespace


IBindable Members

Public Instance Properties

Addable | Field appear in Add Screen?
Editable | Is the Field editable in Edit Mode
textValue | Used to access the value of the control such as its text, selected item(s), date etc.
Trim | Should the Field be trimmed for leading and following whitespace before display to the user?

Public Instance Methods

Bind Function which enables the control to given its value in the database, so the correct item in a list can be selected or the textbox can display a string

See Also

IBindable Interface | Cambro.Web.QuickAdmin Namespace


IBindable Properties

The properties of the IBindable class are listed below. For a complete list of IBindable class members, see the IBindable Members topic.

Public Instance Properties

Addable | Field appear in Add Screen?
Editable | Is the Field editable in Edit Mode
textValue | Used to access the value of the control such as its text, selected item(s), date etc.
Trim | Should the Field be trimmed for leading and following whitespace before display to the user?

See Also

IBindable Interface | Cambro.Web.QuickAdmin Namespace


IBindable.Addable Property

Field appear in Add Screen?

[Visual Basic]
Property Addable As Boolean
[C#]
bool Addable {get; set;}

See Also

IBindable Interface | IBindable Members | Cambro.Web.QuickAdmin Namespace


IBindable.Editable Property

Is the Field editable in Edit Mode

[Visual Basic]
Property Editable As Boolean
[C#]
bool Editable {get; set;}

See Also

IBindable Interface | IBindable Members | Cambro.Web.QuickAdmin Namespace


IBindable.textValue Property

Used to access the value of the control such as its text, selected item(s), date etc.

[Visual Basic]
Property textValue As String
[C#]
string textValue {get; set;}

See Also

IBindable Interface | IBindable Members | Cambro.Web.QuickAdmin Namespace


IBindable.Trim Property

Should the Field be trimmed for leading and following whitespace before display to the user?

[Visual Basic]
Property Trim As Boolean
[C#]
bool Trim {get; set;}

See Also

IBindable Interface | IBindable Members | Cambro.Web.QuickAdmin Namespace


IBindable Methods

The methods of the IBindable class are listed below. For a complete list of IBindable class members, see the IBindable Members topic.

Public Instance Methods

Bind Function which enables the control to given its value in the database, so the correct item in a list can be selected or the textbox can display a string

See Also

IBindable Interface | Cambro.Web.QuickAdmin Namespace


IBindable.Bind Method

Function which enables the control to given its value in the database, so the correct item in a list can be selected or the textbox can display a string

[Visual Basic]
Sub Bind( _
   ByVal Bind As String _
)
[C#]
void Bind(
   string Bind
);

Parameters

Bind

String which is the value of this field from the database

See Also

IBindable Interface | IBindable Members | Cambro.Web.QuickAdmin Namespace


IDataList Interface

Interface implemented by all Local Controls which can be bound to a DataList

For a list of all members of this type, see IDataList Members.

[Visual Basic]
Public Interface IDataList
[C#]
public interface IDataList

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IDataList Members | Cambro.Web.QuickAdmin Namespace


IDataList Members

Public Instance Properties

DataSet This is the ID of the DataLists to bind this control to

Public Instance Methods

BindDataSet This function should Bind the DataLists referenced by the DataSet property.

See Also

IDataList Interface | Cambro.Web.QuickAdmin Namespace


IDataList Properties

The properties of the IDataList class are listed below. For a complete list of IDataList class members, see the IDataList Members topic.

Public Instance Properties

DataSet This is the ID of the DataLists to bind this control to

See Also

IDataList Interface | Cambro.Web.QuickAdmin Namespace


IDataList.DataSet Property

This is the ID of the DataLists to bind this control to

[Visual Basic]
Property DataSet As String
[C#]
string DataSet {get; set;}

See Also

IDataList Interface | IDataList Members | Cambro.Web.QuickAdmin Namespace


IDataList Methods

The methods of the IDataList class are listed below. For a complete list of IDataList class members, see the IDataList Members topic.

Public Instance Methods

BindDataSet This function should Bind the DataLists referenced by the DataSet property.

See Also

IDataList Interface | Cambro.Web.QuickAdmin Namespace


IDataList.BindDataSet Method

This function should Bind the DataLists referenced by the DataSet property.

[Visual Basic]
Sub BindDataSet()
[C#]
void BindDataSet();

See Also

IDataList Interface | IDataList Members | Cambro.Web.QuickAdmin Namespace


IDate Interface

This interface should be implemented by any edit control which returns a date. It is processed so the date is formatted in the ISO Standard

[Visual Basic]
Public Interface IDate
[C#]
public interface IDate

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IDate Members | Cambro.Web.QuickAdmin Namespace


IGroupFields Interface

This interface can be implemented by any Advanced Search or Edit Control which wants to be able extract multiple fields from a linked table to display in a ListControl. The code to use the ForeignGroupFields is as follows

            "SELECT "+ForeignGroupFields+" AS ["+ForeignDataField+"],[" + ForeignKeyField + "] FROM [" + ForeignTable + "] ORDER BY [" + ForeignDataField + "]"

For a list of all members of this type, see IGroupFields Members.

[Visual Basic]
Public Interface IGroupFields
[C#]
public interface IGroupFields

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IGroupFields Members | Cambro.Web.QuickAdmin Namespace


IGroupFields Members

Public Instance Properties

ForeignGroupFields The string to be inserted into the SQL Query Select EmployeeID, LastName + ', ' + FirstName as FullName From Employees Where EmployeeID is the ForeignKeyField, LastName + ',' + FirstName is the ForeignGroupFields string, and FullName is the ForeignDataField

See Also

IGroupFields Interface | Cambro.Web.QuickAdmin Namespace


IGroupFields Properties

The properties of the IGroupFields class are listed below. For a complete list of IGroupFields class members, see the IGroupFields Members topic.

Public Instance Properties

ForeignGroupFields The string to be inserted into the SQL Query Select EmployeeID, LastName + ', ' + FirstName as FullName From Employees Where EmployeeID is the ForeignKeyField, LastName + ',' + FirstName is the ForeignGroupFields string, and FullName is the ForeignDataField

See Also

IGroupFields Interface | Cambro.Web.QuickAdmin Namespace


IGroupFields.ForeignGroupFields Property

The string to be inserted into the SQL Query Select EmployeeID, LastName + ', ' + FirstName as FullName From Employees Where EmployeeID is the ForeignKeyField, LastName + ',' + FirstName is the ForeignGroupFields string, and FullName is the ForeignDataField

[Visual Basic]
Property ForeignGroupFields As String
[C#]
string ForeignGroupFields {get; set;}

See Also

IGroupFields Interface | IGroupFields Members | Cambro.Web.QuickAdmin Namespace


ILocal Interface

Interface for Control which has its value coming from the Local Table

For a list of all members of this type, see ILocal Members.

[Visual Basic]
Public Interface ILocal
[C#]
public interface ILocal

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ILocal Members | Cambro.Web.QuickAdmin Namespace


ILocal Members

Public Instance Properties

LocalField | The Field in the Local Table to bind to
ParentAdmin | This is a reference to the Parent Admin Control. This is initialized on Page Load for every control which implements the ILocal Control.
Quotes | Boolean which specifies whether to enclose the value in Quotation Marks
Title | The Title to display next to your control

See Also

ILocal Interface | Cambro.Web.QuickAdmin Namespace


ILocal Properties

The properties of the ILocal class are listed below. For a complete list of ILocal class members, see the ILocal Members topic.

Public Instance Properties

LocalField | The Field in the Local Table to bind to
ParentAdmin | This is a reference to the Parent Admin Control. This is initialized on Page Load for every control which implements the ILocal Control.
Quotes | Boolean which specifies whether to enclose the value in Quotation Marks
Title | The Title to display next to your control

See Also

ILocal Interface | Cambro.Web.QuickAdmin Namespace


ILocal.LocalField Property

The Field in the Local Table to bind to

[Visual Basic]
Property LocalField As String
[C#]
string LocalField {get; set;}

See Also

ILocal Interface | ILocal Members | Cambro.Web.QuickAdmin Namespace


ILocal.ParentAdmin Property

This is a reference to the Parent Admin Control. This is initialized on Page Load for every control which implements the ILocal Control.

[Visual Basic]
Property ParentAdmin As Cambro.Web.QuickAdmin.Admin
[C#]
Admin ParentAdmin {get; set;}

See Also

ILocal Interface | ILocal Members | Cambro.Web.QuickAdmin Namespace


ILocal.Quotes Property

Boolean which specifies whether to enclose the value in Quotation Marks

[Visual Basic]
Property Quotes As Boolean
[C#]
bool Quotes {get; set;}

See Also

ILocal Interface | ILocal Members | Cambro.Web.QuickAdmin Namespace


ILocal.Title Property

The Title to display next to your control

[Visual Basic]
Property Title As String
[C#]
string Title {get; set;}

See Also

ILocal Interface | ILocal Members | Cambro.Web.QuickAdmin Namespace


IMany2Many Interface

The Interface should be used to implement Controls with One-Many-One Relationships

For a list of all members of this type, see IMany2Many Members.

[Visual Basic]
Public Interface IMany2Many
   Implements IOne2Many, ILocal
[C#]
public interface IMany2Many : IOne2Many, ILocal

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IMany2Many Members

Public Instance Properties

IntermediateForeignKey | The Field where the Key of the One2Many Table is stored
IntermediateLocalKey | The Field where the Key of the Local Table is stored
IntermediateTable | The 'Linking Table' of the One-Many-One Relationship

Public Instance Methods

Insert | Function which returns an ArrayList of all the values for the ForeignKeyField to be stored in the database
Remove | Function which returns an ArrayList of all the values for the ForeignKeyField to be deleted from the database

See Also

IMany2Many Interface | Cambro.Web.QuickAdmin Namespace


IMany2Many Properties

The properties of the IMany2Many class are listed below. For a complete list of IMany2Many class members, see the IMany2Many Members topic.

Public Instance Properties

IntermediateForeignKey | The Field where the Key of the One2Many Table is stored
IntermediateLocalKey | The Field where the Key of the Local Table is stored
IntermediateTable | The 'Linking Table' of the One-Many-One Relationship

See Also

IMany2Many Interface | Cambro.Web.QuickAdmin Namespace


IMany2Many.IntermediateForeignKey Property

The Field where the Key of the One2Many Table is stored

[Visual Basic]
Property IntermediateForeignKey As String
[C#]
string IntermediateForeignKey {get; set;}

See Also

IMany2Many Interface | IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IMany2Many.IntermediateLocalKey Property

The Field where the Key of the Local Table is stored

[Visual Basic]
Property IntermediateLocalKey As String
[C#]
string IntermediateLocalKey {get; set;}

See Also

IMany2Many Interface | IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IMany2Many.IntermediateTable Property

The 'Linking Table' of the One-Many-One Relationship

[Visual Basic]
Property IntermediateTable As String
[C#]
string IntermediateTable {get; set;}

See Also

IMany2Many Interface | IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IMany2Many Methods

The methods of the IMany2Many class are listed below. For a complete list of IMany2Many class members, see the IMany2Many Members topic.

Public Instance Methods

Insert | Function which returns an ArrayList of all the values for the ForeignKeyField to be stored in the database
Remove | Function which returns an ArrayList of all the values for the ForeignKeyField to be deleted from the database

See Also

IMany2Many Interface | Cambro.Web.QuickAdmin Namespace


IMany2Many.Insert Method

Function which returns an ArrayList of all the values for the ForeignKeyField to be stored in the database

[Visual Basic]
Function Insert() As System.Collections.ArrayList
[C#]
ArrayList Insert();

See Also

IMany2Many Interface | IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IMany2Many.Remove Method

Function which returns an ArrayList of all the values for the ForeignKeyField to be deleted from the database

[Visual Basic]
Function Remove() As System.Collections.ArrayList
[C#]
ArrayList Remove();

See Also

IMany2Many Interface | IMany2Many Members | Cambro.Web.QuickAdmin Namespace


IOne2Many Interface

This Interface should be implemented on Controls in Many-One Relationships

For a list of all members of this type, see IOne2Many Members.

[Visual Basic]
Public Interface IOne2Many
   Implements ILocal
[C#]
public interface IOne2Many : ILocal

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IOne2Many Members | Cambro.Web.QuickAdmin Namespace


IOne2Many Members

Public Instance Properties

ForeignDataField | The Field from the One2Many Table to extract the Text from
ForeignKeyField | The Field from the One2Many Table to extract the Primary Key from
ForeignTable | The One2Many Table

See Also

IOne2Many Interface | Cambro.Web.QuickAdmin Namespace


IOne2Many Properties

The properties of the IOne2Many class are listed below. For a complete list of IOne2Many class members, see the IOne2Many Members topic.

Public Instance Properties

ForeignDataField | The Field from the One2Many Table to extract the Text from
ForeignKeyField | The Field from the One2Many Table to extract the Primary Key from
ForeignTable | The One2Many Table

See Also

IOne2Many Interface | Cambro.Web.QuickAdmin Namespace


IOne2Many.ForeignDataField Property

The Field from the One2Many Table to extract the Text from

[Visual Basic]
Property ForeignDataField As String
[C#]
string ForeignDataField {get; set;}

See Also

IOne2Many Interface | IOne2Many Members | Cambro.Web.QuickAdmin Namespace


IOne2Many.ForeignKeyField Property

The Field from the One2Many Table to extract the Primary Key from

[Visual Basic]
Property ForeignKeyField As String
[C#]
string ForeignKeyField {get; set;}

See Also

IOne2Many Interface | IOne2Many Members | Cambro.Web.QuickAdmin Namespace


IOne2Many.ForeignTable Property

The One2Many Table

[Visual Basic]
Property ForeignTable As String
[C#]
string ForeignTable {get; set;}

See Also

IOne2Many Interface | IOne2Many Members | Cambro.Web.QuickAdmin Namespace


IResetable Interface

Interface which should be implemented by both the Advanced Controls and the Add/Edit/View Controls so they can be reset on a new search or on a click of the add button.

For a list of all members of this type, see IResetable Members.

[Visual Basic]
Public Interface IResetable
[C#]
public interface IResetable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

IResetable Members | Cambro.Web.QuickAdmin Namespace


IResetable Members

Public Instance Methods

Reset Function which resets the control

See Also

IResetable Interface | Cambro.Web.QuickAdmin Namespace


IResetable Methods

The methods of the IResetable class are listed below. For a complete list of IResetable class members, see the IResetable Members topic.

Public Instance Methods

Reset Function which resets the control

See Also

IResetable Interface | Cambro.Web.QuickAdmin Namespace


IResetable.Reset Method

Function which resets the control

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

IResetable Interface | IResetable Members | Cambro.Web.QuickAdmin Namespace


ISearchable Interface

Interface implemented by all Simple and Advanced Controls

For a list of all members of this type, see ISearchable Members.

[Visual Basic]
Public Interface ISearchable
[C#]
public interface ISearchable

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ISearchable Members | Cambro.Web.QuickAdmin Namespace


ISearchable Members

Public Instance Properties

MatchMultiplier For an exact Fuzzy Match, what score will the record get

Public Instance Methods

MakeExact | Function called to create Exact query
MakeRank | Function called to create Ranked query

See Also

ISearchable Interface | Cambro.Web.QuickAdmin Namespace


ISearchable Properties

The properties of the ISearchable class are listed below. For a complete list of ISearchable class members, see the ISearchable Members topic.

Public Instance Properties

MatchMultiplier For an exact Fuzzy Match, what score will the record get

See Also

ISearchable Interface | Cambro.Web.QuickAdmin Namespace


ISearchable.MatchMultiplier Property

For an exact Fuzzy Match, what score will the record get

[Visual Basic]
Property MatchMultiplier As Integer
[C#]
int MatchMultiplier {get; set;}

See Also

ISearchable Interface | ISearchable Members | Cambro.Web.QuickAdmin Namespace


ISearchable Methods

The methods of the ISearchable class are listed below. For a complete list of ISearchable class members, see the ISearchable Members topic.

Public Instance Methods

MakeExact | Function called to create Exact query
MakeRank | Function called to create Ranked query

See Also

ISearchable Interface | Cambro.Web.QuickAdmin Namespace


ISearchable.MakeExact Method

Function called to create Exact query

[Visual Basic]
Function MakeExact() As String
[C#]
string MakeExact();

Return Value

Example

See Also

ISearchable Interface | ISearchable Members | Cambro.Web.QuickAdmin Namespace


ISearchable.MakeRank Method

Function called to create Ranked query

[Visual Basic]
Function MakeRank() As String
[C#]
string MakeRank();

Return Value

Example

See Also

ISearchable Interface | ISearchable Members | Cambro.Web.QuickAdmin Namespace


ISetToNull Interface

This interface should be used by any edit control which in the eventuality that an empty string is returned, should allow the user to specify if it will store the value in the database as a NULL.

For a list of all members of this type, see ISetToNull Members.

[Visual Basic]
Public Interface ISetToNull
[C#]
public interface ISetToNull

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

ISetToNull Members | Cambro.Web.QuickAdmin Namespace


ISetToNull Members

Public Instance Properties

SetToNullIfEmpty Any values which are == "" are converted to nulls

See Also

ISetToNull Interface | Cambro.Web.QuickAdmin Namespace


ISetToNull Properties

The properties of the ISetToNull class are listed below. For a complete list of ISetToNull class members, see the ISetToNull Members topic.

Public Instance Properties

SetToNullIfEmpty Any values which are == "" are converted to nulls

See Also

ISetToNull Interface | Cambro.Web.QuickAdmin Namespace


ISetToNull.SetToNullIfEmpty Property

Any values which are == "" are converted to nulls

[Visual Basic]
Property SetToNullIfEmpty As Boolean
[C#]
bool SetToNullIfEmpty {get; set;}

See Also

ISetToNull Interface | ISetToNull Members | Cambro.Web.QuickAdmin Namespace


Admin.ActionType Enumeration

The ActionType exposed by myAdmin.Action This shows you which button was clicked or whether there was a postback etc...

[Visual Basic]
Public Enum Admin.ActionType
[C#]
public enum Admin.ActionType

Members

Member Name | Description
Search | Doing a Search
Reset | Doing a Reset
Add | Doing an Add
Save | Doing a Save
Cancel | Doing a Cancel
Edit | Doing an Edit
Done | Doing a Done
Delete | Doing a Delete
Update | Doing an Update
Postback | Doing a Postback
None | Done Nothing

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


Admin.Mode Enumeration

Enum Defining the modes the QuickAdmin Control can be in

[Visual Basic]
Public Enum Admin.Mode
[C#]
public enum Admin.Mode

Members

Member Name | Description
Postback | Postback Mode
Search | Search Mode
Results | Results Mode
View | View Mode
Edit | Edit Mode
Add | Add Mode
Saving | Saving Mode
Deleting | Deleting - Could end up in Results or View Mode
CancelAdding | CancelAdding - Could end up in Search or Results Mode
Unknown | Unknown Mode - either Search or Results most probably

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


Location Enumeration

Where the message should be displayed

[Visual Basic]
Public Enum Location
[C#]
public enum Location

Members

Member Name | Description
Bottom | Default render at bottom
Top | Render at top
Popup | Display in a popup

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


SearchCriteria Enumeration

Enumeration for SearchType

[Visual Basic]
Public Enum SearchCriteria
[C#]
public enum SearchCriteria

Members

Member Name | Description
Exact | Exact Search Mode
Fuzzy | Fuzzy Search Mode

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


AddingEventHandler Delegate

Handler for the OnAdding Event

[Visual Basic]
Public Delegate Sub AddingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.AddingEventArgs _
)
[C#]
public delegate void AddingEventHandler(
   object sender,
   AddingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


DeletedEventHandler Delegate

Handler for the OnDeleted Event

[Visual Basic]
Public Delegate Sub DeletedEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.DeletedEventArgs _
)
[C#]
public delegate void DeletedEventHandler(
   object sender,
   DeletedEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


DeletingEventHandler Delegate

Handler for the OnDeleting Event

[Visual Basic]
Public Delegate Sub DeletingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.DeletingEventArgs _
)
[C#]
public delegate void DeletingEventHandler(
   object sender,
   DeletingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


EditingEventHandler Delegate

Handler for the OnEditing Event

[Visual Basic]
Public Delegate Sub EditingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.EditingEventArgs _
)
[C#]
public delegate void EditingEventHandler(
   object sender,
   EditingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


InsertedEventHandler Delegate

Handler for the OnInserted Event

[Visual Basic]
Public Delegate Sub InsertedEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.InsertedEventArgs _
)
[C#]
public delegate void InsertedEventHandler(
   object sender,
   InsertedEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


InsertingEventHandler Delegate

Handler for the OnInserting Event

[Visual Basic]
Public Delegate Sub InsertingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.InsertingEventArgs _
)
[C#]
public delegate void InsertingEventHandler(
   object sender,
   InsertingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


ResettingEventHandler Delegate

Handler for the OnResetting Event

[Visual Basic]
Public Delegate Sub ResettingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.ResettingEventArgs _
)
[C#]
public delegate void ResettingEventHandler(
   object sender,
   ResettingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


SearchedEventHandler Delegate

Handler for the OnResetting Event

[Visual Basic]
Public Delegate Sub SearchedEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.SearchedEventArgs _
)
[C#]
public delegate void SearchedEventHandler(
   object sender,
   SearchedEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


SearchingEventHandler Delegate

Handler for the OnSearching Event

[Visual Basic]
Public Delegate Sub SearchingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.SearchingEventArgs _
)
[C#]
public delegate void SearchingEventHandler(
   object sender,
   SearchingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


UpdatedEventHandler Delegate

Handler for the OnUpdated Event

[Visual Basic]
Public Delegate Sub UpdatedEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.UpdatedEventArgs _
)
[C#]
public delegate void UpdatedEventHandler(
   object sender,
   UpdatedEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


UpdatingEventHandler Delegate

Handler for the OnInserting Event

[Visual Basic]
Public Delegate Sub UpdatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.UpdatingEventArgs _
)
[C#]
public delegate void UpdatingEventHandler(
   object sender,
   UpdatingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


ViewingEventHandler Delegate

Handler for the OnViewing Event

[Visual Basic]
Public Delegate Sub ViewingEventHandler( _
   ByVal sender As Object, _
   ByVal e As Cambro.Web.QuickAdmin.ViewingEventArgs _
)
[C#]
public delegate void ViewingEventHandler(
   object sender,
   ViewingEventArgs e
);

Requirements

Namespace: Cambro.Web.QuickAdmin Namespace

Assembly: Cambro.Web.QuickAdmin.dll

See Also

Cambro.Web.QuickAdmin Namespace


Cambro.Web.QuickAdminHierarchy

Cambro.Web.QuickAdmin Class Library

Cambro.Web.QuickAdmin Hierarchy

System.Object
-Control
-Advanced
-EditControl
-EditNote
-Local
-ResultsControl
-SearchControl
-Simple
-ViewControl
-WebControl
-Admin
-BaseDataList
-DataGrid
-ResultsDataGrid
-Calendar
-EditDate
-LocalBetweenDate
-LocalOnDate
-EditCheckBoxList
-EditFileUpload
-EditListBox
-ListControl
-CheckBoxList
-LocalCheckBoxList
-Many2ManyCheckBoxList
-One2ManyCheckBoxList
-DataLists
-DropDownList
-EditDropDownList
-LocalDropDownList
-Many2ManyDropDownList
-One2ManyDropDownList
-ListBox
-LocalListBox
-Many2ManyListBox
-One2ManyListBox
-RadioButtonList
-EditRadioList
-EditTrueFalse
-Many2ManyRadioButtonList
-One2ManyRadioButtonList
-LocalBetweenDateTwice
-LocalBetweenValue
-LocalTrueOrFalse
-Many2Many
-One2Many
-TextBox
-EditIntBox
-EditTextBox
-LocalIntBox
-LocalTextBox
-Many2ManyTextBox
-One2ManyTextBox
-DataGridColumn
-BoundColumn
-ResultsColumn
-HyperLinkColumn
-HyperLinkColumn
-TemplateColumn
-TemplateColumn
-Db
-EventArgs
-baseEventArgs
-AddingEventArgs
-idEventArgs
-DeletedEventArgs
-DeletingEventArgs
-EditingEventArgs
-InsertedEventArgs
-UpdatedEventArgs
-UpdatingEventArgs
-ViewingEventArgs
-InsertingEventArgs
-ResettingEventArgs
-SearchedEventArgs
-SearchingEventArgs
-StrMan

Interfaces

IBindable
IDataList
IDate
IGroupFields
ILocal
IMany2Many
IOne2Many
IResetable
ISearchable
ISetToNull